Contribute
Register

Stork's MyHero II Build: ASUS ROG MAXIMUS Z370 HERO X - i7-8700K - AMD RX 580

Stork

Admin
Staff member
Joined
Sep 21, 2010
Messages
12,963
Motherboard
ASUS ROG MAXIMUS X HERO Z370
CPU
i7-8700K
Graphics
RX 580
Mac
MacBook Pro, Mac mini, Mac Pro
Classic Mac
Power Mac, PowerBook
Mobile Phone
iOS
Hi Stork,

I'm sorry, the .dsl file I attached last week had a typo, the new .dsl file should work / should make a good template.

Kind regards,

Chimiel
I did start looking into creating a SSDT-USB. I discovered from your Post #907 that my case's Front Panel USB 2/3 use a USB 2 motherboard connector. (Long Story.) So, your SSDT might need to be modified by other users, such as myself, for their case's Front Panel USB ports. I'm visiting family right now, and I'll post my results in a couple of weeks.
 
Joined
May 30, 2012
Messages
22
Motherboard
ASUS Z370 ROG MAXIMUS X HERO
CPU
I9 9900K
Graphics
Vega 56
Mac
MacBook Pro
Classic Mac
Centris, LC, Performa, Power Mac, Quadra
Mobile Phone
iOS
Hey, I'm using 1901 from day one. iGPU MultiMonitor is an option in BIOS. What would you like to know?
Hello. I also use a Hero X. Where did you get the 1901 BIOS? My 1901 19/04/11 lastest download from Asus webpage does not have theses iGPU options at all. No idea why. Would you mind to post/attach your BIOS file here. Thanks
 
Joined
Jul 7, 2017
Messages
16
Motherboard
ASUS Z370 MAXIMUS HERO X
CPU
i7-8700K
Graphics
RX580
Mac
MacBook Pro
Mobile Phone
iOS

Attachments

Joined
May 30, 2012
Messages
22
Motherboard
ASUS Z370 ROG MAXIMUS X HERO
CPU
I9 9900K
Graphics
Vega 56
Mac
MacBook Pro
Classic Mac
Centris, LC, Performa, Power Mac, Quadra
Mobile Phone
iOS
Many thanks. Somethings must be wrong then. I give it a second try.
 
Joined
May 30, 2012
Messages
22
Motherboard
ASUS Z370 ROG MAXIMUS X HERO
CPU
I9 9900K
Graphics
Vega 56
Mac
MacBook Pro
Classic Mac
Centris, LC, Performa, Power Mac, Quadra
Mobile Phone
iOS
I think this is not what we need. You need to enable IGPU and have also an option to use PEG as main GC. This is not available. What we use here, is a dedicated Graphiccard plus the use of the internal GPU in the background. Same as apple does. Therefore you can´t see the post at start on an monitor connected to the main graphiccard only. On all other boards you have the choice where you connect the mainmonitor and still have igpu enabled.
 
Joined
Sep 20, 2012
Messages
44
Motherboard
ASUS ROG MAXIMUS HERO X Z370
CPU
i9-9900K
Graphics
RX 580
Mac
iMac
Mobile Phone
iOS
Hello. I also use a Hero X. Where did you get the 1901 BIOS? My 1901 19/04/11 lastest download from Asus webpage does not have theses iGPU options at all. No idea why. Would you mind to post/attach your BIOS file here. Thanks
Very strange, me neither
 
Joined
Jan 3, 2019
Messages
11
Motherboard
ASUS ROG MAXIMUS HERO X Z370
CPU
i7-8700K
Graphics
RX 580
@Stork A new Bios update for the Maximus X Hero has come out have you updated your bios to it?
Any issues?

ROG MAXIMUS X HERO BIOS 1901
- Updated uCode for the latest Intel processor.
 
Joined
Sep 20, 2012
Messages
44
Motherboard
ASUS ROG MAXIMUS HERO X Z370
CPU
i9-9900K
Graphics
RX 580
Mac
iMac
Mobile Phone
iOS
Yeah... don't know what's going on, all I can say is it is there on mine, and that attached file is the one I used to update my BIOS.
Asus released a new BIOS today, version 2003;


The PEG option as primary display is available again.
 

Attachments

Last edited:
Joined
Sep 20, 2012
Messages
44
Motherboard
ASUS ROG MAXIMUS HERO X Z370
CPU
i9-9900K
Graphics
RX 580
Mac
iMac
Mobile Phone
iOS
Hi Stork,

Could you please share some wisdom;
I was wondering if I need to enable iGPU + dGPU, or can I just use the dGPU / RX 580 ?
Do I lose functions or performance in Mojave, not using the iGPU ?

I have a dual boot system (Windows and OS X),
Asus is advising against it to use iGPU + dGPU in Windows, graphics performance will suffer doing so.

My BIOS settings are:
- Advanced/System Agent (SA) Configuration/Graphics Configuration/Primary Display – PEG
- Advanced/System Agent (SA) Configuration/Graphics Configuration/iGPU Multi-Monitor – disabled

I also did not 'Inject Intel' in Clover Configurator > Graphics.

Thanks in advance,

Kind regards
 
Top