Contribute
Register

Stork's MyHero II Build: ASUS ROG MAXIMUS Z370 HERO X - i7-8700K - AMD RX 580

Joined
Jul 20, 2016
Messages
33
Motherboard
ASUS Z370 MAXIMUS HERO X
CPU
i7-8700
Graphics
RX 580
Mac
iMac, Mac mini
Classic Mac
SE/30
Mobile Phone
Android
Hello @Stork,
I'm successfully using my ROG MAXIMUS X HERO with macOS 10.14.3 thanks to your guide!
In addition to what you wrote I created my config.plist starting from a Cofee Lake template template done by another guy on a different forum (that I dunno if can be mentioned here). I also created 2 DSDT for both USB energy fix and limit.

Additionally I updated Lilu, whatevergreen and other kext with KextBeast and system is running fine.
Not having a Saphire Pulse GPU (but a MSI) I didn't make the change framebuffer to Orinico - yet.

Now I'm trying to plan my update macOS to 10.14.5 (or later).

Do you plan to create an update post to suggest how to proceed with those upgrade? I read for example that USB port limit is not required anymore..

Thank you again for the great guide and for the support that you might give me :)
 

Stork

Admin
Staff member
Joined
Sep 21, 2010
Messages
13,354
Motherboard
ASUS ROG MAXIMUS X HERO Z370
CPU
i7-8700K
Graphics
RX 580
Mac
MacBook Pro, Mac mini, Mac Pro
Classic Mac
Power Mac, PowerBook
Mobile Phone
iOS
@blackdir, I updated using my instructions in Post #2 of the macOS 10.14.5 Update thread in the OS X Updates forum section. See

I'll update the OP shortly. Thanks for the reminder.
 
Joined
Oct 29, 2013
Messages
31
Motherboard
Asus Maximus VIII Hero
CPU
i7-6700k
Graphics
GTX 980
Mac
iMac, MacBook, MacBook Pro, Mac mini
Mobile Phone
iOS
@stork6220 My hackintosh had been abruptly shutting down without any warning since I moved to RX 580 from NVidia. I switched the power supply out to a new one and same thing with the UPS I have connected.

My next doubt was that the new GPU is running hot, and I wanted the temp info. I ended up installing HWSensors. I was still not seeing my GPU temps in HWMonitor, and I had lost the audio. My HDMI audio works fine but my onboard (internal) stopped showing up.

I did the dumbest thing ever since I didn't know how to remove HWSensors. I deleted all FakeSMC files from .../Clover/kext/other/ and /S/L/E/. Now the system won't boot!

I created a UniBeast USB so I can boot the system from the Clover on it. Is that the right thing to do? I can't get the USB Clover to show up even on selecting it as a boot device. It always shows my system Clover. I created UEFI mode UniBeast. Should I switch it to legacy?
 
Joined
Oct 29, 2013
Messages
31
Motherboard
Asus Maximus VIII Hero
CPU
i7-6700k
Graphics
GTX 980
Mac
iMac, MacBook, MacBook Pro, Mac mini
Mobile Phone
iOS
I was able to solve the issue. Posting here in case someone stumbles on this thread.

Make sure the UniBeast USB is UEFI. Have UEFI mode enabled in BIOS. Make sure to select GUID when formatting the drive. Not the default MBR.

This allowed me to boot from UniBeast. I selected to boot from Mojave System from that screen. Once into the system, ran MultiBeast and installed FakeSMC, FakeSMC plugins and HWMonitor. While I was at it, I installed AppleALC as well. Once done, remove the USB drive, reboot into Mojave and voila!

Audio works. All sensors work and the system is back to normal (almost).
 
Joined
Sep 20, 2012
Messages
74
Motherboard
ASUS ROG MAXIMUS HERO X Z370
CPU
i9-9900K
Graphics
RX 580
Mac
iMac
Mobile Phone
iOS
@Chimiel, Great! I was going to create an USB SSDT using @UtterDisbelief's guide, but hadn't "gotten 'round to it". I'll try your USB SSDT out, and update the OP with credit to you.
Hi Stork,

I'm sorry, the .dsl file I attached last week had a typo, the new .dsl file should work / should make a good template.

Kind regards,

Chimiel
 

Attachments

Last edited:

Stork

Admin
Staff member
Joined
Sep 21, 2010
Messages
13,354
Motherboard
ASUS ROG MAXIMUS X HERO Z370
CPU
i7-8700K
Graphics
RX 580
Mac
MacBook Pro, Mac mini, Mac Pro
Classic Mac
Power Mac, PowerBook
Mobile Phone
iOS
Hi Stork,

I'm sorry, the .dsl file I attached last week had a typo, the new .dsl file should work / should make a good template.

Kind regards,

Chimiel
I did start looking into creating a SSDT-USB. I discovered from your Post #907 that my case's Front Panel USB 2/3 use a USB 2 motherboard connector. (Long Story.) So, your SSDT might need to be modified by other users, such as myself, for their case's Front Panel USB ports. I'm visiting family right now, and I'll post my results in a couple of weeks.
 
Joined
May 30, 2012
Messages
22
Motherboard
ASUS Z370 ROG MAXIMUS X HERO
CPU
I9 9900K
Graphics
Vega 56
Mac
MacBook Pro
Classic Mac
Centris, LC, Performa, Power Mac, Quadra
Mobile Phone
iOS
Hey, I'm using 1901 from day one. iGPU MultiMonitor is an option in BIOS. What would you like to know?
Hello. I also use a Hero X. Where did you get the 1901 BIOS? My 1901 19/04/11 lastest download from Asus webpage does not have theses iGPU options at all. No idea why. Would you mind to post/attach your BIOS file here. Thanks
 
Joined
Jul 7, 2017
Messages
49
Motherboard
ASUS Z370 MAXIMUS HERO X
CPU
i7-8700K
Graphics
RX580
Mac
MacBook Pro
Mobile Phone
iOS

Attachments

Joined
May 30, 2012
Messages
22
Motherboard
ASUS Z370 ROG MAXIMUS X HERO
CPU
I9 9900K
Graphics
Vega 56
Mac
MacBook Pro
Classic Mac
Centris, LC, Performa, Power Mac, Quadra
Mobile Phone
iOS
Many thanks. Somethings must be wrong then. I give it a second try.
 
Top