Contribute
Register

Stork's MyHero II Build: ASUS ROG MAXIMUS Z370 HERO X - i7-8700K - AMD RX 580

Stork

Admin
Staff member
Joined
Sep 21, 2010
Messages
12,693
Motherboard
ASUS ROG MAXIMUS X HERO Z370
CPU
i7-8700K
Graphics
RX 580
Mac
MacBook Pro, Mac mini, Mac Pro
Classic Mac
Power Mac, PowerBook
Mobile Phone
iOS
@oklhost, I don't have any problems with fan speeds, either case fans, processor fan or graphics card. I've never had to adjust fans' speeds so I can't advise you. I recommend you post your question in the General Help forum section.
 

Stork

Admin
Staff member
Joined
Sep 21, 2010
Messages
12,693
Motherboard
ASUS ROG MAXIMUS X HERO Z370
CPU
i7-8700K
Graphics
RX 580
Mac
MacBook Pro, Mac mini, Mac Pro
Classic Mac
Power Mac, PowerBook
Mobile Phone
iOS
High Sierra. sorry for the delay, I'm in grad school. thanks for your help.
Been there, done that. :D

Boot to the Desktop, then About This Mac and click on the Version to get your build number. Then get the correct Nvidia driver from the tonymacx86 Downloads menu.

Hopefully, this will get you squared away.
 
Joined
Nov 4, 2013
Messages
24
Motherboard
Asus ROG Maximus X Hero (Wi-fi AC)
CPU
i7-8700K
Graphics
GTX 1080 Ti
Mac
iMac
Mobile Phone
iOS
Been there, done that. :D

Boot to the Desktop, then About This Mac and click on the Version to get your build number. Then get the correct Nvidia driver from the tonymacx86 Downloads menu.

Hopefully, this will get you squared away.
I have the correct drivers for my build but I can only get into the desktop by booking in to -s then exiting. magically it loads the desktop with working webdrivers and the correct info for the graphics card. I just can't get past the boot loader. it is stuck in the image attached if I try to load as normal.

have I not injected a kext correctly?
 

Attachments

Stork

Admin
Staff member
Joined
Sep 21, 2010
Messages
12,693
Motherboard
ASUS ROG MAXIMUS X HERO Z370
CPU
i7-8700K
Graphics
RX 580
Mac
MacBook Pro, Mac mini, Mac Pro
Classic Mac
Power Mac, PowerBook
Mobile Phone
iOS
I have the correct drivers for my build but I can only get into the desktop by booking in to -s then exiting. magically it loads the desktop with working webdrivers and the correct info for the graphics card. I just can't get past the boot loader. it is stuck in the image attached if I try to load as normal.

have I not injected a kext correctly?
@pastrychef can you add anything to help @mstemp?
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
8,589
Motherboard
Asus ROG Strix Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Vega 56 + UHD 630
Mac
MacBook, Mac Pro
Classic Mac
iBook, Power Mac, PowerBook
Mobile Phone
iOS
I have the correct drivers for my build but I can only get into the desktop by booking in to -s then exiting. magically it loads the desktop with working webdrivers and the correct info for the graphics card. I just can't get past the boot loader. it is stuck in the image attached if I try to load as normal.

have I not injected a kext correctly?
You have the gIOScreenLockState 3 error. That's a graphics error.

If you currently have IGPU enabled, disable it in BIOS and see if you still have the error.
If the error is gone after disabling IGPU in BIOS, then you probably have IGPU configured incorrectly.
If the error persists even after disabling IGPU in BIOS, the error is due to Nvidia drivers.
 
Joined
Jul 7, 2017
Messages
7
Motherboard
ASUS Z370 MAXIMUS HERO X
CPU
i7-8700K
Graphics
RX580
Mac
MacBook Pro
Mobile Phone
iOS
@Stork Thank you for this amazing tutorial.

I'm building the following:

ASUS Maximus X Hero (no wifi)
Core i7-8700K
Sapphire RX 580 8GB Pulse (purchased)
Samsung 970 PRO 512GB NVMe (purchased)
Samsung 860 EVO 500GB SSD (purchased)
WD Black 1TB (purchased)
Corsair H55 (purchased)
Corsair RM750X

The thing is, I'm trying to have a more future-proof build, specially when it comes to the motherboard, for that reason I was thinking about changing the X Hero for a XI Hero. Have you personally done any tests on that one? I read a lot of articles here, but the ones I found were of people using the XI Hero with an i9-9900, which is not my case. I'd still be using the i7-8700K. I've report of freezes and some things not working properly. Do you have any information on that?

Do you think it'll be possible to have an XI Hero + i7-8700K build working perfectly, like the one you have with the combo X Hero + i7-8700K?

Thanks.
 
Last edited:

Stork

Admin
Staff member
Joined
Sep 21, 2010
Messages
12,693
Motherboard
ASUS ROG MAXIMUS X HERO Z370
CPU
i7-8700K
Graphics
RX 580
Mac
MacBook Pro, Mac mini, Mac Pro
Classic Mac
Power Mac, PowerBook
Mobile Phone
iOS
@ed.stein, MyHero II will sustain me for quite years to come. My other older builds (Gene and MyHero) are still performing well for me. However, I don't play games nor use Final Cut Pro or Adobe products. So, unless you are using your HERO professionally, I'd wait until next year when Intel's processors take a real jump up in performance.
 
Joined
Jul 7, 2017
Messages
7
Motherboard
ASUS Z370 MAXIMUS HERO X
CPU
i7-8700K
Graphics
RX580
Mac
MacBook Pro
Mobile Phone
iOS
@Stork thanks. I do use it professionally, but for development. I also don't use my computer to play games. The graphics card was bought mainly for compatibility, as I've been reading here. I currently own a mid-2014 MBP i7 but now I need 32GB and can't afford $2900 for that...

I'll stick with the X Hero then, thanks for your input.
 
Joined
Sep 20, 2012
Messages
24
Motherboard
ASUS ROG MAXIMUS HERO X Z370
CPU
i9-9900
Graphics
RX 580
Mac
iMac
Mobile Phone
iOS
Hi Stork,

I just gave MultiBeast 11.2.0 a try and update system definition from 14,2 to 19,1 (I have a i9-9900K)
After a restart the updated clover bootscreen appeared and after a boot into Mojave the stop sign appeared.
Do you happen to know if our system is compatible for SMBIOs 19,1 and should I make other changes to do so ?

Kind regards,

Michiel
 
Top