Contribute
Register

Stork's MyHero II Build: ASUS ROG MAXIMUS Z370 HERO X - i7-8700K - AMD RX 580

Joined
Aug 5, 2015
Messages
54
Motherboard
Gigabyte GA-Z97X-UD7 TH
CPU
i7-4790K
Graphics
GTX 950
Is the USB-C on the maximus x hero Thunderbolt capable? I just got an adapter for a Thunderbolt audio interface, but I can't seem to get it working. I looked around but I can't seem to find any info on it. Are there any other work arounds? Thanks!
 
Joined
May 29, 2016
Messages
18
Motherboard
ASUS PRIME H270M-PLUS
CPU
i7 7700k
Graphics
AMD Radeon 580 Pulse 8GB
Mobile Phone
iOS
No, it isn’t. USB C and thunderbolt aren’t the same thing. They just share the same connector.
Is the USB-C on the maximus x hero Thunderbolt capable? I just got an adapter for a Thunderbolt audio interface, but I can't seem to get it working. I looked around but I can't seem to find any info on it. Are there any other work arounds? Thanks!
 
Joined
Oct 25, 2012
Messages
55
Motherboard
ASUS ROG MAXIMUS X HERO
CPU
i5-8400
Graphics
RX 580
Is anyone here having problem with sleep/have sleep work 100%? I have this build almost exactly, but every time I put the computer to sleep, it wakes itself up about 20 seconds later. The fans spin down, it gets to sleep and then *click* it wakes itself up again!
I had this problem before. In my case was the PCI Bluetooth/Wifi card.
 
Joined
May 29, 2016
Messages
18
Motherboard
ASUS PRIME H270M-PLUS
CPU
i7 7700k
Graphics
AMD Radeon 580 Pulse 8GB
Mobile Phone
iOS
I had this problem before. In my case was the PCI Bluetooth/Wifi card.
Interesting. How did you narrow it down to that in the end? I've been using {pmset -g log} to have a poke around and see if anything stands out, but it doesn't make a great deal of sense to me.
 
Joined
Oct 25, 2012
Messages
55
Motherboard
ASUS ROG MAXIMUS X HERO
CPU
i5-8400
Graphics
RX 580
Interesting. How did you narrow it down to that in the end? I've been using {pmset -g log} to have a poke around and see if anything stands out, but it doesn't make a great deal of sense to me.
I tested by disconnecting the PCI card and sleeps returned to normal, then I reconnect it and it was broke again. The thing I don't remember exactly is if just by disconnecting internal usb port that connects to the Bluetooth module was enough to fix the problem. I ended buying a new card and I did't have this problem again.
 
Joined
May 29, 2016
Messages
18
Motherboard
ASUS PRIME H270M-PLUS
CPU
i7 7700k
Graphics
AMD Radeon 580 Pulse 8GB
Mobile Phone
iOS
I tested by disconnecting the PCI card and sleeps returned to normal, then I reconnect it and it was broke again. The thing I don't remember exactly is if just by disconnecting internal usb port that connects to the Bluetooth module was enough to fix the problem. I ended buying a new card and I did't have this problem again.
Yeah, I pulled the USB cable out of the motherboard and the computer was able to sleep. It's strange because I'm sure I'd mapped that port as 'internal', but I guess I'm doing it wrong!
 
Joined
Apr 28, 2015
Messages
78
Motherboard
Asus Maximus X Hero
CPU
i9-9900K
Graphics
Vega 64
@Stork I'm having an issue with my Maximus X Hero build, specifically in the BIOS. Under the latest BIOS 1704, I no longer have the ability to select a "Primary Display" under system agent configuration. Are you running BIOS 1704 on your build? And if you are, could you tell me if you are able to still select a primary display? I've attached a few screenshots from my BIOS where the "Primary Display" option used to be, but is no longer present. I'm trying to figure out if this is specific to my build with the 9900K. It's a real problem because I once I enable the internal graphics, I cannot select PEG as the primary like I have in the past, and the BIOS seems to default to the IGFX as primary once internal graphics are enabled. So I can't see POST, get into the BIOS, etc.

 
Joined
Jan 12, 2018
Messages
22
Motherboard
MSI Z370-A PRO
CPU
i7-8700K
Graphics
RX 580
I have the Sapphire Nitro+ Limited Edition with RX 580, currently running 10.14.2, but the graphics are quite laggy. What do I need to check? The GPU is recognized by the OS. Thank you for all the help you give:)
 

Stork

Admin
Staff member
Joined
Sep 21, 2010
Messages
13,449
Motherboard
ASUS ROG MAXIMUS X HERO Z370
CPU
i7-8700K
Graphics
RX 580
Mac
MacBook Pro, Mac mini, Mac Pro
Classic Mac
Power Mac, PowerBook
Mobile Phone
iOS
I have the Sapphire Nitro+ Limited Edition with RX 580, currently running 10.14.2, but the graphics are quite laggy. What do I need to check? The GPU is recognized by the OS. Thank you for all the help you give:)
Are you using Luli and WhatEverGreen kexts? If so, then I'm at a loss for a solution.
 
Top