Contribute
Register

Stork's MyHero II Build: ASUS ROG MAXIMUS Z370 HERO X - i7-8700K - AMD RX 580 - Thunderbolt 3

Joined
Aug 5, 2015
Messages
53
Motherboard
Gigabyte GA-Z97X-UD7 TH
CPU
i7-4790K
Graphics
GTX 950
Hey @pastrychef any advice you can offer trying to use internal graphics on this Asus Rog Maximus Z370 Hero X? Its a little glitchy currently, and I'm not sure if I have to install a different kext/configuration like "Inject HD 6xx"

Thanks!
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
16,733
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Vega 56 (Bios flashed to 64)
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
Hey @pastrychef any advice you can offer trying to use internal graphics on this Asus Rog Maximus Z370 Hero X? Its a little glitchy currently, and I'm not sure if I have to install a different kext/configuration like "Inject HD 6xx"

Thanks!

Are you trying to use the IGPU in conjunction with your GTX 950 or are you trying to use ONLY the IGPU? Are you using High Sierra or Mojave?

Please post your EFI folder.
 
Joined
Jan 20, 2018
Messages
132
Motherboard
ASUS ROG MAXIMUS X HERO Z370
CPU
i7-8086K
Graphics
Vega 56
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
Mobile Phone
  1. iOS
Sleep is broken again, what am I doing wrong?
 

Attachments

  • config.plist
    6.5 KB · Views: 95
  • SSDT-UIAC.aml
    659 bytes · Views: 28

Stork

Admin
Staff member
Joined
Sep 21, 2010
Messages
13,631
Motherboard
Asus ProArt Z490 Creator
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Pro
  2. Mac mini
  3. Mac Pro
Classic Mac
  1. Power Mac
  2. PowerBook
Mobile Phone
  1. iOS
Sleep is broken again, what am I doing wrong?
Nothing jumps out at me when I look at your config.plist file. However, I don't use a SSDT-USB, yet, so I can't comment on it. Maybe @pastrychef can take a look. He has much more experience in solving this type of problem.
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
16,733
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Vega 56 (Bios flashed to 64)
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
Sleep is broken again, what am I doing wrong?

I can't tell if the SSDT is correct because I don't know how the ports are mapped.

You haven't enabled CPU power management. To do so, enable PluginType:
Screen Shot 2018-11-13 at 12.28.13 PM.png
 
Joined
Jan 20, 2018
Messages
132
Motherboard
ASUS ROG MAXIMUS X HERO Z370
CPU
i7-8086K
Graphics
Vega 56
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
Mobile Phone
  1. iOS
Thank you.
I just did enable PluginType

Same result :(
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
16,733
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Vega 56 (Bios flashed to 64)
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
Joined
Jan 20, 2018
Messages
132
Motherboard
ASUS ROG MAXIMUS X HERO Z370
CPU
i7-8086K
Graphics
Vega 56
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
Mobile Phone
  1. iOS
It’s going to sleep, and restart’s again, doesn't stay in sleep mode
 
Joined
Sep 27, 2010
Messages
35
Motherboard
ASUS Z370 ROG MAXIMUS X HERO
CPU
i7-8700K
Graphics
RX VEGA 56
Mac
  1. MacBook
  2. MacBook Air
  3. MacBook Pro
  4. Mac mini
Mobile Phone
  1. iOS
Yes, you can use the VGTab utility to customize the fan speeds and then create a kext that will fix the fans. You can find the VGTab utility attached to post #1 of my Z370 build thread. Link is below in my signature.
@pastrychef I updated to OSX 10.14.1 and removed my VegaTab_56.kext from /L/E and the fans seem to run quietly now. Have you tried this?
 
Top