Contribute
Register

Stork's MyHero II Build: ASUS ROG MAXIMUS Z370 HERO X - i7-8700K - AMD RX 580 - Thunderbolt 3

Joined
Jul 7, 2010
Messages
129
Motherboard
ASUS ROG MAXIMUS HERO X Z370
CPU
i9-9900KS
Graphics
RX 580
Mac
  1. MacBook Air
Classic Mac
  1. PowerBook
Mobile Phone
  1. iOS
Am running a very similar build to you (thanks for the guide Stork) and have the Syba FW card advised on page 1 in the first slot PCIe x1_1above my graphics board. Worked out of the box for me with an Avid 003 connected on the 400 port and also running hard drives from the 800 port on an 800 to 400 adapter.
 
Joined
Jan 6, 2015
Messages
7
Motherboard
Asus Maximus Hero X
CPU
i7 8700k
Graphics
GTX 960
Mac
  1. Mac Pro
Mobile Phone
  1. iOS
This is what i have =(
Screen Shot 2018-06-12 at 11.16.25 AM.png Screen Shot 2018-06-12 at 11.16.39 AM.png

No fw.. PCI is only graphic.. Still didnt find solution... FW works on diferent OS (Win).
 

Stork

Admin
Staff member
Joined
Sep 21, 2010
Messages
13,204
Motherboard
Gigabyte Z690 Aero G
CPU
i5-12600K
Graphics
RX 6800 XT
Mac
  1. MacBook Pro
  2. Mac mini
  3. Mac Pro
Classic Mac
  1. Power Mac
  2. PowerBook
Mobile Phone
  1. iOS
Hmmm, that's interesting, especially the System Report > Hardware > PCI which shows your graphics card. My Report does not show my graphics in the PCI area, only in the Hardward > Graphics/Displays.

Are you running the latest BIOS? What version of macOS?

I'm puzzled. I only thing I can think to do is to move it to another PCIe slot. Try several PCIe slots.
 
Joined
Jun 6, 2018
Messages
34
Motherboard
ASUS ROG LGA1151 DDR4
CPU
Intel Core i5-8600K
Graphics
EVGA GeForce GTX 1070 SC
Awesome write-up, thanks for the info.

I am having a terrible time with the USB 3.0 situation. I have one on the motherboard that is operational as a 3.0 but the others only read 2.0. I feel that I followed your directions carefully. In regards to the text swap out in the KernelAndKextPatches, the original text was not present in the place you had mentioned. I typed in the swap and still no luck. Any ideas would be greatly appreciated.
 

Stork

Admin
Staff member
Joined
Sep 21, 2010
Messages
13,204
Motherboard
Gigabyte Z690 Aero G
CPU
i5-12600K
Graphics
RX 6800 XT
Mac
  1. MacBook Pro
  2. Mac mini
  3. Mac Pro
Classic Mac
  1. Power Mac
  2. PowerBook
Mobile Phone
  1. iOS
Awesome write-up, thanks for the info.

I am having a terrible time with the USB 3.0 situation. I have one on the motherboard that is operational as a 3.0 but the others only read 2.0. I feel that I followed your directions carefully. In regards to the text swap out in the KernelAndKextPatches, the original text was not present in the place you had mentioned. I typed in the swap and still no luck. Any ideas would be greatly appreciated.
Check your PMHeart patch carefully. See if you can open it in Xcode or PlistEditPro. Or Clover Configurator. You probably have a hidden character that causing the patch not to work.
 
Joined
Jun 6, 2018
Messages
34
Motherboard
ASUS ROG LGA1151 DDR4
CPU
Intel Core i5-8600K
Graphics
EVGA GeForce GTX 1070 SC
Check your PMHeart patch carefully. See if you can open it in Xcode or PlistEditPro. Or Clover Configurator. You probably have a hidden character that causing the patch not to work.





This is exactly what I have

<dict>
<key>Comment</key>
<string>USB 10.13.4+ by PMHeart</string>
<key>Disabled</key>
<false/>
<key>Find</key>
<data>
g32UDw+DlwQAAA==
</data>
<key>InfoPlistPatch</key>
<false/>
<key>MatchOS</key>
<string>10.13.x</string>
<key>Name</key>
<string>com.apple.driver.usb.AppleUSBXHCI</string>
<key>Replace</key>
<data>
g32UD5CQkJCQkA==
</data>
</dict>
 
Joined
Jun 6, 2018
Messages
34
Motherboard
ASUS ROG LGA1151 DDR4
CPU
Intel Core i5-8600K
Graphics
EVGA GeForce GTX 1070 SC
Erased
 
Last edited:
Joined
Jun 6, 2018
Messages
34
Motherboard
ASUS ROG LGA1151 DDR4
CPU
Intel Core i5-8600K
Graphics
EVGA GeForce GTX 1070 SC
Check your PMHeart patch carefully. See if you can open it in Xcode or PlistEditPro. Or Clover Configurator. You probably have a hidden character that causing the patch not to work.



Here is a better shot




<dict>
<key>#FakeCPUID</key>
<string>0x010676</string>
<key>AppleIntelCPUPM</key>
<true/>
<key>AppleRTC</key>
<true/>
<key>KernelCpu</key>
<false/>
<key>KernelLapic</key>
<false/>
<key>KernelPm</key>
<true/>
<key>KextsToPatch</key>
<array>
<dict>
<key>Comment</key>
<string>External icons patch</string>
<key>Find</key>
<data>
RXh0ZXJuYWw=
</data>
<key>Name</key>
<string>AppleAHCIPort</string>
<key>Replace</key>
<data>
SW50ZXJuYWw=
</data>
</dict>
<dict>
<key>Comment</key>
<string>USB 10.13.4+ by PMHeart</string>
<key>Disabled</key>
<false/>
<key>Find</key>
<data>
g32UDw+DlwQAAA==
</data>
<key>InfoPlistPatch</key>
<false/>
<key>MatchOS</key>
<string>10.13.x</string>
<key>Name</key>
<string>com.apple.driver.usb.AppleUSBXHCI</string>
<key>Replace</key>
<data>
g32UD5CQkJCQkA==
</data>
</dict>
<dict>
<key>Comment</key>
<string>Unsupported_Audio_Device_ID_Kaby_Lake</string>
<key>Find</key>
<data>
PXCh
</data>
<key>Name</key>
<string>AppleHDAController</string>
<key>Replace</key>
<data>
PfCi
</data>
</dict>
</array>
 

Stork

Admin
Staff member
Joined
Sep 21, 2010
Messages
13,204
Motherboard
Gigabyte Z690 Aero G
CPU
i5-12600K
Graphics
RX 6800 XT
Mac
  1. MacBook Pro
  2. Mac mini
  3. Mac Pro
Classic Mac
  1. Power Mac
  2. PowerBook
Mobile Phone
  1. iOS
Here is a better shot




<dict>
<key>#FakeCPUID</key>
<string>0x010676</string>
<key>AppleIntelCPUPM</key>
<true/>
<key>AppleRTC</key>
<true/>
<key>KernelCpu</key>
<false/>
<key>KernelLapic</key>
<false/>
<key>KernelPm</key>
<true/>
<key>KextsToPatch</key>
<array>
<dict>
<key>Comment</key>
<string>External icons patch</string>
<key>Find</key>
<data>
RXh0ZXJuYWw=
</data>
<key>Name</key>
<string>AppleAHCIPort</string>
<key>Replace</key>
<data>
SW50ZXJuYWw=
</data>
</dict>
<dict>
<key>Comment</key>
<string>USB 10.13.4+ by PMHeart</string>
<key>Disabled</key>
<false/>
<key>Find</key>
<data>
g32UDw+DlwQAAA==
</data>
<key>InfoPlistPatch</key>
<false/>
<key>MatchOS</key>
<string>10.13.x</string>
<key>Name</key>
<string>com.apple.driver.usb.AppleUSBXHCI</string>
<key>Replace</key>
<data>
g32UD5CQkJCQkA==
</data>
</dict>
<dict>
<key>Comment</key>
<string>Unsupported_Audio_Device_ID_Kaby_Lake</string>
<key>Find</key>
<data>
PXCh
</data>
<key>Name</key>
<string>AppleHDAController</string>
<key>Replace</key>
<data>
PfCi
</data>
</dict>
</array>
Can't tell anything about the format. Did you try to open your config.plist in Xcode or PlistEditPro?
 
Top