Contribute
Register

Stork's MyHero II Build: ASUS ROG MAXIMUS Z370 HERO X - i7-8700K - AMD RX 580 - Thunderbolt 3

Joined
Jul 7, 2010
Messages
130
Motherboard
ASUS ROG MAXIMUS HERO X Z370
CPU
i9-9900KS
Graphics
RX 580
Mac
  1. MacBook Air
Classic Mac
  1. PowerBook
Mobile Phone
  1. iOS
Hello to all,
I haven't written here for a long time, for various reasons, but mostly because I didn't have much to say. I have limited myself to reading a little something seldom.
Until yesterday, Catalina was my faithful travel companion, despite being among the first to install Big Sur just released.
Yesterday I decided to try to move to Big Sur as a very late adopter, but in the end the temptation of Monterey was such to lead me to give him and salt the number 11 on foot.
So with a short post I share with those who still did not have the desire, courage or interest to try the 12, which can be done on this configuration (mine is upgraded, but with upgrades that as demonstrated in the past, make no difference in terms of working configuration, except for details).
I have to thank c0c0p0ps for sharing his config, from which I started to create an EFI Frankestine, mixing it with mine and that in the miliuco guide for Monterey here on the forum for Clover (5138 at the moment)
EFI Frankenstine at the moment said significantly that the Kext must be updated to at least get this far.
I have a lot to work to fix everything and bring it to the levels of reliability guaranteed at his time by Stork with the first installation guide for Mojave and then continued, as far as I'm concerned with Catalina until today, since the super early adoption.
In short, to start it starts, (in configuration 1.1), even if very patched and quirked for the moment ... I'll let you know ...
I cloned the Catalina disk and then upgraded it to Monterey and had never seen the idle CPU load drop to 0.28 before ...

Bye
Hey @Simon70 That is good to hear that you have got it booting in Monterey already as I am sure it will only be a few weeks till release now. I would be interested to see what changes you had to make to the Clover config as I am also running an i9-9900 in this board along with a Titan Ridge flashed Thunderbolt card.

In fact since I posted that config I have updated mine and BIOS settings to enable AppleVTD as outlined here https://www.tonymacx86.com/threads/...olt-3-i7-9700k-amd-rx-580.267551/post-2261811
 
Joined
Jan 23, 2019
Messages
187
Motherboard
ASUS ROG MAXIMUS Z370 HERO X
CPU
i9-9900K
Graphics
Radeon VII
Hey @Simon70 That is good to hear that you have got it booting in Monterey already as I am sure it will only be a few weeks till release now. I would be interested to see what changes you had to make to the Clover config as I am also running an i9-9900 in this board along with a titan ridge flashed thunderbolt card.

In fact since I posted that config I have updated mine and BIOS settings to enable AppleVTD as outlined here https://www.tonymacx86.com/threads/...olt-3-i7-9700k-amd-rx-580.267551/post-2261811
Hi,
as I write in previous post EFI is a Frankenstein that mixes your Config.plist, mine Stork's Mojave-to-Catalina old and miliuco's EFI released in his guide on Monterey/guide section and is far to be optimal, but give to me, selecting the drive at boot, the upgrade and the functionality (I'm testing for problems).
At the moment USB seem OK as USB3 and C speed too (I need to ceck USBport.kext with hackintool, but plugging random I got 430MB/s on blue and red ones).
Audio after upgrade ALC kext to 1.6.4 is in testing, at the moment I have found that headphones don't "speak", but internal "speak", and need to go further on checking in and out (output via DP is OK).
Fake Sensor kext aren't good: I think must take the Virtual way...
So here it is at Frankenstein state...hope if you make evolution you'll share, so for all other in this thread and forum.
I'll give you news, but I think I'm not enough updated on the story, so is most probable that you'll give news to me...

:wave:
 

Attachments

  • EFI_Clover5138_Monterey_earlystate.zip
    7.8 MB · Views: 31
Joined
Jul 7, 2010
Messages
130
Motherboard
ASUS ROG MAXIMUS HERO X Z370
CPU
i9-9900KS
Graphics
RX 580
Mac
  1. MacBook Air
Classic Mac
  1. PowerBook
Mobile Phone
  1. iOS
Hi,
as I write in previous post EFI is a Frankenstein that mixes your Config.plist, mine Stork's Mojave-to-Catalina old and miliuco's EFI released in his guide on Monterey/guide section and is far to be optimal, but give to me, selecting the drive at boot, the upgrade and the functionality (I'm testing for problems).
At the moment USB seem OK as USB3 and C speed too (I need to ceck USBport.kext with hackintool, but plugging random I got 430MB/s on blue and red ones).
Audio after upgrade ALC kext to 1.6.4 is in testing, at the moment I have found that headphones don't "speak", but internal "speak", and need to go further on checking in and out (output via DP is OK).
Fake Sensor kext aren't good: I think must take the Virtual way...
So here it is at Frankenstein state...hope if you make evolution you'll share, so for all other in this thread and forum.
I'll give you news, but I think I'm not enough updated on the story, so is most probable that you'll give news to me...

:wave:
Thanks for sharing. Really interesting to see some of the config options, as there are a lot of things in there which I thought were totally irrelevant for this board and definitely are not needed for Big Sur.

I have tweaked a few things and swapped over the SMC kexts to use the AcidAnthera versions so would be really interested to know if this boots for you and how stable it is.

There is a load of other stuff you have which I personally don't need like the sleep patching and your have something in your RTVariables to do with Dell which I have left alone but as far as I know can probably be removed.
 

Attachments

  • EFI_Clover_Monterey_Test.zip
    7.7 MB · Views: 29
Joined
Jan 23, 2019
Messages
187
Motherboard
ASUS ROG MAXIMUS Z370 HERO X
CPU
i9-9900K
Graphics
Radeon VII
Hi,
thanks for sharing to you too. Tested rapidly for same things I described in previous post and all seems ok. Noticed that you have eliminated kext and driver and nothing apparently changed, the same for SSDTs you changed. You did replace the USBport.kext too, with your?
Now I ask you if that is working on your Big Sur too, and if answer is yes, I ask you to try this new EFI with many changes in config.plist and that is here functional in same way, but with big diet in stuffs.
Functionality seems the same with SIP on 0x0000000 and in 0x3 on 1.1.
In Clover boot section you need to change the drive with your correspondent (you'll find the data in Clover Boot.log section after "generate log" as miliuco suggested in his guide), and load in your data in SMBIOS.
If you do the test, tell me what is bad on your Big Sur configuration.
 

Attachments

  • EFI_VirtualSMC_Monterey_test_mod.zip
    8.4 MB · Views: 24
Joined
Feb 28, 2011
Messages
21
Motherboard
Gigabyte Z390 Designare
CPU
i9
Graphics
RX 580
Mobile Phone
  1. Android
Have you guys looked at Dortanias guides at all? All your fumbling is clearly explained there.
 
Joined
Jul 7, 2010
Messages
130
Motherboard
ASUS ROG MAXIMUS HERO X Z370
CPU
i9-9900KS
Graphics
RX 580
Mac
  1. MacBook Air
Classic Mac
  1. PowerBook
Mobile Phone
  1. iOS
Hi,
thanks for sharing to you too. Tested rapidly for same things I described in previous post and all seems ok. Noticed that you have eliminated kext and driver and nothing apparently changed, the same for SSDTs you changed. You did replace the USBport.kext too, with your?
Now I ask you if that is working on your Big Sur too, and if answer is yes, I ask you to try this new EFI with many changes in config.plist and that is here functional in same way, but with big diet in stuffs.
Functionality seems the same with SIP on 0x0000000 and in 0x3 on 1.1.
In Clover boot section you need to change the drive with your correspondent (you'll find the data in Clover Boot.log section after "generate log" as miliuco suggested in his guide), and load in your data in SMBIOS.
If you do the test, tell me what is bad on your Big Sur configuration.
Hi @Simon70 Sorry it has been a few days. My equipment has all been packed down as I have been moving into a new studio! I didn't change the USB ports kext in that EFI I sent as I personally use an SSDT to inject all my USB and keep below the port limit. I will try and test your EFI for you this weekend, but it means making changes in my BIOS to disable VTD.
 
Joined
Jan 23, 2019
Messages
187
Motherboard
ASUS ROG MAXIMUS Z370 HERO X
CPU
i9-9900K
Graphics
Radeon VII
Hi,
I'm making other things too in these days... If the changes in BIOS that you must do to try are problematic, don't make even try. I have tried to boot Catalina with that EFI and system started smoothly, but maybe there are some things to repair as the same in Monterey. I think if EFI work in both, can work in Big Sur too, fine tuning apart.
So choice to do with total freedom and without stress (new studio is already enough).

At the next...
 
Last edited by a moderator:
Joined
Oct 6, 2015
Messages
29
Motherboard
Asus Maximus Hero X(wifi - ac) Z370
CPU
i7-8700K
Graphics
RX 580
Mac
  1. iMac
Hi,
I'm making other things too in these days... If the changes in BIOS that you must do to try are problematic, don't make even try. I have tried to boot Catalina with that EFI and system started smoothly, but maybe there are some things to repair as the same in Monterey. I think if EFI work in both, can work in Big Sur too, fine tuning apart.
So choice to do with total freedom and without stress (new studio is already enough).

At the next...
Simon I updated to Big Sur 11.6 from Catalina from App store no problem - I then tried to update to Monteray via app store but on the reboot/restart I choose macintosh hd option from bootloader and after a while of trying to boot i get black screens and goes back to boot page. Have you got Monteray to boot ?
 
Top