Contribute
Register

Stork's MyHero II Build: ASUS ROG MAXIMUS Z370 HERO X - i7-8700K - AMD RX 580 - Thunderbolt 3

Joined
Jan 20, 2017
Messages
27
Motherboard
Z170X-UH3
CPU
i7 6700
Graphics
GTX Titan
Mac
  1. iMac
  2. MacBook Air
  3. MacBook Pro
Mobile Phone
  1. iOS
thank you very much all of you we gonna try
 
Joined
Jul 7, 2017
Messages
73
Motherboard
ASUS Z370 MAXIMUS HERO X
CPU
i7-8700K
Graphics
RX580
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Alright, so after a few days I can say 11.4 is pretty stable!
It's so good to finally be able to use spotlight to do math again... :D
It seems pretty rock solid to me. I've got zero complaints so far. As I've said on my first post-11.4-migration post, the resources usage has dropped considerably. So it's not only faster, it's finally stable! I don't miss Mojave anymore, after 2 years struggling with Catalina, I can finally let Mojave go :beachball:

If you haven't yet and your workflow allows you to, go to 11.4!
It's so good in here, I hope I can hold on migrating to Monterey (Catalina is too fresh in my memory...) :D
 
Joined
Jul 7, 2017
Messages
73
Motherboard
ASUS Z370 MAXIMUS HERO X
CPU
i7-8700K
Graphics
RX580
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Updated to 11.5.1 without any problems.

EDIT:
Update to 11.5.2 also ran without any problems. Just like it would on official apple's hardware.
 

Attachments

  • 2021-08-19 at 06.38.23@2x.png
    2021-08-19 at 06.38.23@2x.png
    160.9 KB · Views: 17
Last edited:
Joined
Apr 10, 2013
Messages
31
Motherboard
Asus Maximus X Hero Z370
CPU
i7-8700K
Graphics
RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Hello !! I've been using this build with Clover since a few years and decided to finally switch to OpenCore / Big Sur.
I did a try with @ed.stein EFI folder on an USB drive and got a proper boot, so decided to use it on my main drive and update to Big Sur.
So far almost everything works perfectly. I'd say even better that with the latest Clover (5138) with which I got some random freezes.
The only problem I have right now is external USB input devices not being recognized (a Wacom Tablet and a USB mic). External USB disks and card readers works fine though.
I don't know if this has to do with devices being USB 2.0 instead of 3.0 and if i should make a custom SSDT.
I was using a custom SSDT-USBX on Clover, but that was a long time ago and honestly I should re-learn how to make one, if that could help.
Do you have any suggestion ?
Thanks in advance.
 
Last edited:

Feartech

Moderator
Joined
Aug 3, 2013
Messages
24,853
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
Hello !! I've been using this build with Clover since a few years and decided to finally switch to OpenCore / Big Sur.
I did a try with @ed.stein EFI folder on an USB drive and got a proper boot, so decided to use it on my main drive and update to Big Sur.
So far almost everything works perfectly. I'd say even better that with the latest Clover (5138) with which I got some random freezes.
The only problem I have right now is external USB input devices not being recognized (a Wacom Tablet and a USB mic). External USB disks and card readers works fine though.
I don't know if this has to do with devices being USB 2.0 instead of 3.0 and if i should make a custom SSDT.
I was using a custom SSDT-USBX for USBInjectAll on Clover, but that was a long time ago and honestly I should re-learn how to make one, if that could help.
Do you have any suggestion ?
Thanks in advance.
 
Joined
Jul 7, 2017
Messages
73
Motherboard
ASUS Z370 MAXIMUS HERO X
CPU
i7-8700K
Graphics
RX580
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Joined
Apr 10, 2013
Messages
31
Motherboard
Asus Maximus X Hero Z370
CPU
i7-8700K
Graphics
RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Thanks both for the reply. I didn't have success with the suggested method, adding USBInjectALL to the existing configuration seem to totally break my USB setup, at the point that it can't detect any device.
@ed.stein your EFI folder already contains a USBPorts.kext, i tried both leaving it active or disabled, with no succes.
Any hints on how to debug this?

I noticed though that removing the Quirk XhciPortLimit (as advised at the end of the Beginner's guide to USB) seems to restore USB2 funcionality, but with an unpleasante side effect: Hackintool is hanging at launch and can't be used anymore. This leads me to think that something is indeed wrong and could lead to more serious problems down the line
 
Joined
Apr 10, 2013
Messages
31
Motherboard
Asus Maximus X Hero Z370
CPU
i7-8700K
Graphics
RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Well, i somehow managed to fix it:
I noticed Hackintool already displayed all the available ports beyond the 15 limit without USBInjectAll, even though some of them didn't work because falling out of the range.
I recovered an old .ASL file containing the mapping of the ports i did in Clover, so i knew which one to keep.
I was then able to generate the USBPorts.Kext and voilà, everything working perfectly.
 

Attachments

  • Screenshot 2021-08-23 at 23.56.44.png
    Screenshot 2021-08-23 at 23.56.44.png
    95.6 KB · Views: 16

Feartech

Moderator
Joined
Aug 3, 2013
Messages
24,853
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
Well, i somehow managed to fix it:
I noticed Hackintool already displayed all the available ports beyond the 15 limit without USBInjectAll, even though some of them didn't work because falling out of the range.
I recovered an old .ASL file containing the mapping of the ports i did in Clover, so i knew which one to keep.
I was then able to generate the USBPorts.Kext and voilà, everything working perfectly.
you have set them all to internal though......?
 
Top