Contribute
Register

Stork's Entry Level Hector Build: GA-H97N-WIFI - i5-4690 - HD4600 & GTX 750 Ti

Joined
Aug 28, 2012
Messages
42
Motherboard
Gigabyte Z97N-WiFi
CPU
i7-4790K
Graphics
HD 4600
Mac
iMac, MacBook, MacBook Air, MacBook Pro, Mac mini, Mac Pro
Classic Mac
512K, iMac, LC, Plus, Portable, Power Mac, PowerBook, Quadra, SE, Xserve
Thanks. I did try again to install all 3 kexts with MB, but it still didn't work. I wiped the system and started to reinstall. But, once I booted from the UniBeast drive and before I started the OS install, I opened the terminal and pinged my router, and it was working, so I knew it wasn't my hardware. I then did the clean install.

Once it was up, I ran MB again and installed AppleIntel and Atheros, but upon reboot, networking still didn't work. I popped the UniBeast drive back in, mounted its EFI and looked at what kexts were where, and compared to the EFI on the boot drive.

I found that MB had installed the kexts into S/L/E, but they were not in EFI/Clover/Kexts. I copied all the kexts, and dropped them in EFI/Clover/Kexts/Other and rebooted, and it all seemed to work.

My wondering is: Why did MB for Yosemite create a clover folder in the EFI? Wasn't MB still using Chimera then?

Also, I was feeling cocky, so I downloaded the Mojave installer and ran that - 30 min later, the system was booting into Mojave with no major issues. I'm gonna push on the edges a little more tomorrow when I get into work to see if there's anything I need that's not working, but for the moment, I'm basking in the glow of a nice (and somewhat easily) working system.

thanks!
 

Stork

Admin
Staff member
Joined
Sep 21, 2010
Messages
12,356
Motherboard
ASUS ROG MAXIMUS X HERO Z370
CPU
i7-8700K
Graphics
RX 580
Mac
MacBook Pro, Mac mini, Mac Pro
Classic Mac
Power Mac, PowerBook
Mobile Phone
iOS
Joined
Aug 28, 2012
Messages
42
Motherboard
Gigabyte Z97N-WiFi
CPU
i7-4790K
Graphics
HD 4600
Mac
iMac, MacBook, MacBook Air, MacBook Pro, Mac mini, Mac Pro
Classic Mac
512K, iMac, LC, Plus, Portable, Power Mac, PowerBook, Quadra, SE, Xserve
Ah, gotcha. I was basing off memory. I think Yosemite was out before Clover was integrated into MB, so maybe MB was updated with a mid version release? BTW, I went back and checked the (currently live version ) MB 7.5, and the features .pdf mentions Chameleon, Chimera and Easybeast, but not Clover, so maybe that doc wasn't updated then either.
 
Top