StickFigure's Ugly Build - P8Z77-V-LK + i53570k + GTX-660ti

Not open for further replies.
Mar 26, 2013
Ugly Build MAC- P8Z77-V-LK
Classic Mac
  1. Lisa
  2. Plus
  3. Quadra
  4. SE
Mobile Phone
  1. iOS
StickFigure's Ugly Build - P8Z77-V-LK + i5-3570k + GTX-660ti

Stickfigure's Ugly Build: ASUS P8Z77-V-LK - Core i5-3570k – GTX-660ti



Apple Mac OS X version 10.8.3 Mountain Lion from the Apple App Store

TonyMac UniBeast Mountain Lion 1.7.0
TonyMac MultiBeast Mountain Lion 5.3.0

Already Owned

LIAN LI PC-T60B Black Aluminum ATX / Micro-ATX TEST BENCH


Intel Core i5-3570K CPU

EVGA SuperClocked+ 03G-P4-3663-KR GeForce GTX 660 Ti 3GB GPU

CORSAIR Vengeance 32GB (4 x 8GB) DDR3 1600 Model CMZ32GX3M4X1600C10 RAM

CORSAIR Hydro Series H100i Water Cooler


Crucial M4 CT256M4SSD2 2.5" 256GB SATA III MLC Internal Solid State Drive (SSD) x 2

Cyber Acoustics 4 Watt 2.0 Computer Speaker System - Black (CA-2014) (For Testing)

Acer G245HQLbd Black 23.6" 5ms Widescreen LED Monitor 300 cd/m2 ACM 100,000,000:1 (1000:1)

Microsoft Wired Desktop Keyboard & Mouse

Any 8GB USB 3.0 Thumb Drive

Limited Availability as of this Post

Pioneer BDR206-MBK Blu-Ray BDXL Writer


This is only my second build; that said, this has been a REALLY easy build. This was my Test Bench system used to find out if HDDs were bad, if customer drives were infected with whatever and generally test stuff I didn't want any where near my main systems.

I tried a few times to bring this system up using the built in Intel Graphics with no luck. I could only get it to boot in safe mode. When I installed the GTX-660ti all of the problems went away. At no point during this installation did I need any boot flags.

This system finally came together with the release of MultiBeast 5.3.0. After reinstalling with the settings detailed below everything finally worked. My hat's off to all who worked on this release!

Many thanks to all the people who pioneered using this MOBO!

The MOBO Preparation

First, I prepped the MOBO by changing a few settings in the BIOS;

I started the computer and at the ASUS Splash Screen I pressed the "Delete" key to enter BIOS.
I then hit F5 to bring up "Load Optimized Defaults" and hit “Enter”.
I hit F7 to enter “Advanced Mode” and when the dialog box appeared hit “Enter”.
From here I did the following:
I selected “Advanced” from the upper tabs then:
SATA Configuration - SATA Mode Selection - and confirm AHCI, then select “Back”.
System Agent Configuration - Graphics Configuration - Primary Display – PCIE, then “Back”
USB Configuration - Intel xHCI Mode - Auto (defaults to ‘Smart Auto’) – then set EHCI Hand-off to “Enabled”, then “Back”.
Then “Save and Exit”

After Installation I made one more change:

I started the computer and at the ASUS Splash Screen I pressed the “Delete” key to enter BIOS.
I hit F7 and “Enter” to go into “Advanced” mode.
I selected “AI Tweaker” then “AI Overclock Timer” and selected “XMP” to enable the 1600 MHz RAM.
Then “Save and Exit”

The Install

I already had an 8 Gig, USB 3.0 Mountain Lion Install thumb drive, (there are no USB 2.0 ports on the back of the MOBO), that I put together for a previous build using the tonymacx86 OS X 10.8 guide,

I plugged the Install Thumb Drive into one of the Z77 controlled USB 3.0 ports on the back of the MOBO, (check the MOBO manual), I made sure that, other than the keyboard and mouse, nothing else was connected to a USB port.

I Started the machine and at the ASUS Splash screen held down F8 to get to the Boot Option screen.

Here I selected the thumb drive and hit enter.

When the Chimera boot loader menu came up I hit enter and was presented with the ML install screen. Throughout the install process no boot flags were needed.

I followed the instructions in the tonymacx86 UniBeast + Mountain Lion install guide:

When the installation was finished and the system rebooted I waited for the ASUS Splash screen, when it came up I hit F8 to get to the boot options screen, selected the UniBeast install thumb drive and hit enter.

At the Chimera boot loader screen I selected the Mountain Lion SSD and hit enter.

I went through the ML set up screens and then downloaded MultiBeast Mountain Lion 5.3.0 from

Now I opened MultiBeast Mountain Lion 5.3.0 and used the following settings:

MultiBeast 5.3.0 Configuration



I installed the configuration and then closed MultiBeast 5.3.0.

I then opened the Apple Disk Utility, selected the ML disk partition and selected 'Repair Permissions'

After the Disk Utility finished I closed it and shut down the system. I pulled the thumb drive and rebooted.
The MOBO found the ML SSD, booted, and I was presented with the ML desktop.

What Works


Pioneer BDR206-MBK (probably EOL by now): Read/Write CDs & DVDs & Play Blu-Rays(see BLU-RAY NOTE)

USB 2.0 + 3.0 (including 2 rear Asmedia ports) Thanks to the new MultiBeast 5.3.0 and RehabMan’s ‘USB 3.0-Universal’ kext.

All SATA ports

Video through the 660ti @ 1920x1080, accellerated (Couldn’t get HD-4000 to work, but I really didn’t try too hard)

All Audio I/O ports work including the optical port.

Other Notes

I modified the 1001 BIOS using PMPatch and installed it but for some reason it didn't work, I still needed the Patched AppelIntelCPUPowerManagement for OSX 10.8.x to stop KPs. I will try again when I have time.

I currently have the system Over Clocked to 4.2 GHz and will probably try to push it further.

I installed Parallels last night and it seems to work; will install MS Office as a final test soon.

I spent some time testing various DVD/Blu-Ray Burners with this build and here are the results:

Toshiba – Samsung 224-BB: Read/Write CDs & DVDs
NOTE: On first DVD Play; After setting Region 1 received initial error 7032; Eject DVD, reinsert and worked.

LG Blu-Ray Burner WH14NS40: Read/Write CDs & DVDs & Play Blu-Rays (see BLU-RAY NOTE)
NOTE: On first DVD Play; After setting Region 1 received initial error 7032; Eject DVD, reinsert and worked.

ASUS DRW-24B1ST: Read/Write CDs only; 70012 Error with DVD

SONY Optiarc AD-7240S (EOL) Read/Write both CDs & DVDs

BLU-RAY NOTE: Used ‘Free Mac Blu-Ray Player’ by Bluraymaster downloaded from CNET:

For those who want to know(64 bit, best of 3 runs, 5 min idle between runs):


I have no idea if this is good or not.

EDIT: (I will enter updates here as the testing continues)
Last edited by a moderator:
Have no answer as to why -x was needed. It sorted itself when I upgraded the BIOS to the latest version, mine was very old. Same multibeast configuration as the threadstarter except for the sound which is ALC887 here. Sound works, network works, Apple store does NOT work. Power management turned off since I haven't patched the BIOS. 3D games work. OS is ML 10.8.3.

I also have W7 on this and I'm using the BIOS boot menu to select OS.

Thanks StickFigure for the inspiration.

Congtrats! Glad you got it going!

The BIOS thing is interesting. I hadn't really thought about it but when I first started to mess around with this board I was on BIOS v.0908 and then upgraded the BIOS to 1001 and changed to the 660ti both at the same time. I always assumed it was the video issue but it may have been the BIOS or a combination of the 2 =/

As for power management I was not able to get passed a KP at boot until I installed the AppleIntelCPUPowerManagement item in MultiBeast. I hope to try PMPatch again soon and see if I can get passed that. I don't use sleep so it's not a big issue but I've read that if you update OS X then you will have to rerun MultiBeast, kinda' makes sense.

Once again, congrats!
I had BIOS 0801 which I upgraded to 1801. The 660Ti refused to work in 3D before the update, maybe because I had to boot with -x. That is no longer necessary and 3D works. That could be a general heads up, if the system refuses to work, try updating the BIOS.

Played good old Everquest for Mac on both systems, one character on each. Friend has a Macbook and had 3 clients up at the same time :D He had to alttab between hus characters while I split my brain and had one hand on each keyboard. :mrgreen:
Hi, Logad.
I have the same motherboard with the same BIOS version 1801, and graphics card as you have.
I too followed the steps StickFigure took for the installation except for the audio selection in MultiBeast as you did.
My BIOS is successfully patched and flashed. The patch seems to be working since I receive no Kernel Panics
whatsoever when I boot into the OS. But even though I followed the steps both of you've taken, I seems to have an unusual problem now.
I've done extensive research in this forum with no one having encountered or experienced my error here.

Our series of mobo does not require any DSDT.aml (Confirmed by CodeRush). And our graphics card should work out of the box.

Since we have the same mobo/graphics, I too, like you and StickFigure should be able to boot into ML normally without any issues.
But here's the thing, I'm not able too. Not without -x boot flag. To be more accurate, it seems that every now and then I'm able to boot
normally. But most of the times it gets stuck at the boot screen with the wheel spinning forever. Several restart from 2-8 times is
necessary for it to boot normally into the OS. When it does boot, everything within works wonderfully well. I really don't get what's
happening here and where it should not have any problems, something is wrong and I can't pin it down. You've both managed to get it
running, and Logad, you're the one closest to home spec wise that I've found here in this forum. I'm so close now and this is the only thing
preventing it from being truly successful.

I'm asking for your help.
I'm not expecting anything nor a miracle. But your help would be deeply appreciated if you're willing to.
If I've wasted your time, I truly apologize. But I've run out of options and I'm forced to seek help from you guys.
Best of wishes, and congrats on your successful builds!
Not open for further replies.