Contribute
Register

Step by Step Fix for iMessage - Requires Clover (Alternate Bootloader)

Status
Not open for further replies.
Joined
Dec 20, 2012
Messages
3
Motherboard
Mountain Lion 10.8.x
CPU
Intel Core i7 extreme
Graphics
ATI Radeon HD
Mac
Classic Mac
Mobile Phone
Hi everyone!
First off thanks for making such an easy guide for noobs.. ( like me :D ) but unfortunately it wasn't noob-friendly enough. By MISTAKE I went ...... i would like to avoid a fresh install !

Thankssss!!

try using some friend's mac to install Chimera / Chameloen boot loader (whihever was your old boot loader -- and i hope you remeber your old bootloaders settings etc) , (using chameleon wizrad if its chameleon) on some pen drive, use it to boot to your osx installation, once you are in, install Chameleon bootloader onto your HDD (dont worry abt uninstalling clover.) and you will be able to natively boot.

IMPORTANT : DONT DAMAGE YOUR FRIEND'S OSX. so install the bootloader using his Mac onto your Pendrive NOT to his HDD
 
Joined
Sep 27, 2011
Messages
10
Motherboard
Gigabyte GA-H67N-USB3 LGA 1155
CPU
Intel Core i5-2500K Sandy Brige 3.3GHz
Graphics
Intel 3000
Mac
Classic Mac
Mobile Phone
I followed the directions in the first post but my flash drive isn't booting. I can't find anything to help me out. Does anyone have any idea what could be wrong? My unibeast flash drive works just fine.

Edit: I reflashed the drive as MSDOS and now it boots.
 
Joined
Nov 16, 2011
Messages
1
Motherboard
Dell Latitude E4200
CPU
Stock
Graphics
Stock
Mac
Classic Mac
Mobile Phone
I have an original Mac Pro 1,1 where i have loaded Mountain Lion using Chameleon.

Like everyone else i've not got Messages working, but don't think Clover is supported on a Mac pro. or at least when i copy Clover to my USB drive it doesn't come up as an EFI drive. I've tried GUID formatting and MBR formatting and am using Apple Extended.

Has anyone with a proper (unsupported) Mac with Mountain Lion installed managed to get this fix to work?

Or do i have to keep my fingers crossed that a fix comes out for Chameleon, i guess i'm in no mans land at the moment not quite a Macintosh not quite a Hackintosh.

ANy help appreciated

Cheers

Mik
 
Joined
Jun 25, 2012
Messages
25
Motherboard
Mountain Lion
CPU
i5 3570k
Graphics
Gigabyte HD 6870 OC
Mac
  1. MacBook Pro
  2. Mac mini
Classic Mac
  1. iMac
  2. PowerBook
Mobile Phone
  1. iOS
This worked perfectly for me, thanks.
 
Joined
Sep 25, 2012
Messages
528
Motherboard
Asus ROG STRIX Z390-F
CPU
i5-9600K
Graphics
RX 580
Mac
  1. iMac
Mobile Phone
  1. iOS
I am having a similar issues. I followed the guide, made a bootable USB, but I can not move the mouse or use the keyboard at the Clover boot screen. I only have USB 2.0, mobo is a EX58-UD5. I have also tried making the USB with the x64 drivers. I have noticed that I now have a nvram.plist and boot.log files in my root directory on all typical boots using Chimera. Anyone have any thoughts?

I did put my DSDT in the ACPI/patched folder on my Clover boot stick, if that helps? Check through your USB settings also, you may have missed something. Clover won't boot with my keyboard and mouse working in USB3, USB2 is fine and iMessage works again.
 
Joined
Apr 22, 2012
Messages
304
Motherboard
ASRock Z77 Professional-M
CPU
i7-3770K (4.2 GHz)
Graphics
GTX 670
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
  4. Mac Pro
Classic Mac
  1. Classic
  2. Performa
  3. Power Mac
  4. Xserve
Mobile Phone
  1. iOS
I did put my DSDT in the ACPI/patched folder on my Clover boot stick, if that helps? Check through your USB settings also, you may have missed something. Clover won't boot with my keyboard and mouse working in USB3, USB2 is fine and iMessage works again.

For anyone interested the boot.log and nvram.plist files in /root are created with older Clover versions scripts located

/etc/rc.local
/etc/rc.shutdown.local

Clover r1014+ should fix/correct how those files are created and handled by the system.
 
Status
Not open for further replies.
Top