Contribute
Register

[Stable] Nicoras' Mac: H370M Bazooka + Vega 56 | OpenCore-based

Status
Not open for further replies.
Joined
Dec 4, 2017
Messages
105
Motherboard
Asus ROG Strix Z370-I Gaming
CPU
i9-9900K
Graphics
Radeon RX 6800 XT
Mac
  1. iMac
  2. MacBook
  3. MacBook Air
  4. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Not sure if anyone noticed, latest version of bootloader with OC has audio injection issues. Looks like we may need to patch our IRQ

EDIT

IRQ patched. Wow. All good now. I'll work on Thunderbolt soon.
 
Last edited:
Joined
Jan 18, 2018
Messages
106
Motherboard
GA EP45-UD3P
CPU
Q9550
Graphics
Sapphire RX 580 Nitro+ L.E
Mac
  1. iMac
  2. MacBook
Mobile Phone
  1. iOS
Thanks for the help mate. I'm actually utilizing an Engineering sample. Would that be still applicable?
It depends on how your CPU is identified by macOS. How is your processor presented in "About this Mac"? if it says Unknown, you can just modify applesysteminfo.strings.
 
Joined
Apr 27, 2020
Messages
2
Motherboard
Gigabyte Z390 Aorus Pro
CPU
i5-9600K
Graphics
UHD 630
Mac
  1. MacBook Air
  2. Mac mini
Mobile Phone
  1. Android
Anyone having trouble getting Final Cut or iMovie to launch? I would imagine it is an issue with having both the iGPI and dGPU enabled at the same time, but I would prefer to keep both active as my RX 470 only has one DVI output.
 
Joined
Jan 17, 2017
Messages
5
Motherboard
MSI H370M BAZOOKA
CPU
i7-8700
Graphics
RX 580 8GB
Mac
  1. iMac
Mobile Phone
  1. iOS
Finally have everything running smoothly!!!

Hi Nicoras, I was able to install Catalina 10.5.5 with your OpenCore EFI, thanks very much. It installed in the first try.

I have one very annoying issue. No internet connection. I searched and found out that my TPLINK WDN4800 N900 doesn't work anymore, ok, but my ethernet also doesn't work. It's been very difficult to fix it. I have to use other computer and tranfer files with USB stick every try.

Have you experienced something similar? Have any tip on where I could start? Not really start because I already wasted some hours but any thing would help.
 
Joined
Apr 27, 2020
Messages
2
Motherboard
Gigabyte Z390 Aorus Pro
CPU
i5-9600K
Graphics
UHD 630
Mac
  1. MacBook Air
  2. Mac mini
Mobile Phone
  1. Android
Hi Nicoras, I was able to install Catalina 10.5.5 with your OpenCore EFI, thanks very much. It installed in the first try.

I have one very annoying issue. No internet connection. I searched and found out that my TPLINK WDN4800 N900 doesn't work anymore, ok, but my ethernet also doesn't work. It's been very difficult to fix it. I have to use other computer and tranfer files with USB stick every try.

Have you experienced something similar? Have any tip on where I could start? Not really start because I already wasted some hours but any thing would help.


Finally something I can help with haha.

I had the exact same WiFi card for years in my old hackintosh. Mojave dropped native support, so you will have to track down the proper installer to get it working again. Additionally the installer won't work with sip protection enabled, so you will have to disable that through recovery before using it.

I believe there are two different installers that work. One is called "atheros airport installer" and one is something like "atheros for 10.14/10.15"
They can both be tracked down on Google or through this forum. I'll try to find a link or the file myself if you're having trouble!
 
Joined
Dec 4, 2017
Messages
105
Motherboard
Asus ROG Strix Z370-I Gaming
CPU
i9-9900K
Graphics
Radeon RX 6800 XT
Mac
  1. iMac
  2. MacBook
  3. MacBook Air
  4. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Hi Nicoras, I was able to install Catalina 10.5.5 with your OpenCore EFI, thanks very much. It installed in the first try.

I have one very annoying issue. No internet connection. I searched and found out that my TPLINK WDN4800 N900 doesn't work anymore, ok, but my ethernet also doesn't work. It's been very difficult to fix it. I have to use other computer and tranfer files with USB stick every try.

Have you experienced something similar? Have any tip on where I could start? Not really start because I already wasted some hours but any thing would help.
Finally something I can help with haha.

I had the exact same WiFi card for years in my old hackintosh. Mojave dropped native support, so you will have to track down the proper installer to get it working again. Additionally the installer won't work with sip protection enabled, so you will have to disable that through recovery before using it.

I believe there are two different installers that work. One is called "atheros airport installer" and one is something like "atheros for 10.14/10.15"
They can both be tracked down on Google or through this forum. I'll try to find a link or the file myself if you're having trouble!

Tbh, I don't really like to mess around with connectivity functionalities on macOS. From the looks of it, its very finicky. Sorry about that won't be of much help to you..
 
Joined
Jul 3, 2018
Messages
101
Motherboard
MSI H370M Bazooka
CPU
i5-8600
Graphics
RX 570
If anyone is curious; with OpenCore 0.6.3, this build (MSI Bazooka H370M) runs Big Sur wonderfully.
 
Status
Not open for further replies.
Top