Contribute
Register

[STABLE] Lenovo E560 Full Work

Joined
Mar 6, 2019
Messages
3
Motherboard
Lenovo Thinkpad E560
CPU
i3-6100U
Graphics
HD 520
Mobile Phone
iOS
Great Job! With your EFI files, easily installed Mojave 10.14.3. I really appreciate you!
And now I got some minor problems.

1. Microphone input - I know I should use VoodooHDA to activate internal mic, but sometimes the mic works. so I tested repeatedly and eventually I got found that only in battery mode the mic input works and with AC-adaptor it doesn't... but can't find the way to fix that. Any ideas?

2. Brightness sensor and display rotation - There's SMCLightSensor.kext in clover and in System Preferences display "Automatically adjust brightness" option checked but it seems the sensor doesn't work. And System Infomation says "rotation : supported" but there's no rotation option in display preferences. Am I different with you or these options are not working currently?
 
Joined
Oct 30, 2013
Messages
15
Motherboard
ThinkPad E560-Clover
CPU
i3-6100U
Graphics
HD 520 1920x1080 IPS
Mac
MacBook Pro
Mobile Phone
Android
Great Job! With your EFI files, easily installed Mojave 10.14.3. I really appreciate you!
And now I got some minor problems.

1. Microphone input - I know I should use VoodooHDA to activate internal mic, but sometimes the mic works. so I tested repeatedly and eventually I got found that only in battery mode the mic input works and with AC-adaptor it doesn't... but can't find the way to fix that. Any ideas?

2. Brightness sensor and display rotation - There's SMCLightSensor.kext in clover and in System Preferences display "Automatically adjust brightness" option checked but it seems the sensor doesn't work. And System Infomation says "rotation : supported" but there's no rotation option in display preferences. Am I different with you or these options are not working currently?
Hi!
I not need a microphone and I just did not understand how to start it. If you need, then put this SSDT-CX20753.aml to EFI/CLOVER/ACPI/Patched. Also probably need more CodecCommander.kext .Then rebuilt kext cache with kext utility.app
Also try to change LayoutID=21 in Clover. Read also this.
Good luck!))))
 

Attachments

Joined
Mar 6, 2019
Messages
3
Motherboard
Lenovo Thinkpad E560
CPU
i3-6100U
Graphics
HD 520
Mobile Phone
iOS
Hi!
I not need a microphone and I just did not understand how to start it. If you need, then put this SSDT-CX20753.aml to EFI/CLOVER/ACPI/Patched. Also probably need more CodecCommander.kext .Then rebuilt kext cache with kext utility.app
Also try to change LayoutID=21 in Clover. Read also this.
Good luck!))))
I'v tried all above, with no success... but the issues are just trivial things and I'm really satisfied with my lenovo mojave now :)

Thanks for all the efforts of you!
 
Joined
Oct 30, 2013
Messages
15
Motherboard
ThinkPad E560-Clover
CPU
i3-6100U
Graphics
HD 520 1920x1080 IPS
Mac
MacBook Pro
Mobile Phone
Android
Great Job! With your EFI files, easily installed Mojave 10.14.3. I really appreciate you!
And now I got some minor problems.

1. Microphone input - I know I should use VoodooHDA to activate internal mic, but sometimes the mic works. so I tested repeatedly and eventually I got found that only in battery mode the mic input works and with AC-adaptor it doesn't... but can't find the way to fix that. Any ideas?

2. Brightness sensor and display rotation - There's SMCLightSensor.kext in clover and in System Preferences display "Automatically adjust brightness" option checked but it seems the sensor doesn't work. And System Infomation says "rotation : supported" but there's no rotation option in display preferences. Am I different with you or these options are not working currently?
Hi, i fixed Microphone. Now everything works well with AppleALC.
Download the latest commit link
 
Joined
Jul 24, 2016
Messages
19
Motherboard
Lenovo E550
CPU
i7-5500u
Graphics
HD5500, 1928x1080; AMD Radeon R7 M260
For those of you with the Radeon R7 in your E560, how did you go about disabling it? I just bought one which should show up early next week (i7-6500U, radeon r7 370). Didn't realize the i3 model here only had the iGPU before pulling the trigger.
I have never been able to figure out how to turn off the DGPU in my E550 so hoping there's a more straightforward solution for this one...
 
Joined
Aug 29, 2015
Messages
9
Motherboard
GA-Z97P-d3 & thinkpad e560
CPU
i5 4590 & i7 6500u
For those of you with the Radeon R7 in your E560, how did you go about disabling it? I just bought one which should show up early next week (i7-6500U, radeon r7 370). Didn't realize the i3 model here only had the iGPU before pulling the trigger.
I have never been able to figure out how to turn off the DGPU in my E550 so hoping there's a more straightforward solution for this one...
dont inject or check anything under the graphics section (for ati), the radeon is default unavailable

did you edited your DSDT? you can disable DGPU there if needed . Dont use the SSDT for amdtable etc under ACPI/patched.. OEM tables should be dropped by clover by default

when i inject ATI , put a vbios.rom under CLOVER/rom/ there is Displayed in Sysinfo but i cannot use it. no opencl 2.x support etc.



for intel injection i use the device tab like this:

<key>Properties</key>
<dict>
<key>PciRoot(0x0)/Pci(0x2,0x0)</key>
<dict>
<key>AAPL,ig-platform-id</key>
<data>
AAAWGQ==
</data>
<key>device-id</key>
<data>
FhkAAA==
</data>
<key>enable-hdmi20</key>
<data>
AQAAAA==
</data>
<key>framebuffer-fbmem</key>
<data>
AACQAA==
</data>
<key>framebuffer-patch-enable</key>
<data>
AQAAAA==
</data>
<key>framebuffer-stolenmem</key>
<data>
AAAwAQ==
</data>
<key>framebuffer-unifiedmem</key>
<data>
AAAAgA==
</data>
</dict>
</dict>
 
Joined
Nov 21, 2015
Messages
18
Motherboard
HP Elitebook 850 G1
CPU
i5-4200U
Graphics
HD 4400, 1920X1080
I also have the I7 version with with the same issue. I boot with config.plist then at clover screen have to use config2.plist to finish booting. The first config is the i-3 version and needs to be modified somehow to boot I-7 with ATI. Please review the attached and guide me on the correct path.

THANKS
 
Last edited:
Joined
Nov 21, 2015
Messages
18
Motherboard
HP Elitebook 850 G1
CPU
i5-4200U
Graphics
HD 4400, 1920X1080
muhviehstarr - Would you share your config.plist for those of us with ATI gpu version of the e560. I follow instructions and edited Properties no joy.
Thanks,
 
Last edited:
Top