Contribute
Register

SSDT generation script (Ivybridge PM)

Status
Not open for further replies.
Joined
Aug 17, 2011
Messages
36
Motherboard
ASUS Z170 strie
CPU
i7 6700K
Graphics
GEFORCE 980ti
I have overclocked my CPU i5 4670k at 4,6Ghz. Everything seems to work perfectly in Prime
Nice temp ...etc

I have added
~/ssdtPRGen.[sh/command] Frequency (4600)

Is is the correct way to use SSDTPrGen for overclocking ?
 
Joined
Jan 28, 2012
Messages
26
Motherboard
Gigabyte GA-Z77-DS3H rev 1.0 F9 BIOS
CPU
Intel Core i5 3570K
Graphics
Zotac Geforce GTX 670 4Gb (GK104)
Mac
  1. MacBook Air
Classic Mac
Mobile Phone
  1. iOS
Ok, I'll experiment if you say it should work.

I still don't understand why ssdtPRGen produce different SSDT.amls under Mavericks and Mountain Lion. I think the problem originates from this point.

SOLVED! And all the kexts are stock.

I updated ssdtPRGen to v9.0 and not it generates a 1726 bytes long ssdt.aml which works with Mavericks 10.9.1!
 
Joined
Jan 22, 2014
Messages
4
Mac
Classic Mac
Mobile Phone
Hello i tried your script, its fantastic work. I only got one problem my system log says CPUs evaluation failed _CST and when i generate SSDT file it shows this warning

System information: Mac OS X 10.9.1 (13B42)
Brandstring 'Intel(R) Core(TM) i5-3317U CPU @ 1.70GHz'
Processor Declaration(s) Found in DSDT
Generating ssdt_pr.dsl for a MacBookAir5,2 [Mac-2E6FAB96566FE58C]
Ivy Bridge Core i5-3317U processor [0x306A9] setup [0x0604]
With a maximum TDP of 17 Watt, as specified by Intel


Warning: Low Frequency Mode is 0 (unknown/unconfirmed)
Now using 1200 MHz for Mobile processor


Number logical CPU's: 4 (Core Frequency: 1700 MHz)
Number of Turbo States: 9 (1800-2600 MHz)
Number of P-States: 15 (1200-2600 MHz)
Adjusting C-States for detected (mobile) processor
Injected C-States for CPU0 (C1,C3,C6,C7)
Injected C-States for CPU1 (C1,C2,C3)


Warning: 'cpu-type' may be set improperly (0x0604 instead of 0x0704)Is it the problem?

My system only has the P-State 16 all the time, it never changes.

I am using Mavericks 10.9.1, Clover, SMBIOS MBA5,1 / MBA 5,2

edit fixed, i just had to rename my ssdt file to SSDT.aml, for clover


 
Joined
Jan 19, 2013
Messages
271
Motherboard
Mac mini
CPU
i[5/7]
Graphics
HD[3/4]000
Mac
Classic Mac
Mobile Phone
I have overclocked my CPU i5 4670k at 4,6Ghz. Everything seems to work perfectly in Prime
Nice temp ...etc

I have added
~/ssdtPRGen.[sh/command] Frequency (4600)

Is is the correct way to use SSDTPrGen for overclocking ?
Correct!
 
Joined
May 15, 2012
Messages
2
Mac
Classic Mac
Mobile Phone
I added the following to the gServerSandyBridgeCPUList, you may want to add it to the script - but it still tries to tell me my proc is a v2 ;)

Code:
E5-2690,135,0,2900,3800,8,1

Also I've been working on trying to get my X9DAi's sleep to work right (it seems to sleep but the processor fans don't stop and it keeps using more power than it should) ... generating it this way didn't seem to change anything, and it never uses the lower speedster values (only a few higher ones)

Would anybody have any suggestions for what I may want to try or where to go to actually learn what is happening and how to debug it? I'm wondering if I need to do a custom DSDT, and I've been working on that but I haven't finished yet.
 
Joined
Feb 13, 2011
Messages
8
Motherboard
H87-HD3
CPU
i5-4440
Graphics
R9 380
I am only getting 2 states, 8 and 31 with my i5-4440

is there is something that can be done to get those in between?
edited no kexts and using native power management
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
186,689
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Joined
Feb 13, 2011
Messages
8
Motherboard
H87-HD3
CPU
i5-4440
Graphics
R9 380
That is somewhat normal for iMac smbios. Are you using XCPM?

I think that's related to the mach_kernel file, doesn't it?
and if so then I the md5 of the mach_kernel I have used during installation matches the md5 of the vanilla one from your other thread

perhaps that's a no?
though I have "XCPM: registered" in my system log or maybe that's just the unpatched xcpm
 
Status
Not open for further replies.
Top