Contribute
Register

SSDT for Asus Z370-I

Joined
Oct 25, 2018
Messages
12
Motherboard
ASUS ROG Strix Z370-I Gaming
CPU
i7 8700K
Graphics
Rx 5700 XT
Mac
  1. iMac
  2. Mac Pro
So Since nothings want to work and I dont suces to have a log out with your EFI I decided to try to create my own SSDT
I used you first post to have the right location and name and this link to do it https://www.tonymacx86.com/threads/a-beginners-guide-to-creating-a-custom-usb-ssdt.272505/ . But my SSDT are so different, I don't understand but when i try it this is what happen. may be the FakePCIID.kext is the problems
IMG_1440.jpeg
 

Attachments

  • SSDT-UIAC.aml
    695 bytes · Views: 30
Joined
Nov 28, 2018
Messages
78
Motherboard
asus z370-i
CPU
i7-9700k
Graphics
RX 580
Mac
  1. iMac
  2. MacBook
  3. Mac Pro
Classic Mac
  1. Apple
Mobile Phone
  1. iOS
Ok, your configuration ist not the same then my or did you also replace the wlan module ?

--> WALN / BCM94352Z; AC 40Mhz is working - 80Mhz sometimes / If you do not replaced the wlan module.
I suggest to disable the wlan+bluetooth module / remove all bcm* kex and still use the rest of my EFI without them..
you need to plug in a usb keyboard and mouse
 
Joined
Oct 25, 2018
Messages
12
Motherboard
ASUS ROG Strix Z370-I Gaming
CPU
i7 8700K
Graphics
Rx 5700 XT
Mac
  1. iMac
  2. Mac Pro
the only things i have replaced is the WIFI Bluetooth card inside of the little steel box with a Broadcom,
 
Joined
Nov 28, 2018
Messages
78
Motherboard
asus z370-i
CPU
i7-9700k
Graphics
RX 580
Mac
  1. iMac
  2. MacBook
  3. Mac Pro
Classic Mac
  1. Apple
Mobile Phone
  1. iOS
ok what chip set ? Could you please follow my suggestion ?
 
Joined
Nov 28, 2018
Messages
78
Motherboard
asus z370-i
CPU
i7-9700k
Graphics
RX 580
Mac
  1. iMac
  2. MacBook
  3. Mac Pro
Classic Mac
  1. Apple
Mobile Phone
  1. iOS
Thats the output of my boot. I saw some minor issues... but as I said, the system is stable

Bash:
0:100  0:100  MemLog inited, TSC freq: 3600506760
0:100  0:000  CPU was calibrated with RTC
0:100  0:000 
0:100  0:000  Now is 26.03.2020,  06:35:43 (GMT)
0:100  0:000  Starting Clover revision: 5104 (master, commit 60b6eb5c3) on American Megatrends EFI
0:100  0:000  Build with: [Args: -D NO_GRUB_DRIVERS_EMBEDDED -t GCC53 | -D NO_GRUB_DRIVERS_EMBEDDED --conf=/Users/sergey/src/CloverHackyColor/Conf -D USE_LOW_EBDA -a X64 -b RELEASE -t GCC53 -n 5 | OS: 10.14.6]
0:100  0:000  SelfDevicePath=PciRoot(0x0)\Pci(0x1D,0x0)\Pci(0x0,0x0)\NVMe(0x1,AA-4F-B1-81-59-38-25-00)\HD(1,GPT,9EC5CC0F-BA9E-478F-B77A-DDEA117D159A,0x28,0x64000) @7160FB98
0:100  0:000  SelfDirPath = \EFI\BOOT
0:100  0:000  Clover : Image base = 0x673C1000
0:100  0:000  g_str = g_str:foobar
0:100  0:000  g_str2 = g_str:foobar2
0:100  0:000  global_str1 = global_str1
0:100  0:000  global_str2 = global_str2
0:100  0:000  SimpleTextEx Status=Success
0:100  0:000  === [ Get Smbios ] ========================================
0:100  0:000  Type 16 Index = 0
0:100  0:000  Total Memory Slots Count = 2
0:100  0:000  Type 17 Index = 0
0:100  0:000  SmbiosTable.Type17->Speed = 2800MHz
0:100  0:000  SmbiosTable.Type17->Size = 16384MB
0:100  0:000  SmbiosTable.Type17->Bank/Device = BANK 0 ChannelA-DIMM1
0:100  0:000  SmbiosTable.Type17->Vendor = Kingston
0:100  0:000  SmbiosTable.Type17->SerialNumber =
0:100  0:000  SmbiosTable.Type17->PartNumber =     
0:100  0:000  Type 17 Index = 1
0:100  0:000  SmbiosTable.Type17->Speed = 2800MHz
0:100  0:000  SmbiosTable.Type17->Size = 16384MB
0:100  0:000  SmbiosTable.Type17->Bank/Device = BANK 2 ChannelB-DIMM1
0:100  0:000  SmbiosTable.Type17->Vendor = Kingston
0:100  0:000  SmbiosTable.Type17->SerialNumber =
0:100  0:000  SmbiosTable.Type17->PartNumber =       
0:100  0:000  Boot status=0
0:100  0:000  Running on: 'System Product Name' with board 'ROG STRIX Z370-I GAMING'
0:100  0:000  === [ GetCPUProperties ] ==================================
0:100  0:000  CPU Vendor = 756E6547 Model=906EC
0:100  0:000   The CPU supported SSE4.1
0:100  0:000  BrandString = Intel(R) Core(TM) i7-9700K CPU @ 3.60GHz
0:100  0:000   The CPU supported turbo
0:100  0:000  MSR 0x35               80008
0:100  0:000   TSC/CCC Information Leaf:
0:100  0:000    numerator     : 300
0:100  0:000    denominator   : 2
0:100  0:000   Calibrated ARTFrequency: 24003378
0:100  0:000   Rounded ARTFrequency: 24000000
0:100  0:000  MSR 0xE2 before patch 1E000000
0:100  0:000  MSR 0xCE              08080838_F1012400
0:100  0:000  corrected FLEX_RATIO = E0000
0:100  0:000  MSR 0x1B0             00000000
0:100  0:000  FSBFrequency = 100 MHz, DMI FSBFrequency = 100 MHz, Corrected FSBFrequency = 100 MHz
0:100  0:000  MaxDiv/MinDiv: 36.0/8
0:100  0:000  Turbo: 49/50/50/50
0:100  0:000  Features: 0xBFEBFBFF
0:100  0:000  Threads: 8
0:100  0:000  Cores: 8
0:100  0:000  FSB: 100 MHz
0:100  0:000  CPU: 3600 MHz
0:100  0:000  TSC: 3600 MHz
0:100  0:000  PIS: 100 MHz
0:100  0:000  ExternalClock: 25 MHz
0:100  0:000  === [ GetDevices ] ========================================
0:100  0:000  GOP found at: PciRoot(0x0)/Pci(0x1,0x0)/Pci(0x0,0x0)/AcpiAdr(0x80010304)
0:100  0:000  PCI (00|00:00.00) : 8086 3E30 class=060000
0:100  0:000  PCI (00|00:01.00) : 8086 1901 class=060400
0:100  0:000  PCI (00|01:00.00) : 1002 67DF class=030000
0:100  0:000   - GOP: Provided by device
0:100  0:000   - GFX: Model=AMD Radeon RX 480 (ATI/AMD)
0:101  0:000  PCI (00|01:00.01) : 1002 AAF0 class=040300
0:101  0:000   - HDMI Audio:
0:101  0:000  PCI (00|00:02.00) : 8086 3E98 class=030000
0:101  0:000   - GFX: Model=Intel UHD Graphics 630 (Intel)
0:101  0:000  PCI (00|00:14.00) : 8086 A2AF class=0C0330
0:101  0:000  PCI (00|00:16.00) : 8086 A2BA class=078000
0:101  0:000  PCI (00|00:17.00) : 8086 A282 class=010601
0:101  0:000  PCI (00|00:1B.00) : 8086 A2E7 class=060400
0:101  0:000  PCI (00|00:1B.03) : 8086 A2EA class=060400
0:101  0:000  PCI (00|03:00.00) : 14E4 43B1 class=028000
0:101  0:000   - WIFI: Vendor=Broadcom
0:101  0:000  PCI (00|00:1B.04) : 8086 A2EB class=060400
0:101  0:000  PCI (00|04:00.00) : 144D A808 class=010802
0:101  0:000  PCI (00|00:1C.00) : 8086 A290 class=060400
0:101  0:000  PCI (00|00:1C.04) : 8086 A294 class=060400
0:101  0:000  PCI (00|00:1D.00) : 8086 A298 class=060400
0:101  0:000  PCI (00|07:00.00) : 144D A808 class=010802
0:101  0:000  PCI (00|00:1F.00) : 8086 A2C9 class=060100
0:101  0:000  PCI (00|00:1F.02) : 8086 A2A1 class=058000
0:101  0:000  PCI (00|00:1F.03) : 8086 A2F0 class=040300
0:101  0:000  PCI (00|00:1F.04) : 8086 A2A3 class=0C0500
0:101  0:000  PCI (00|00:1F.06) : 8086 15B8 class=020000
0:101  0:000   - LAN: 0 Vendor=Intel
0:101  0:000  === [ GetDefaultSettings ] ================================
0:101  0:000  Clover load options size = 0 bytes
0:102  0:000  CheckOEMPathExists tried EFI\CLOVER\OEM\System Product Name--00-00-00-00-00-00. Dir not exists
0:102  0:000  CheckOEMPathExists tried EFI\CLOVER\OEM\ROG STRIX Z370-I GAMING\UEFI. Dir not exists
0:102  0:000  CheckOEMPathExists tried EFI\CLOVER\OEM\System Product Name. Dir not exists
0:102  0:000  CheckOEMPathExists tried EFI\CLOVER\OEM\System Product Name-3600. Dir not exists
0:102  0:000  CheckOEMPathExists tried EFI\CLOVER\OEM\ROG STRIX Z370-I GAMING. Dir not exists
0:102  0:000  CheckOEMPathExists tried EFI\CLOVER\OEM\ROG STRIX Z370-I GAMING-3600. Dir not exists
0:102  0:000  set OEMPath by default: EFI\CLOVER
0:104  0:002  EFI\CLOVER\config.plist loaded: Success
0:105  0:000  === [ GetListOfThemes ] ===================================
0:105  0:000  - [00]: SGR
0:106  0:000  - [01]: newyear
0:107  0:001  - [02]: mac
0:108  0:001  - [03]: christmas
0:109  0:000  - [04]: random
0:110  0:000  - [04]: embedded
0:111  0:000  === [ Found config plists ] ===============================
0:111  0:000  - config.plist
0:112  0:000  === [ GetEarlyUserSettings ] ==============================
0:112  0:000  timeout set to 0
0:112  0:000  Custom boot CUSTOM_BOOT_DISABLED (0x0)
0:112  0:000  KernelXCPM: enabled
0:112  0:000  KextsToPatch: 1 requested
0:112  0:000   - [00]: com.apple.iokit.IOAHCIBlockStorage (Enable TRIM for SSD) :: BinPatch :: data len: 11
0:112  0:000  Default theme: mac
0:112  0:000  Hiding entries with string \EFI\BOOT\BOOTX64.EFI
0:112  0:000  === [ LoadDrivers ] =======================================
0:113  0:001  Loading AptioInputFix.efi  status=Success
0:114  0:001  Loading HFSPlus.efi  status=Success
0:115  0:001   - driver needs connecting
0:115  0:000  Loading AppleImageLoader.efi  status=Success
0:117  0:001  Loading AppleKeyFeeder.efi  status=Success
0:118  0:001  Loading AptioMemoryFix.efi  status=Success
0:119  0:001  Loading UsbKbDxe.efi  status=Success
0:120  0:001   - driver needs connecting
0:120  0:000  Loading ApfsDriverLoader.efi  status=Success
0:121  0:001   - driver needs connecting
0:121  0:000  3 drivers needs connecting ...
0:121  0:000  PlatformDriverOverrideProtocol not found. Installing ... Success
0:121  0:000  HFS+ driver loaded
0:121  0:000  APFS driver loaded
0:121  0:000  Searching for invalid DiskIo BY_DRIVER connects: not found, all ok
0:785  0:663  === [ InitScreen ] ========================================
0:785  0:000  Console modes reported: 4, available modes:
0:785  0:000   - [01]: 80x25 (current mode)
0:785  0:000   - [02]: 80x50
0:785  0:000   - [03]: 100x31
0:785  0:000   - [04]: 320x84
0:785  0:000  SetScreenResolution: 2560x1600 - setting Mode 0
0:791  0:006  Video mode change to mode #0: Success
0:791  0:000  reinit: self device path=PciRoot(0x0)\Pci(0x1D,0x0)\Pci(0x0,0x0)\NVMe(0x1,AA-4F-B1-81-59-38-25-00)\HD(1,GPT,9EC5CC0F-BA9E-478F-B77A-DDEA117D159A,0x28,0x64000)
0:791  0:000  === [ GetMacAddress ] =====================================
0:791  0:000  MAC address of LAN #0= 0C:9D:92:82:0A:3F:
0:791  0:000  MAC address of LAN #1= 0C:9D:92:82:0A:3F:
0:791  0:000  MAC address of LAN #2= 0C:9D:92:82:0A:3F:
0:791  0:000  MAC address of LAN #3= 0C:9D:92:82:0A:3F:
0:791  0:000  === [ ScanSPD ] ===========================================
0:792  0:000  Scanning SMBus [8086:A2A3], mmio: 0xFF024004, ioport: 0xF040, hostc: 0x11
0:810  0:018  Slot: 0 Type 26 16384MB 2666MHz Vendor=Kingston PartNo=KHX2666C1616G SerialNo=
0:829  0:018  Slot: 2 Type 26 16384MB 2666MHz Vendor=Kingston PartNo=KHX2666C1616G SerialNo=
0:830  0:000  === [ GetAcpiTablesList ] =================================
0:830  0:000  Get Acpi Tables List from RSDT:
0:830  0:000   - [00]: FACP  A M I  len=132
0:830  0:000   - [01]: APIC  A M I  len=188
0:830  0:000   - [02]: FPDT  A M I  len=68
0:830  0:000   - [03]: FIDT  A M I len=156
0:830  0:000   - [04]: WSMT  A M I  len=40
0:830  0:000   - [05]: MCFG  A M I  len=60
0:830  0:000   - [06]: SSDT  SataTabl len=931
0:830  0:000   - [07]: SSDT  SaSsdt  len=12355
0:830  0:000   - [08]: SSDT  PegSsdt len=9745
0:830  0:000   - [09]: HPET  KBL len=56
0:830  0:000   - [10]: SSDT  Ther_Rvp len=4514
0:830  0:000   - [11]: SSDT  xh_rvp08 len=2845
0:830  0:000   - [12]: UEFI  A M I  len=66
0:830  0:000   - [13]: SSDT  CpuSsdt len=6062
0:830  0:000   - [14]: LPIT  KBL len=148
0:830  0:000   - [15]: SSDT  HdaDsp len=321
0:830  0:000   - [16]: SSDT  sensrhub len=671
0:830  0:000   - [17]: SSDT  PtidDevc len=12290
0:830  0:000   - [18]: SSDT  TbtTypeC len=1303
0:830  0:000   - [19]: DBGP   len=52
0:830  0:000   - [20]: DBG2   len=84
0:830  0:000   - [21]: VFCT  A M I  len=59524
0:830  0:000   - [22]: BGRT  A M I  len=56
0:830  0:000  Calibrated TSC Frequency = 3600506760 = 3600MHz
0:830  0:000  === [ GetUserSettings ] ===================================
0:830  0:000  Add 1 devices:
0:830  0:000  USB FixOwnership: no
0:830  0:000   - final DSDT Fix mask=00000004
0:830  0:000  ResetAddr: 0x0
0:830  0:000  Calc ResetVal: 0x0
0:830  0:000  ResetVal: 0x0
0:830  0:000  smartUPS: present
0:830  0:000  Using ProductName from config: iMacPro1,1
0:830  0:000  Using latest BiosVersion from config
0:830  0:000  BiosVersion: IMP11.88Z.0064.B30.1712081714
0:830  0:000  BiosReleaseDate: 12/08/2017
0:830  0:000  Using EfiVersion from clover: 1037.80.41.0.0
0:830  0:000  Using FirmwareFeatures from clover: 0xFD8FF53F
0:830  0:000  Using FirmwareFeaturesMask from clover: 0xFF9FFF3F
0:830  0:000  Board-ID set from config as Mac-
0:830  0:000  BoardType: 0xA
0:830  0:000  ChassisType: 0x9
0:830  0:000  Converted CustomUUID 53C5A21E-
0:830  0:000  === [ GetEfiBootDeviceFromNvram ] =========================
0:831  0:001   - efi-boot-device-data: PciRoot(0x0)\Pci(0x1D,0x0)\Pci(0x0,0x0)\SasEx(0x0100000000253859,0x81B14FAA7074616C,0x0,NoTopology,0,0,0)\HD(2,GPT,80577429-D05B-4DC6-86BC-1A43E1D7FCCB,0x64028,0x3A321FE0)\VenMedia(BE74FCF7-0B7C-49F3-9147-01F4042E6842,BDD82FC34AD2EB4C9CA0EE5D9BC182AF)\6AD7F212-4D67-35C2-AFB1-5995FEEF02AF\System\Library\CoreServices\boot.efii
0:831  0:000    - Volume: 'PciRoot(0x0)\Pci(0x1D,0x0)\Pci(0x0,0x0)\SasEx(0x0100000000253859,0x81B14FAA7074616C,0x0,NoTopology,0,0,0)\HD(2,GPT,80577429-D05B-4DC6-86BC-1A43E1D7FCCB,0x64028,0x3A321FE0)\VenMedia(BE74FCF7-0B7C-49F3-9147-01F4042E6842,BDD82FC34AD2EB4C9CA0EE5D9BC182AF)'
0:831  0:000    - LoaderPath: '\6AD7F212-4D67-35C2-AFB1-5995FEEF02AF\System\Library\CoreServices\boot.efi'
0:831  0:000    - Guid =
0:832  0:000  === [ Found DSDT tables ] =================================
1:379  0:546  === [ ScanVolumes ] =======================================
1:379  0:000  Found 13 volumes with blockIO
1:379  0:000  - [00]: Volume: PciRoot(0x0)\Pci(0x17,0x0)\Sata(0x5,0xFFFF,0x0)
1:379  0:000  - [01]: Volume: PciRoot(0x0)\Pci(0x17,0x0)\Sata(0x5,0xFFFF,0x0)\HD(1,MBR,0x00000000,0x800,0x6FCC000)
1:380  0:000  - [02]: Volume: PciRoot(0x0)\Pci(0x1B,0x4)\Pci(0x0,0x0)\NVMe(0x1,76-4F-B1-81-59-38-25-00)
1:380  0:000  - [03]: Volume: PciRoot(0x0)\Pci(0x1B,0x4)\Pci(0x0,0x0)\NVMe(0x1,76-4F-B1-81-59-38-25-00)\HD(1,GPT,26AF6D69-AC8D-4B42-B918-6E4333DDCFA9,0x28,0x64000)
1:380  0:000          Result of bootcode detection: bootable unknown (legacy)
1:380  0:000  - [04]: Volume: PciRoot(0x0)\Pci(0x1B,0x4)\Pci(0x0,0x0)\NVMe(0x1,76-4F-B1-81-59-38-25-00)\HD(2,GPT,BFBB86DB-4612-4E5E-B150-8C4884FAC50B,0x64028,0x3A2E1FE0)
1:380  0:000          Result of bootcode detection: bootable unknown (legacy)
1:380  0:000  - [05]: Volume: PciRoot(0x0)\Pci(0x1D,0x0)\Pci(0x0,0x0)\NVMe(0x1,AA-4F-B1-81-59-38-25-00)
1:380  0:000  - [06]: Volume: PciRoot(0x0)\Pci(0x1D,0x0)\Pci(0x0,0x0)\NVMe(0x1,AA-4F-B1-81-59-38-25-00)\HD(1,GPT,9EC5CC0F-BA9E-478F-B77A-DDEA117D159A,0x28,0x64000)
1:380  0:000          Result of bootcode detection: bootable unknown (legacy)
1:381  0:000          This is SelfVolume !!
1:381  0:000  - [07]: Volume: PciRoot(0x0)\Pci(0x1D,0x0)\Pci(0x0,0x0)\NVMe(0x1,AA-4F-B1-81-59-38-25-00)\HD(2,GPT,80577429-D05B-4DC6-86BC-1A43E1D7FCCB,0x64028,0x3A321FE0)
1:381  0:000          Result of bootcode detection: bootable unknown (legacy)
1:381  0:000  - [08]: Volume: PciRoot(0x0)\Pci(0x1B,0x4)\Pci(0x0,0x0)\NVMe(0x1,76-4F-B1-81-59-38-25-00)\HD(2,GPT,BFBB86DB-4612-4E5E-B150-8C4884FAC50B,0x64028,0x3A2E1FE0)\VenMedia(BE74FCF7-0B7C-49F3-9147-01F4042E6842,8D46EBAD8114F733919DF5F70156B129)
1:384  0:002  - [09]: Volume: PciRoot(0x0)\Pci(0x1D,0x0)\Pci(0x0,0x0)\NVMe(0x1,AA-4F-B1-81-59-38-25-00)\HD(2,GPT,80577429-D05B-4DC6-86BC-1A43E1D7FCCB,0x64028,0x3A321FE0)\VenMedia(BE74FCF7-0B7C-49F3-9147-01F4042E6842,BDD82FC34AD2EB4C9CA0EE5D9BC182AF)
1:384  0:000  - [10]: Volume: PciRoot(0x0)\Pci(0x1D,0x0)\Pci(0x0,0x0)\NVMe(0x1,AA-4F-B1-81-59-38-25-00)\HD(2,GPT,80577429-D05B-4DC6-86BC-1A43E1D7FCCB,0x64028,0x3A321FE0)\VenMedia(BE74FCF7-0B7C-49F3-9147-01F4042E6842,12F2D76A674DC235AFB15995FEEF02AF)
1:384  0:000  - [11]: Volume: PciRoot(0x0)\Pci(0x1D,0x0)\Pci(0x0,0x0)\NVMe(0x1,AA-4F-B1-81-59-38-25-00)\HD(2,GPT,80577429-D05B-4DC6-86BC-1A43E1D7FCCB,0x64028,0x3A321FE0)\VenMedia(BE74FCF7-0B7C-49F3-9147-01F4042E6842,BB3734629FC76C4E9EFAF6D3659DDFB3)
1:384  0:000  - [12]: Volume: PciRoot(0x0)\Pci(0x1D,0x0)\Pci(0x0,0x0)\NVMe(0x1,AA-4F-B1-81-59-38-25-00)\HD(2,GPT,80577429-D05B-4DC6-86BC-1A43E1D7FCCB,0x64028,0x3A321FE0)\VenMedia(BE74FCF7-0B7C-49F3-9147-01F4042E6842,2BCD05765EBFC945B18F37B15948C48F)
1:384  0:000  No AudioIoProtocols, status=Not Found
1:384  0:000  === [ InitTheme ] =========================================
1:384  0:000  use night theme
1:392  0:007  Using theme 'mac' (EFI\CLOVER\themes\mac)
1:392  0:000  file sound read: sound_night.wav Not Found
1:392  0:000  file sound read: sound.wav Not Found
1:394  0:001  Loading font from ThemeDir: Success
1:394  0:000  theme inited
1:394  0:000  Chosen theme mac
1:395  0:000  after NVRAM boot-args=dart=0 -alcbeta shikigva=60 brcmfx-country=CH nvda_drv=1 keepsyms=1 -disablegfxfirmware -ilubetaall -wegbeta
1:395  0:000  === [ Dump SMC keys from NVRAM ] ==========================
1:395  0:000  no AppleSMC protocol
1:467  0:071  === [ ScanLoader ] ========================================
1:467  0:000  - [01]: 'Transfer'
1:480  0:013  - [03]: 'EFI'
1:493  0:012  - [06]: 'EFI'
1:506  0:013          AddLoaderEntry for Volume Name=EFI
1:506  0:000          skipped because entry is hidden
1:506  0:000  - [08]: 'data'
1:642  0:135  - [09]: 'Preboot'
1:643  0:000          AddLoaderEntry for Volume Name=Preboot
1:645  0:001      Check if volume Is Hibernated:
1:645  0:000      Check sleep image 'by signature':
1:645  0:000      using default sleep image name = \private\var\vm\sleepimage
1:645  0:000      sleepimage not found -> Not Found
1:645  0:000      hibernated: no - sign
1:646  0:001          [!] Icon 18 (icons\vol_internal_apfs.icns) not found (path: EFI\CLOVER\themes\mac)
1:648  0:002          AddLoaderEntry for Volume Name=Preboot
1:660  0:011  - [10]: 'system'
1:664  0:003          AddLoaderEntry for Volume Name=system
1:665  0:000      Check if volume Is Hibernated:
1:665  0:000      Check sleep image 'by signature':
1:668  0:002      read prefs \Library\Preferences\com.apple.PowerManagement.plist status=Success
1:668  0:000      using default sleep image name = \private\var\vm\sleepimage
1:669  0:001      sleepimage not found -> Not Found
1:669  0:000      hibernated: no - sign
1:680  0:011  - [11]: 'Recovery'
1:681  0:000          AddLoaderEntry for Volume Name=Recovery
1:694  0:012  - [12]: 'VM'
1:703  0:009  Scanning legacy ...
1:703  0:000  === [ AddCustomTool ] =====================================
1:704  0:001  found tool \EFI\CLOVER\tools\Shell64U.efi
1:704  0:000  Checking EFI partition Volume 3 for Clover
1:704  0:000  Checking EFI partition Volume 6 for Clover
1:705  0:000   Found Clover
1:708  0:002  === [ GetEfiBootDeviceFromNvram ] =========================
1:708  0:000  === [ FindStartupDiskVolume ] =============================
1:708  0:000    - Volume: partition = PciRoot(0x0)\Pci(0x1D,0x0)\Pci(0x0,0x0)\SasEx(0x0100000000253859,0x81B14FAA7074616C,0x0,NoTopology,0,0,0)\HD(2,GPT,8057742E1D7FCCB,0x64028,0x3A321FE0)\VenMedia(BE74FCF7-0B7C-49F3-9147-01F4042E6842,BDD82FC34AD2EB4C9CA0EE5D9BC182AF)
1:708  0:000     - searching for that partition and loader '\6AD7F2EEF02AF\System\Library\CoreServices\boot.efi'
1:708  0:000      - [!] not found
1:708  0:000     - searching again, but comparing Media dev path nodes
1:708  0:000     - found entry 0. 'Boot FileVault Prebooter from Preboot', Volume 'Preboot', '\6AD7F21FEEF02AF\System\Library\CoreServices\boot.efi'
1:708  0:000  Boot redirected to Entry 0. 'Boot FileVault Prebooter from Preboot'
1:708  0:000  DefaultIndex=0 and MainMenu.EntryCount=10
1:708  0:000  exit from MainMenu 4
1:708  0:000  === [ StartLoader ] =======================================
1:708  0:000  Finally: ExternalClock=26MHz BusSpeed=100015kHz CPUFreq=3601MHz PIS: hw.busfrequency=104000000Hz
1:708  0:000  Loading boot.efi  status=Success
1:719  0:011  GetOSVersion: 10.14.6 (18G3020)
1:719  0:000  CSR_CFG: CSR_ALLOW_UNTRUSTED_KEXTS | CSR_ALLOW_UNRESTRICTED_FS | CSR_ALLOW_TASK_FOR_PID | CSR_ALLOW_UNRESTRICTED_DTRACE | CSR_ALLOW_UNRESTRICTED_NVRAM
1:719  0:000  Filtering KextPatches:
1:719  0:000   - [00]: com.apple.iokit.IOAHCIBlockStorage (Enable TRIM for SSD) :: BinPatch :: [OS: 10.14.6 | MatchOS: All | MatchBuild: All] ==> allowed
1:719  0:000  Will not patch boot.efi
1:719  0:000  === [ PatchSmbios ] =======================================
1:719  0:000  insert table 9 for dev 0:0
1:719  0:000  insert table 9 for dev 0:1
1:719  0:000  insert table 9 for dev 1F:6
1:719  0:000  insert table 9 for dev 0:0
1:719  0:000  Table 11 present, but rewritten for us
1:720  0:000  Trusting SMBIOS...
1:720  0:000  Detected alternating SMBIOS channel banks
1:720  0:000  Channels: 2
1:720  0:000  Interleave: 0 2 1 3 4 6 5 7 8 10 9 11 12 14 13 15 16 18 17 19 20 22 21 23
1:720  0:000   partNum=KHX2666C16/16G     
1:720  0:000  SMBIOS Type 17 Index = 0 => 0 0:
1:720  0:000  BANK 0 DIMM0 2800MHz 16384MB(Ext:0MB)
1:720  0:000   partNum=KHX2666C16/16G     
1:720  0:000  SMBIOS Type 17 Index = 1 => 1 2:
1:720  0:000  BANK 1 DIMM0 2800MHz 16384MB(Ext:0MB)
1:720  0:000  mTotalSystemMemory = 32768
1:720  0:000  NumberOfMemoryDevices = 2
1:720  0:000  Type20[0]->End = 0xFFFFFF, Type17[0] = 0x4000
1:720  0:000  Type20[1]->End = 0x1FFFFFF, Type17[1] = 0xC000
1:720  0:000  Table 131 is present, CPUType=35
1:720  0:000  Change to: 1005
1:720  0:000  === [ PatchACPI ] =========================================
1:720  0:000  Xsdt reallocation done
1:720  0:000  old FADT length=114
1:720  0:000   SignatureFixup: 0x8E7D179D -> 0x0
1:720  0:000  Apply DsdtFixMask=0x00000004
1:720  0:000     drop _DSM mask=0xFFFF
1:720  0:000  === [ FixBiosDsdt ] =======================================
1:720  0:000    0 replacements
1:721  0:000  PreCleanup XSDT: count=23, length=220
1:721  0:000  PreCleanup XSDT, corrected XSDT: count=23, length=220
1:721  0:000  === [ ACPIDropTables ] ====================================
1:721  0:000    0 replacements
1:721  0:000    0 replacements
1:721  0:000  Found OperationRegion(SANV, SystemMemory, 7638D418, ...)
1:722  0:000    0 replacements
1:722  0:000    0 replacements
1:722  0:000    0 replacements
1:722  0:000    0 replacements
1:722  0:000  Found OperationRegion(PNVS, SystemMemory, 67896000, ...)
1:722  0:000    0 replacements
1:722  0:000    0 replacements
1:722  0:000    0 replacements
1:722  0:000    0 replacements
1:722  0:000  === [ ACPIPatchedAML ] ====================================
1:722  0:000  Unsorted
1:722  0:000  Inserting SSDT-UIAC.aml from EFI\CLOVER\ACPI\patched: size=699 ... Success
1:722  0:000  Inserting SSDT-USBX.aml from EFI\CLOVER\ACPI\patched: size=185 ... Success
1:722  0:000  ApicCPUNum=1
1:722  0:000  Maximum control=0x24
1:722  0:000  Turbo control=0x32
1:722  0:000  P-States: min 0x8, max 0x32
1:722  0:000  SSDT with plugin-type without P-States is generated
1:722  0:000  Cleanup XSDT: count=26, length=244
1:722  0:000  corrected XSDT count=26, length=244
1:722  0:000  === [ RestSetup macOS ] ===================================
1:722  0:000  EdidDiscovered size=128
1:722  0:000  --- Discovered EDID Table size:128
1:722  0:000  000  |  00  FF  FF  FF  FF  FF  FF  00  06  10
1:722  0:000  010  |  21  92  53  16  01  02  2E  11  01  03
1:722  0:000  020  |  80  40  28  78  28  FE  85  A3  57  4A
1:722  0:000  030  |  9C  25  13  50  54  00  00  00  01  01
1:722  0:000  040  |  01  01  01  01  01  01  01  01  01  01
1:722  0:000  050  |  01  01  01  01  BC  1B  00  A0  50  20
1:722  0:000  060  |  17  30  30  20  36  00  81  91  21  00
1:722  0:000  070  |  00  1A  B0  68  00  A0  A0  40  2E  60
1:722  0:000  080  |  30  20  36  00  81  91  21  00  00  1A
1:722  0:000  090  |  00  00  00  FF  00  43  59  37  34  36
1:722  0:000  100  |  30  30  36  58  4D  50  0A  00  00  00
1:722  0:000  110  |  00  FC  00  43  69  6E  65  6D  61  20
1:722  0:000  120  |  48  44  0A  00  00  00  01  EC
1:722  0:000  add device: PciRoot(0x0)/Pci(0x2,0x0)
1:722  0:000     Add key=device-id valuelen=4
1:722  0:000     Add key=AAPL,ig-platform-id valuelen=4
1:722  0:000  ATI injection not set
1:722  0:000  Intel GFX injection not set
1:722  0:000   RCBA disabled; cannot use it
1:723  0:000  stringlength = 366
1:723  0:000  CurrentMode: Width=2560 Height=1600
1:723  0:000  Beginning FSInjection
1:723  0:000   - ERROR: gFSInjectProtocolGuid not found!
1:738  0:015  Use origin smbios table type 1 guid.
1:745  0:007  Preparing kexts injection for arch=x86_64 from EFI\CLOVER\kexts\Other
1:745  0:000  ->Extra kext: EFI\CLOVER\kexts\Other\Lilu.kext.dSYM (v.<null string>)
1:748  0:003  Failed to load extra kext (Info.plist not found): EFI\CLOVER\kexts\Other\Lilu.kext.dSYM
1:748  0:000  ->Extra kext: EFI\CLOVER\kexts\Other\AirportBrcmFixup.kext.dSYM (v.<null string>)
1:750  0:001  Failed to load extra kext (Info.plist not found): EFI\CLOVER\kexts\Other\AirportBrcmFixup.kext.dSYM
1:750  0:000  ->Extra kext: EFI\CLOVER\kexts\Other\AppleALC.kext.dSYM (v.1.4.3)
1:752  0:002  ->Extra kext: EFI\CLOVER\kexts\Other\WhateverGreen.kext.dSYM (v.1.3.4)
1:754  0:002  ->Extra kext: EFI\CLOVER\kexts\Other\IntelMausi.kext (v.1.0.2)
1:762  0:007  ->Extra kext: EFI\CLOVER\kexts\Other\BrcmNonPatchRAM2.kext (v.2.2.10)
1:771  0:009  ->Extra kext: EFI\CLOVER\kexts\Other\FakePCIID.kext (v.1.3.15)
1:777  0:005  ->Extra kext: EFI\CLOVER\kexts\Other\FakePCIID_Broadcom_WiFi.kext (v.1.3.15)
1:782  0:005  ->Extra kext: EFI\CLOVER\kexts\Other\BrcmPatchRAM2.kext (v.2.2.10)
1:841  0:059  ->Extra kext: EFI\CLOVER\kexts\Other\BrcmFirmwareData.kext (v.2.2.10)
1:851  0:009  ->Extra kext: EFI\CLOVER\kexts\Other\SATA-200-series-unsupported.kext (v.0.5.1)
1:854  0:003  ->Extra kext: EFI\CLOVER\kexts\Other\FakeSMC.kext (v.1800)
1:866  0:011  ->Extra kext: EFI\CLOVER\kexts\Other\FakeSMC_CPUSensors.kext (v.1800)
1:874  0:008  ->Extra kext: EFI\CLOVER\kexts\Other\FakeSMC_GPUSensors.kext (v.1800)
1:884  0:010  ->Extra kext: EFI\CLOVER\kexts\Other\FakeSMC_ACPISensors.kext (v.1800)
1:898  0:014  ->Extra kext: EFI\CLOVER\kexts\Other\AirportBrcmFixup.kext (v.2.0.6)
1:909  0:011  ->Extra kext: EFI\CLOVER\kexts\Other\IntelMausiEthernet.kext (v.2.4.1d1)
1:916  0:007  ->Extra kext: EFI\CLOVER\kexts\Other\FakeSMC_LPCSensors.kext (v.1800)
2:046  0:129  ->Extra kext: EFI\CLOVER\kexts\Other\WhateverGreen.kext (v.1.3.7)
2:057  0:010  ->Extra kext: EFI\CLOVER\kexts\Other\AppleALC.kext (v.1.4.7)
2:659  0:602  ->Extra kext: EFI\CLOVER\kexts\Other\FakeSMC_SMMSensors.kext (v.1800)
2:673  0:013  ->Extra kext: EFI\CLOVER\kexts\Other\Lilu.kext (v.1.4.2)
2:683  0:009  Preparing kexts injection for arch=x86_64 from EFI\CLOVER\kexts\Off
2:683  0:000  Preparing kexts injection for arch=x86_64 from EFI\CLOVER\kexts\10
2:683  0:000  Preparing kexts injection for arch=x86_64 from EFI\CLOVER\kexts\10_normal
2:683  0:000  Preparing kexts injection for arch=x86_64 from EFI\CLOVER\kexts\10.14
2:683  0:000  Preparing kexts injection for arch=x86_64 from EFI\CLOVER\kexts\10.14_normal
2:683  0:000  Preparing kexts injection for arch=x86_64 from EFI\CLOVER\kexts\10.14.6
2:683  0:000  Preparing kexts injection for arch=x86_64 from EFI\CLOVER\kexts\10.14.6_normal
2:685  0:002  SetScreenResolution: 2560x1600 - already set
2:685  0:000  Custom boot is disabled
 
Joined
Oct 25, 2018
Messages
12
Motherboard
ASUS ROG Strix Z370-I Gaming
CPU
i7 8700K
Graphics
Rx 5700 XT
Mac
  1. iMac
  2. Mac Pro
Ok, your configuration ist not the same then my or did you also replace the wlan module ?

--> WALN / BCM94352Z; AC 40Mhz is working - 80Mhz sometimes / If you do not replaced the wlan module.
I suggest to disable the wlan+bluetooth module / remove all bcm* kex and still use the rest of my EFI without them..
you need to plug in a usb keyboard and mouse

BUT wait you didn't had to change your card network by other one to have the Bluetooth and the wifi working ?
I can put the original card back and that should work normally
 
Joined
Aug 29, 2020
Messages
2
Motherboard
ASUS Z370
CPU
i7-8700
Graphics
Intel version # > See Rules!
Did someone manage to get the sleep/wakeup to work on this build?
 
Joined
Apr 14, 2014
Messages
48
Motherboard
ASUS ROG STRIX Z370-I GAMING
CPU
i7-8700K
Graphics
RX 580
Mobile Phone
  1. Android
  2. iOS
Hello, I've recently updated to Big Sur and OpenCore, everything went smooth, except for the FixShutdown option. Does anyone have the proper SSDT for that?
 
Joined
Nov 28, 2018
Messages
78
Motherboard
asus z370-i
CPU
i7-9700k
Graphics
RX 580
Mac
  1. iMac
  2. MacBook
  3. Mac Pro
Classic Mac
  1. Apple
Mobile Phone
  1. iOS
Hello, I've recently updated to Big Sur and OpenCore, everything went smooth, except for the FixShutdown option. Does anyone have the proper SSDT for that?
Did that as well, no big issues so far. DRM is known to be brocken. Someone interested how I did it ?
 
Joined
Jan 9, 2019
Messages
14
Motherboard
ASUS Strix Rog z370-i Gaming
CPU
Intel Core i7-8700K 3,60GHz Boxed CPU
Graphics
AMD Sapphire 8 GB RX580 PULSE 8G 2x H, 2x DP, DVI
Did that as well, no big issues so far. DRM is known to be brocken. Someone interested how I did it ?
Definitely interested in your approach! Would be great if you'd take the time to share your process.

I'm about to take the leap to OC aswell but I'm currently unsure as to whether I should just "replace" the Clover-EFI with the OC-EFI (which I would create according to the dortania-guide of course) and keep my current SMBIOS information (serail, etc.) or whether I should create a completely new system with a new SN on a new harddrive. Did you experience any issues moving your current SMBIOS-data into the OpenCore-EFI? Thinking about stuff like iMessage etc. and I read that some users can't use the AppStore after the upgrade…
 
Top