Contribute
Register

SPDIF onboard digital audio from Realtek -- best option?

Status
Not open for further replies.
Joined
Oct 25, 2011
Messages
20
Motherboard
Asus PRIME B250M-A
CPU
i5-7600
Graphics
Radeon RX 5700 XT
Classic Mac
  1. iBook
  2. Power Mac
  3. Quadra
  4. SE
Mobile Phone
  1. iOS
I'm using 10.12.6 with ASUS PRIME B250M-A motherboard, which has the ALC887 chipset. I have sound working with multibeast realtek audio, but it only provides sound when I use the "Internal Speakers" (actually it's the green port) output option in System Preferences > Sound. I'd really like to get digital output to my receiver like I had on my previous hackintosh. I hooked up a SPDIF Optical and RCA Out Plate Cable Bracket to the motherboard's SPDIF wire connector but I can't get it to output anything in macOS.

I found https://github.com/toleda/audio_ALC_guides/blob/master/Customization.pdf and I *think* procedure 7 describes a mod that does what I want. However I'm not sure if the instructions are up to date for Sierra, and more to the point, I tried modifying my AppleHDA.kext in /S/L/E (just replacing integers 30 and 6 with 17 and 16 everywhere they appeared), and what I do that either the driver doesn't load, or it fails in some other way such that all my output devices disappear from System Preferences > Sound > Output, and then I have to reinstall multibeast realtek audio to restore even analog sound.

Does anyone have experience with using the onboard SPDIF connection with a realtek chipset and macOS Sierra? Does the AppleHDA customization work if applied correctly? Or is there a Clover based solution to patch it? I'd be happy to post extra diagnostic information if it would help.
 
Joined
Oct 25, 2011
Messages
20
Motherboard
Asus PRIME B250M-A
CPU
i5-7600
Graphics
Radeon RX 5700 XT
Classic Mac
  1. iBook
  2. Power Mac
  3. Quadra
  4. SE
Mobile Phone
  1. iOS
Yes. Sierra, yes.
Do all the steps, edit the correct entries

Great, glad to know I am on the right track. How do I know which PathMapID corresponds to my unit? My Platforms.xml file has 74 PathMapID entries and the instructions say only "Open the current SPDIFOut (last item)". But the last PathMapID in my Platforms.xml does not have the corresponding NodeID numbers.
 
Joined
Oct 25, 2011
Messages
20
Motherboard
Asus PRIME B250M-A
CPU
i5-7600
Graphics
Radeon RX 5700 XT
Classic Mac
  1. iBook
  2. Power Mac
  3. Quadra
  4. SE
Mobile Phone
  1. iOS
Do not touch the .xml files, edit the .zml files as noted.

Thanks toleda. Customization.pdf says "Edit Platforms.xml/zml" so I assumed that meant I needed to edit both files. Now that I see how the zml files works it makes sense I would only edit that.

According to System Information/Audio/Intel High Definition Audio my Audio ID is 2. And my CodecID is 0x10ec0887. So if I am understanding Customization.pdf appendix B correctly that means I should edit the entry with PathMapId = 287 (Item 2). I edited that in Platforms.zml.zlib and restored the original Platforms.xml.zlib and installed my new AppleHDA.kext with KextBeast. The result is unfortunately the same: "Internal Speakers" works but "Digital Out" does not. Just to double check I also tried editing Item 1 / PathMapID 887 and the result is the same. (note that if I apply the edits to both PathMapIDs at the same time the system boots with no audio output devices.) Is there any way to verify whether the zml is having the intended effect? I am not sure how to diagnose from here. Thanks again.
 

toleda

Moderator
Joined
May 19, 2010
Messages
22,921
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. 512K
  2. LC
  3. Power Mac
Mobile Phone
  1. iOS
Joined
Oct 25, 2011
Messages
20
Motherboard
Asus PRIME B250M-A
CPU
i5-7600
Graphics
Radeon RX 5700 XT
Classic Mac
  1. iBook
  2. Power Mac
  3. Quadra
  4. SE
Mobile Phone
  1. iOS
Did you edit RealtekALC.kext/Contents/Info.plist?

I used PlistEdit Pro to apply the two patches to (starting with RealtekALC.kext 2.1) RealtekALC.kext/Contents/Info.plist under HDAConfigDefault/2, which is the one that has CodecID = 283904135 and LayoutID = 2
Find: 21171cf0 21171d00 21171e00 21171f40
Replace: 21171ca0 21171d01 21171e43 21171f99
Find: 21e71c90 21e71d61 21e71e4b 21e71f01
Replace: 21e71cf0 21e71d00 21e71e00 21e71f40

But after installing the new kext and rebooting I am back to having no Sound output devices. :(
 
Joined
Oct 25, 2011
Messages
20
Motherboard
Asus PRIME B250M-A
CPU
i5-7600
Graphics
Radeon RX 5700 XT
Classic Mac
  1. iBook
  2. Power Mac
  3. Quadra
  4. SE
Mobile Phone
  1. iOS
Attached the edited (uncompressed) Platforms.xml and Info.plist files

Attached are my edited RealtekALC.kext/Contents/Info.plist and AppleHDA.kext/Contents/Resources/Platforms.zml.zlib files. The latter has been inflated and renamed to allow uploading. Thanks for looking.
 

Attachments

  • Info.plist
    12.1 KB · Views: 351
  • Platforms.txt
    171.8 KB · Views: 410
Status
Not open for further replies.
Top