Contribute
Register

Sound on 10.13 Realtek ALC256?

Status
Not open for further replies.
Joined
Jul 15, 2016
Messages
60
Motherboard
Dell V33HM
CPU
i7-6500u
Graphics
Intel® HD Graphics 520
Mac
  1. MacBook
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Has anyone here managed to get sound working?

I'm using a Realtek ALC256 (I think) and can't find anything on it for High Sierra 10.13. Any Suggestions on what to do?
 
Joined
Feb 20, 2017
Messages
80
Motherboard
HP Spectre x360 13-ap0xxx
CPU
i5-8265u
Graphics
UHD 620, 1920x1080
Classic Mac
  1. iMac
Mobile Phone
  1. Android
Has anyone here managed to get sound working?

I'm using a Realtek ALC256 (I think) and can't find anything on it for High Sierra 10.13. Any Suggestions on what to do?

Try AppleALC kext, install to clover kexts folder, use boot flag '-alcbeta'. ALC256 is under supported codecs. Inject layout id 13 through config.plist. If your layout differs do a codec dump from linux.
 
Joined
Jul 15, 2016
Messages
60
Motherboard
Dell V33HM
CPU
i7-6500u
Graphics
Intel® HD Graphics 520
Mac
  1. MacBook
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Try AppleALC kext, install to clover kexts folder, use boot flag '-alcbeta'. ALC256 is under supported codecs. Inject layout id 13 through config.plist. If your layout differs do a codec dump from linux.
Where can I find said kext? Is it here?
 
Joined
May 30, 2011
Messages
123
Motherboard
Gigabyte Aero 15W V8
CPU
i7-8750H
Graphics
HD 630
Mobile Phone
  1. Android
  2. iOS
all you need
AppleALC + Lilu + CodecCommander + SSDT-ALC256.aml

install CodecCommander to L/E or S/L/E
remove all applehda patches in clover config
Devices\Inject\Audio\13
boot with -lilubeta -alcbeta argument
 
Joined
Jul 15, 2016
Messages
60
Motherboard
Dell V33HM
CPU
i7-6500u
Graphics
Intel® HD Graphics 520
Mac
  1. MacBook
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
all you need
AppleALC + Lilu + CodecCommander + SSDT-ALC256.aml

install CodecCommander to L/E or S/L/E
remove all applehda patches in clover config
Devices\Inject\Audio\13
boot with -lilubeta -alcbeta argument
Didn't seem to work. All the kexts loaded in the following order:
Lilu, AppleALC, CodecCommander, and finally AppleHDA. I simply dragged and dropped the SSDT-ALC256.aml into ESP/EFI/CLOVER/ACPI/Patched/
Am I missing something? (and yeah, boot args were overall "-v darwake=0 -lilubeta -alcbeta" with all KextsToPatch entries with HDA in them (5 in total) were all deleted)
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
184,623
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Didn't seem to work. All the kexts loaded in the following order:
Lilu, AppleALC, CodecCommander, and finally AppleHDA. I simply dragged and dropped the SSDT-ALC256.aml into ESP/EFI/CLOVER/ACPI/Patched/
Am I missing something? (and yeah, boot args were overall "-v darwake=0 -lilubeta -alcbeta" with all KextsToPatch entries with HDA in them (5 in total) were all deleted)

Read FAQ, "Problem Reporting"
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
 
Joined
May 30, 2011
Messages
123
Motherboard
Gigabyte Aero 15W V8
CPU
i7-8750H
Graphics
HD 630
Mobile Phone
  1. Android
  2. iOS
try to rebuild kext cache and reboot

sudo kextcache -i /
 
Joined
Jul 15, 2016
Messages
60
Motherboard
Dell V33HM
CPU
i7-6500u
Graphics
Intel® HD Graphics 520
Mac
  1. MacBook
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
try to rebuild kext cache and reboot

sudo kextcache -i /
nope, no luck. I think I've messed up somewhere along the road. I've done what you did before and gotten the audio working but I fear I may have possibly patched my official AppleHDA when I shouldn't have or something so I'll try re-extracting it from the installation file. I'm going to start again and maybe look into also using VoodoHDA as suggested in RehabMan's link
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
184,623
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
nope, no luck. I think I've messed up somewhere along the road. I've done what you did before and gotten the audio working but I fear I may have possibly patched my official AppleHDA when I shouldn't have or something so I'll try re-extracting it from the installation file. I'm going to start again and maybe look into also using VoodoHDA as suggested in RehabMan's link

See post #6.
Attach "Problem Reporting" files.
 
Joined
Jul 15, 2016
Messages
60
Motherboard
Dell V33HM
CPU
i7-6500u
Graphics
Intel® HD Graphics 520
Mac
  1. MacBook
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Here's what I think you may need to debug what's going on.

Here are screenshots from terminal for kextstat and kextcache as well as a clover folder (minus themes folder)
Screen Shot 2017-07-05 at 7.30.31 PM.png


note: VoodooHDA was just installed, should I remove it?
 

Attachments

  • CLOVER.zip
    7.4 MB · Views: 235
Status
Not open for further replies.
Top