Contribute
Register

Sound can't work

Joined
Aug 8, 2017
Messages
33
Motherboard
ThundeRobot-G150T-D1a
CPU
I7-6700HQ
Graphics
HD530 + GTX965M 1920 x 1080
cpu:I7-6700HQ
gpu:hd530
Sound card:ALC269
-alcdbg -liludbg log:
2019-03-17 04:39:02.670036-0700 localhost kernel[0]: calling mpo_policy_init for Lilu
2019-03-17 04:39:02.670039-0700 localhost kernel[0]: Security policy loaded: Lilu Kernel Extension 1.3.4 (Lilu)
2019-03-17 04:39:05.562308-0700 localhost kernel[0]: (kernel) Lilu: patcher @ lookup patching applied only 1 patches out of 0
2019-03-17 04:39:05.614030-0700 localhost kernel[0]: (kernel) AppleALC: alc @ failed to find IOHDACodecVendorID, retrying 0
2019-03-17 04:39:05.616300-0700 localhost kernel[0]: (kernel) Lilu: patcher @ lookup patching applied only 0 patches out of 1
 

Attachments

Feartech

Moderator
Joined
Aug 3, 2013
Messages
11,252
Motherboard
Asus N752VX-Clover
CPU
i7-6700HQ / HM170
Graphics
HD530 + GTX 950m 1920 x 1080
Mac
iMac
Mobile Phone
Android
cpu:I7-6700HQ
gpu:hd530
Sound card:ALC269
-alcdbg -liludbg log:
2019-03-17 04:39:02.670036-0700 localhost kernel[0]: calling mpo_policy_init for Lilu
2019-03-17 04:39:02.670039-0700 localhost kernel[0]: Security policy loaded: Lilu Kernel Extension 1.3.4 (Lilu)
2019-03-17 04:39:05.562308-0700 localhost kernel[0]: (kernel) Lilu: patcher @ lookup patching applied only 1 patches out of 0
2019-03-17 04:39:05.614030-0700 localhost kernel[0]: (kernel) AppleALC: alc @ failed to find IOHDACodecVendorID, retrying 0
2019-03-17 04:39:05.616300-0700 localhost kernel[0]: (kernel) Lilu: patcher @ lookup patching applied only 0 patches out of 1
try enabling these:
Code:
<key>Comment-IRQ Fix</key>
                <string>The following fixes may be needed for onboard audio/USB/etc</string>
                <key>FixHDA</key>
                <false/>
                <key>FixHPET</key>
                <false/>
                <key>FixIPIC</key>
                <false/>
                <key>FixRTC</key>
                <false/>
                <key>FixTMR</key>
                <false/>
and enable these: (remove the #'s
Code:
<key>PciRoot(0)/Pci(0x1f,3)</key>
            <dict>
                <key>#hda-gfx</key>
                <string>onboard-1</string>
                <key>#layout-id</key>
                <integer>3</integer>
                <key>#no-controller-patch</key>
                <integer>1</integer>
            </dict>
        </dict>
 
Joined
Aug 8, 2017
Messages
33
Motherboard
ThundeRobot-G150T-D1a
CPU
I7-6700HQ
Graphics
HD530 + GTX965M 1920 x 1080
try enabling these:
Code:
<key>Comment-IRQ Fix</key>
                <string>The following fixes may be needed for onboard audio/USB/etc</string>
                <key>FixHDA</key>
                <false/>
                <key>FixHPET</key>
                <false/>
                <key>FixIPIC</key>
                <false/>
                <key>FixRTC</key>
                <false/>
                <key>FixTMR</key>
                <false/>
and enable these: (remove the #'s
Code:
<key>PciRoot(0)/Pci(0x1f,3)</key>
            <dict>
                <key>#hda-gfx</key>
                <string>onboard-1</string>
                <key>#layout-id</key>
                <integer>3</integer>
                <key>#no-controller-patch</key>
                <integer>1</integer>
            </dict>
        </dict>
After the modification, the log becomes
2019-03-17 05:21:17.679124-0700 localhost kernel[0]: calling mpo_policy_init for Lilu
2019-03-17 05:21:17.679127-0700 localhost kernel[0]: Security policy loaded: Lilu Kernel Extension 1.3.4 (Lilu)
2019-03-17 05:21:20.544371-0700 localhost kernel[0]: (kernel) Lilu: patcher @ lookup patching applied only 1 patches out of 0
2019-03-17 05:21:20.560238-0700 localhost kernel[0]: (kernel) AppleALC: alc @ failed to obtain device info for analog controller (1)
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
11,252
Motherboard
Asus N752VX-Clover
CPU
i7-6700HQ / HM170
Graphics
HD530 + GTX 950m 1920 x 1080
Mac
iMac
Mobile Phone
Android
After the modification, the log becomes
2019-03-17 05:21:17.679124-0700 localhost kernel[0]: calling mpo_policy_init for Lilu
2019-03-17 05:21:17.679127-0700 localhost kernel[0]: Security policy loaded: Lilu Kernel Extension 1.3.4 (Lilu)
2019-03-17 05:21:20.544371-0700 localhost kernel[0]: (kernel) Lilu: patcher @ lookup patching applied only 1 patches out of 0
2019-03-17 05:21:20.560238-0700 localhost kernel[0]: (kernel) AppleALC: alc @ failed to obtain device info for analog controller (1)
please read the faq for proper hardware profile setup:

How and where to install kexts:
 
Joined
Aug 8, 2017
Messages
33
Motherboard
ThundeRobot-G150T-D1a
CPU
I7-6700HQ
Graphics
HD530 + GTX965M 1920 x 1080
Thank you, I will try again.
 
Joined
Aug 8, 2017
Messages
33
Motherboard
ThundeRobot-G150T-D1a
CPU
I7-6700HQ
Graphics
HD530 + GTX965M 1920 x 1080
please read the faq for proper hardware profile setup:

How and where to install kexts:
After this, it still looks like this.
AppleALC: alc @ failed to find IOHDACodecVendorID
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
11,252
Motherboard
Asus N752VX-Clover
CPU
i7-6700HQ / HM170
Graphics
HD530 + GTX 950m 1920 x 1080
Mac
iMac
Mobile Phone
Android
After this, it still looks like this.
AppleALC: alc @ failed to find IOHDACodecVendorID
Use this tool and upload your problem reporting files:
 
Joined
Aug 8, 2017
Messages
33
Motherboard
ThundeRobot-G150T-D1a
CPU
I7-6700HQ
Graphics
HD530 + GTX965M 1920 x 1080
I am using the hotpatch injection id
 
Joined
Aug 8, 2017
Messages
33
Motherboard
ThundeRobot-G150T-D1a
CPU
I7-6700HQ
Graphics
HD530 + GTX965M 1920 x 1080
The file has been uploaded, thank you
 

Attachments

Feartech

Moderator
Joined
Aug 3, 2013
Messages
11,252
Motherboard
Asus N752VX-Clover
CPU
i7-6700HQ / HM170
Graphics
HD530 + GTX 950m 1920 x 1080
Mac
iMac
Mobile Phone
Android
The file has been uploaded, thank you
please update your hardware profile, missing laptop make and model and also screen resolution in graphics (also mentions hd4000, should that not say HD530???)

see mine for inspiration

<-----

you still haven't enabled these:

Code:
<key>Comment-IRQ Fix</key>
                <string>The following fixes may be needed for onboard audio/USB/etc</string>
                <key>FixHPET</key>
                <false/>
                <key>FixIPIC</key>
                <false/>
                <key>FixRTC</key>
                <false/>
                <key>FixTMR</key>
                <false/>
            </dict>
remove:

Code:
<key>FixHDA</key>

                <false/>
InjectKexts should be set to Detect

MacBookPro13,1 would be a better choice
 
Top