Contribute
Register

Sony Vaio - Sucessful Install - Black Screen on Boot

Joined
Feb 15, 2016
Messages
24
Motherboard
Lenovo A540 - Clover UEFI
CPU
i5-4258U / Haswell
Graphics
HD 5100 1920 x 1080
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. Android
Hi All

I've managed to install Sierra onto a vpcf13m0e I've been gifted.
Boots with graphics via nv_disable=1 , otherwise the HDMI and internal Display do not produce an image.
Even via screenshare on my other Macbook, I cannot produce an image when connected.

Wifi + Bluetooth is sorted
Audio + Graphics to complete!
Graphics is my main priority.

Attached Problem Reporting Files, can provide extra information.
My BIOS (American Megatrends) is severely limited, there's little options to configure, there's nothing to do with the Graphics I can mention that may help there.

Any help is much appreciated.
 

Attachments

  • CLOVER.zip
    3 MB · Views: 187
  • IOReg.zip
    588.2 KB · Views: 116
  • Patchmatic Extract.zip
    18.9 KB · Views: 106
Joined
Jul 18, 2018
Messages
11
Motherboard
Xps L502x
CPU
i7
Graphics
HD3000
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Were you able to solve this?
 
Joined
Feb 15, 2016
Messages
24
Motherboard
Lenovo A540 - Clover UEFI
CPU
i5-4258U / Haswell
Graphics
HD 5100 1920 x 1080
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. Android
Were you able to solve this?
Sadly no, I think the issue was the Display of my Sony Vaio was not supported at the time.
The laptop mobo ended up dying so I got a nice little Asus instead and haven't looked back.
 
Top