Contribute
Register

Sonoma 14.3 on Haswell i5-4690 GA H97-D3H - OC 0.8.5 & OCLP 1.3.0

Sonoma 14.1.1

Screenshot 2023-11-12 at 1.26.15 PM.png
 
Finally, I got the wifi working after so many trials and errors.
I followed some suggestion from the forum and combined the solutions.
Here are the things I added to make wifi works:
  • csr-active-config | data | 03080000
  • boot-args | string | amfi=0x80
  • com.apple.iokit.IOSkywalkFamily blocked
  • IOSkywalk.kext, IO80211FamilyLegacy.kext and AirPortBrcmNIC.kext added in this order
  • AirportBrcmFixup.kext
View attachment 572551View attachment 572552
Congratulations! Did your wifi-setup also work with Apple services, like iMessage?
 
Congratulations! Did your wifi-setup also work with Apple services, like iMessage?
Thank you...
Yes, iMessages FaceTime are working fine...
 
Thank you very much! Sirsasana, finally, I fellow your EFI and got my 4790 and HD4600 in 4K Hackintosh, after long time to struggle with sip-disable.
Thank you again, and thank tonymacx86,thank trs96,thanks everyone in our forums.

截屏2024-01-04 02.28.48.png
 
Last edited:
I get this error message when starting the installation, is it because of the HD 4600 graphics card?
Thank you.
Maybe you could install Monterey first, and then update to Sonoma, just like me.
 
Hi, @Sirsasana Can you share how you install Sonoma successfully?

I installed Monterey on a HP Elitedesk 800 G3. But could launch Sonoma installer even.

Thanks.
 
Hi, @Sirsasana Can you share how you install Sonoma successfully?

I installed Monterey on a HP Elitedesk 800 G3. But could launch Sonoma installer even.

Thanks.
If you have Monterey installed and running, try updating your SMBIOS to at least iMac19,1 and then update the system from System Update
Hopefully this help.

Cheers
 
I'm using MacBookPro14,3 . Doesn't it work?

Thanks.
 
Back
Top