Contribute
Register

Sonnet GE1000LAB-E Presto Gigabit Ethernet card (DRIVER ON BUG REPORT WITH APPLE)

Status
Not open for further replies.
Joined
Sep 1, 2012
Messages
15
Motherboard
Mountain Lion
CPU
GA-Z77-D3SH F8 & i5 3570k
Graphics
EVGA 560ti
Mac
  1. MacBook Pro
Classic Mac
  1. PowerBook
Mobile Phone
  1. iOS
The PDF on this site went away, I guess, but it was there yesterday.

If you are running the card in the subject line, there is a note in the compatibility update for High Sierra that the card uses native drivers in macOS, and it is broken. In my build it shows no installed Ethernet cards. The PDF states that there is a bug report filed with apple to have it fixed.

https://www.sonnettech.com/support/charts/highsierra/index.html

 

pastrychef

Moderator
Joined
May 29, 2013
Messages
17,700
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Vega 56 (Bios flashed to 64)
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
Is this the PDF you were looking for?
 

Attachments

  • macossierra-compatibility-122017.pdf
    86.7 KB · Views: 291
Joined
Sep 1, 2012
Messages
15
Motherboard
Mountain Lion
CPU
GA-Z77-D3SH F8 & i5 3570k
Graphics
EVGA 560ti
Mac
  1. MacBook Pro
Classic Mac
  1. PowerBook
Mobile Phone
  1. iOS
No sorry, that is the compatibility list for Sierra not High Sierra. The link I sent has a broken link to the High Sierra PDF. Hopefully it will be fixed soon. Maybe they are updating it.
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
17,700
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Vega 56 (Bios flashed to 64)
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
Did you look at the PDF?
Screen Shot 2018-02-07 at 9.43.58 PM.png
 
Joined
Sep 1, 2012
Messages
15
Motherboard
Mountain Lion
CPU
GA-Z77-D3SH F8 & i5 3570k
Graphics
EVGA 560ti
Mac
  1. MacBook Pro
Classic Mac
  1. PowerBook
Mobile Phone
  1. iOS
My apologies, you're right! They must have combined the PDFs. Last night i found one for each version of the OS.

If you look at note (5): "The Presto Gigabit Ethernet Pro uses an Apple macOS naive driver. Sonnet has filed a bug report with Apple. "

Hoping they fix this soon. I added this thread as an FYI for anyone else running this card.

(luckily my wifi still works!)
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
17,700
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Vega 56 (Bios flashed to 64)
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
I think that compatibility with the GE1000LAB-E has been broken since 10.13.0. Not sure if compatibility will ever be restored.

You can probably find a NIC that works with IntelMausiEthernet.kext or RealtekRTL8111.kext for pretty cheap now...
 
Joined
Nov 6, 2012
Messages
196
Motherboard
Gigabyte Z390 Aorus Xtreme
CPU
i9-9900
Graphics
RX-580
I think that compatibility with the GE1000LAB-E has been broken since 10.13.0. Not sure if compatibility will ever be restored.

You can probably find a NIC that works with IntelMausiEthernet.kext or RealtekRTL8111.kext for pretty cheap now...


I think some use this board specifically for it's macOS native AVB audio support. My MOTU AVB interface can use the MAC network card for hi resolution audio for recording over the ethernet to other AVB enabled devices/PCs... There is a work around that involves using the older apple driver which i have applied and it works until the next apple update ( like many hackintosh solutions ) i got that information from another thread here.
 
Joined
Nov 6, 2012
Messages
196
Motherboard
Gigabyte Z390 Aorus Xtreme
CPU
i9-9900
Graphics
RX-580
This appears to work with latest update without rolling back to Sierra driver
 
Joined
Nov 6, 2012
Messages
196
Motherboard
Gigabyte Z390 Aorus Xtreme
CPU
i9-9900
Graphics
RX-580
Both my machines are still working after 10.13.4 update
 
Joined
Sep 1, 2012
Messages
15
Motherboard
Mountain Lion
CPU
GA-Z77-D3SH F8 & i5 3570k
Graphics
EVGA 560ti
Mac
  1. MacBook Pro
Classic Mac
  1. PowerBook
Mobile Phone
  1. iOS
I just applied the update and the network card is now showing but is saying that the cable is disconnected. I'll try a new cable when i can dig one out of storage.
 
Status
Not open for further replies.
Top