Contribute
Register

Solving NVIDIA Driver Install & Loading Problems

Joined
Jul 27, 2015
Messages
13
Motherboard
Asus Sabertooth Z97 mk1
CPU
Intel i7 4790k
Graphics
GeForce gtx750 ti sc
Mac
Classic Mac
Mobile Phone
Solving NVIDIA driver install problems

I'm having an issue with the Nvidia driver not working. After installing OS X 10.10.4 using Clover r.3320 I shut down the machine to install my GTX750ti SC card and it would not boot up, just would cycle to clover boot screen. I removed the card and installed the OS X Default Graphics Driver 346.02.02f01 and got it to boot with the card but can only get 1024 x 768 graphics to my Apple 30" Cinema display. Looked at system info and under graphics it looks like there isn't a driver loaded?

I also upgraded to OS X 10.10.5 and Graphics Driver 346.02.03f01 and have the same issue.

Asus Z97 Sabertooth mk1, i7 4790k 4ghz, 32gb Corsair Vengance ram, EVGA GeForce GTX750ti SC.

Any ideas? I also noticed there is no build number on "About this Mac".
 

Attachments

  • Screen Shot 2015-11-15 at 11.58.49 AM.png
    Screen Shot 2015-11-15 at 11.58.49 AM.png
    154.5 KB · Views: 97
  • Screen Shot 2015-11-16 at 5.58.35 AM.png
    Screen Shot 2015-11-16 at 5.58.35 AM.png
    56.2 KB · Views: 93
Joined
Jul 27, 2015
Messages
13
Motherboard
Asus Sabertooth Z97 mk1
CPU
Intel i7 4790k
Graphics
GeForce gtx750 ti sc
Mac
Classic Mac
Mobile Phone
Solving NVIDIA driver install problems

My build number doesn't match the list for problem #2. I'm running OS X 10.10.5 and I get this error:
 

Attachments

  • Screen Shot 2015-11-17 at 2.15.35 PM.png
    Screen Shot 2015-11-17 at 2.15.35 PM.png
    62.8 KB · Views: 105
  • Screen Shot 2015-11-17 at 2.11.19 PM.png
    Screen Shot 2015-11-17 at 2.11.19 PM.png
    65.8 KB · Views: 99
Joined
Jul 27, 2015
Messages
13
Motherboard
Asus Sabertooth Z97 mk1
CPU
Intel i7 4790k
Graphics
GeForce gtx750 ti sc
Mac
Classic Mac
Mobile Phone

slim.jim

Moderator
Joined
Dec 17, 2014
Messages
4,258
Motherboard
MSI Z97 Gaming 9 AC
CPU
i7-4790K
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
Classic Mac
  1. PowerBook
Mobile Phone
  1. iOS
Solving NVIDIA driver install problems

Thanks for the response Slim.jim

I tried running 346.02.03.f02 and I still have the issue of only 1024 x 768 graphics resolution.

Any clues?

Post your config file
 
Joined
Jul 27, 2015
Messages
13
Motherboard
Asus Sabertooth Z97 mk1
CPU
Intel i7 4790k
Graphics
GeForce gtx750 ti sc
Mac
Classic Mac
Mobile Phone

Attachments

  • config.plist
    4.4 KB · Views: 215
Joined
Jul 18, 2015
Messages
62
Motherboard
GA Z97X UD7 TH
CPU
Intel i7 4790K
Graphics
Gigabyte GTX 1050 TI Windforce
Solving NVIDIA driver install problems

Hi!

Having issues with Gigabyte GTX 960 G1 Gaming 4 GB GDDR5. Running El Capitan 10.11.1 from clean install.
Don't have any of the 4 problems described here. This is my config View attachment config.plist

But in summary is this:
iMac14,2
Boot arguments: nvda_drv=1 cpus=1

Inject NVidea: False
I tried selecting it (checked on Clover Configurator) also and there was no difference.

I managed to install de Web Drivers for Nvidia and also CUDA.
In NVIDIA Graphics Manager I have selected OSX Default Graphics Driver. Shows nothing on Slots of ECC

Using Display Port and HDMI ports this is what I get:
OsxAptioFixDrv : Starting overrides for System/Library/CoreServices/boot.efi
Error Allocating 0x166dd pages at 0x00000000101ae000 alloc type 2
Couldn't allocate runtime area
Boot failed, sleeping for 10 seconds before exiting...

Help please!
 
Last edited:

slim.jim

Moderator
Joined
Dec 17, 2014
Messages
4,258
Motherboard
MSI Z97 Gaming 9 AC
CPU
i7-4790K
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
Classic Mac
  1. PowerBook
Mobile Phone
  1. iOS
Solving NVIDIA driver install problems

Hi!

Having issues with Gigabyte GTX 960 G1 Gaming 4 GB GDDR5. Running El Capitan 10.11.1 from clean install.
Don't have any of the 4 problems described here. This is my config View attachment 162845

But in summary is this:
iMac14,2
Boot arguments: nvda_drv=1 cpus=1

Inject NVidea: False
I tried selecting it (checked on Clover Configurator) also and there was no difference.

I managed to install de Web Drivers for Nvidia and also CUDA.
In NVIDIA Graphics Manager I have selected OSX Default Graphics Driver. Shows nothing on Slots of ECC

Using Display Port and HDMI ports this is what I get:


Help please!

Your problem isn't graphics related.
 
Joined
Sep 28, 2011
Messages
14
Motherboard
Not sure
CPU
i7 4790K
Graphics
Nvidia 980m
Mac
Classic Mac
Mobile Phone
Solving NVIDIA driver install problems

Hope someone can help me out, it feels like I'm so close.

I have tried just about everything on this thread but still no success. Here is the scenario thus far:

Done all updates, everything is current. System is a laptop, and works great when using the native OS X video driver. When I switch to the nvidia driver, the built in laptop screen turns off. However, if I use an external monitor, it works fine. It is as if the OS cannot find the laptop screen with nvidia enabled. I have tried detecting displays in the system prefs but the OS cannot find the laptop screen. But when using the native driver it does detect the laptop screen.

Any suggestions? Any help is greatly appreciated.
 

P1LGRIM

Moderator
Joined
Mar 2, 2012
Messages
25,604
Motherboard
Lenovo ThinkStation p700
CPU
2x E5-2620 V3
Graphics
RX 560
Mac
  1. MacBook Pro
  2. Mac mini
Classic Mac
  1. Power Mac
Mobile Phone
  1. iOS
Solving NVIDIA driver install problems

Any suggestions? Any help is greatly appreciated.

For Laptop issues post in the relevant Laptop forum.
 
Top