Contribute
Register

Solving NVIDIA Driver Install & Loading Problems

Joined
Aug 25, 2016
Messages
25
Motherboard
Z170 Pro Gaming
CPU
i7 > need model # > See Rules!
Graphics
GTX 1060
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
Hi, I can't seem to fix the black screen after boot. The only way I'm able to boot up is to hook up the monitor via HDMI to onboard graphics and pull it out once it's booted. I've tried the Lilu.kext and NvidiaGraphicsFixup.kext. Also Shilohh's AGDPfix. But no sucess so far :( Any ideas ?

System:
Asus Z170 Pro Gaming
i7 6700k
GTX 1060
950 Pro Boot drive
 

Attachments

  • EFI.zip
    37.4 MB · Views: 68

slim.jim

Moderator
Joined
Dec 17, 2014
Messages
4,291
Motherboard
MSI Z97 Gaming 9 AC
CPU
i7-4790K
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
Classic Mac
  1. PowerBook
Mobile Phone
  1. iOS
Hi, I can't seem to fix the black screen after boot. The only way I'm able to boot up is to hook up the monitor via HDMI to onboard graphics and pull it out once it's booted. I've tried the Lilu.kext and NvidiaGraphicsFixup.kext. Also Shilohh's AGDPfix. But no sucess so far :( Any ideas ?

System:
Asus Z170 Pro Gaming
i7 6700k
GTX 1060
950 Pro Boot drive

What kind of connection to your monitor are you using? Are you using any adapters?
 
Joined
Aug 25, 2016
Messages
25
Motherboard
Z170 Pro Gaming
CPU
i7 > need model # > See Rules!
Graphics
GTX 1060
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
What kind of connection to your monitor are you using? Are you using any adapters?

Nope just a straight displayport cable...
 
Joined
Aug 25, 2016
Messages
25
Motherboard
Z170 Pro Gaming
CPU
i7 > need model # > See Rules!
Graphics
GTX 1060
Mac
  1. MacBook Pro
Mobile Phone
  1. Android

slim.jim

Moderator
Joined
Dec 17, 2014
Messages
4,291
Motherboard
MSI Z97 Gaming 9 AC
CPU
i7-4790K
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
Classic Mac
  1. PowerBook
Mobile Phone
  1. iOS
You're a genius ! Any idea why this fixes it though ? Thanks !!

Not really sure to be honest. For some monitors is seems to be an issue but I am not sure how to fix it and haven't seen a solution. For my Dell monitor DP1.2 has always worked fine.
 
Joined
Jan 30, 2011
Messages
83
Motherboard
GA-H87N-WIFI
CPU
i3-3225
Graphics
HD 4000
Mac
  1. Mac mini
Classic Mac
  1. Apple
Mobile Phone
  1. iOS
  2. Other
Pascal Support is HERE!
Please let me know of any other errors you are encountering and I will update this post with solutions.
Thank you for the guide, i have gone trough the most the fix options, but i am still where i was at the beginning, without updating clover (from 3377 to 4061), without editing the kexts, nor the plist...

So i get the card recognized even without any updates (except to 10.12.4 + nVidia driver). see attached the screenshot. Only issue is (no errors btw) that my screen does go blank, no signal is going out on DVI :( the screenshot below is taken connecting remotely to my machine. Is there a way to know or to redirect video output? i don't know if this is the right question at all... :( Pascal-not-working.png
 
Joined
Jan 15, 2014
Messages
62
Motherboard
GA-Z87X-OC
CPU
i7 4770K
Graphics
GTX 1060 OC 6GB
Hi,

I installed a GTX 1060 6GB. I found the matching drivers (346.02.03f12) to my Yosemite 10.10.5 Installation and installed them succesfully (Nvidia Driver Manager says Up to Date). But when I restart the whole OS is very jittery and slow and in the system profiler my new card doesn't show up. GraphicEnabler is set to NO. I also tried with the bootflag. Please Help.
 

P1LGRIM

Moderator
Joined
Mar 2, 2012
Messages
24,231
Motherboard
Lenovo ThinkStation p300 ⌘
CPU
i7-4790K
Graphics
HD 4600
Mac
  1. MacBook Pro
  2. Mac mini
Classic Mac
  1. Power Mac
Mobile Phone
  1. iOS
Hi,

I installed a GTX 1060 6GB. I found the matching drivers (346.02.03f12) to my Yosemite 10.10.5 Installation and installed them succesfully (Nvidia Driver Manager says Up to Date). But when I restart the whole OS is very jittery and slow and in the system profiler my new card doesn't show up. GraphicEnabler is set to NO. I also tried with the bootflag. Please Help.

GTX 10*0 (Pascal) graphics are currently only supported in Sierra.
 
Joined
Jan 15, 2014
Messages
62
Motherboard
GA-Z87X-OC
CPU
i7 4770K
Graphics
GTX 1060 OC 6GB
GTX 10*0 (Pascal) graphics are currently only supported in Sierra.
Thanks alot, somehow I managed to ignore this information. So I will try to update and hope that my systems stays stable.
 
Top