Contribute
Register

Solving NVIDIA Driver Install & Loading Problems

Joined
Jan 26, 2011
Messages
90
Motherboard
GA Z77-D3H
CPU
i5 2500K
Graphics
EVGA GTX 970
Mac
  1. iMac
Solving NVIDIA driver install problems

Sorry
in windows 8.1 funs works well
thanks
 

slim.jim

Moderator
Joined
Dec 17, 2014
Messages
4,220
Motherboard
MSI Z97 Gaming 9 AC
CPU
i7-4790K
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
Classic Mac
  1. PowerBook
Mobile Phone
  1. iOS
Solving NVIDIA driver install problems

thanks for reply
i'm sure booting with nvda_drv=1.
new nvidia WEB DRIVER (346.01.03) add automatically nvda_drv=1. in nvram boot-args

sorry but regarding GraphicsEnabler=No or Inject/NVidia/false.
i dont know how to
I am using ozmosis rom bios therefore, I have not an org.chameleon.Boot.plist
or extra folder.
if you have a solution, I would be very grateful
thank you very much

Ive never used ozmosis. You will probably have better luck over in the insanely Mac forums.
 
Joined
Jan 26, 2011
Messages
90
Motherboard
GA Z77-D3H
CPU
i5 2500K
Graphics
EVGA GTX 970
Mac
  1. iMac
Solving NVIDIA driver install problems

thanks,very very much
 
Joined
Jun 25, 2015
Messages
2
Motherboard
Gigabyte X99 UD4
CPU
Core i7-5820K
Graphics
2x Asus GTX 970 Strx
Mac
Classic Mac
Mobile Phone
Solving NVIDIA driver install problems

Hi,

Sorry if this was answered before in this thread but I'm doing my first hackintosh build and I decided to go the clover build as I'm planning to dual boot with windows. I pretty much followed this tutorial as I have a Gigabyte X99 UD4:
https://www.youtube.com/watch?v=CjMXkB2wMWE

I used different arguements due to having 2 GTX 970s to go through the install phase. Everything went fine until I installed the Nvidia web driver (346.01.03f01) and restarted the computer. All I get is a blank screen when i choose to boot Yosemite now from clover. I'm currently using npci=0x2000 kext-dev-mode=1 nvda_drv=1. Does anyone have any idea how to resolve this?

Thanks!
 

slim.jim

Moderator
Joined
Dec 17, 2014
Messages
4,220
Motherboard
MSI Z97 Gaming 9 AC
CPU
i7-4790K
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
Classic Mac
  1. PowerBook
Mobile Phone
  1. iOS
Solving NVIDIA driver install problems

Try adding PCIrootUID=1 to your boot flags.
 
Joined
Jun 25, 2015
Messages
2
Motherboard
Gigabyte X99 UD4
CPU
Core i7-5820K
Graphics
2x Asus GTX 970 Strx
Mac
Classic Mac
Mobile Phone
Solving NVIDIA driver install problems

Hi Slim Jim, unfortunately that did not work. Same thing happens, just goes to a blank screen.

I used npci=0x2000 kext-dev-mode=1 nvda_drv=1 PCIrootUID=1 which did not work in clover. I used it in chimera from my usb boot drive and it showed the apple sign at least but did not load at all still :(
 
Joined
Jul 2, 2015
Messages
42
Motherboard
ASUS Z97 Pro WiFi AC
CPU
4790K @ 4.7GHz
Graphics
ASUS GTX 960 STRIX 2GB
Mac
  1. MacBook Air
  2. MacBook Pro
Classic Mac
Mobile Phone
Solving NVIDIA driver install problems

I just wanted to say this post literally save my butt! ASUS GTX 960 STRIX, plagued by "Problem 4: Monitor goes to sleep at the end of the boot sequence", managed to sort it out by modifying the AppleGraphicsDevicePolicy.kext. A BIG Thank You!
 

eelhead

Super Moderator
Joined
Mar 1, 2011
Messages
3,113
Motherboard
GA-Z170X-Designare
CPU
i5 7600k
Graphics
GTX 1070
Mac
  1. iMac
  2. MacBook Pro
Classic Mac
  1. iMac
  2. Power Mac
Mobile Phone
  1. iOS
Solving NVIDIA driver install problems

Great job with this mini guide for the GTX 970, I will most likely be putting this to the test sometime tomorrow as my 970 didn't much care for my updating OS X lol.
 

slim.jim

Moderator
Joined
Dec 17, 2014
Messages
4,220
Motherboard
MSI Z97 Gaming 9 AC
CPU
i7-4790K
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
Classic Mac
  1. PowerBook
Mobile Phone
  1. iOS
Top