Contribute
Register

Solving NVIDIA Driver Install & Loading Problems

slim.jim

Moderator
Joined
Dec 17, 2014
Messages
4,258
Motherboard
MSI Z97 Gaming 9 AC
CPU
i7-4790K
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
Classic Mac
  1. PowerBook
Mobile Phone
  1. iOS
Just updated Yosemite from 10.10.1 to 10.10.5, installed latest nVidia drivers, and obviously my GTX960 isnt still found, cause it shows NVIDIA Chip Model 7MB. I am using Chimera with bootflags: kext-dev-mode=1 nvda_drv=1. Also I got "No Device Found" in NVIDIA Driver Manager / ECC and no signal on monitor upon reboot, I've been following the problem 4 and all methods but not work,. In 10.10.1 it works perfectly with above mentioned flags. (i3 3220/msi gtx960 4g/ecs h61h2-mv/iMac15,1/Driver 346.02.03f01) Any ideas ???

I would recommend moving away from Chimera and setup Clover
 
Joined
May 24, 2016
Messages
4
Motherboard
Gigabyte GA-Z170X-UD5 TH
CPU
Core i7-6700K
Graphics
Gigabyte GTX 980 Ti
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
After installing todays security update (10.11.6 15F1004) I had to install the beta driver? 346.03.15b01. my gtx98ti is detected again - only I have still 0 GB VRAM. Strange…
 

slim.jim

Moderator
Joined
Dec 17, 2014
Messages
4,258
Motherboard
MSI Z97 Gaming 9 AC
CPU
i7-4790K
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
Classic Mac
  1. PowerBook
Mobile Phone
  1. iOS
After installing todays security update (10.11.6 15F1004) I had to install the beta driver? 346.03.15b01. my gtx98ti is detected again - only I have still 0 GB VRAM. Strange…

0MB VRAM means you have Inject Nvidia set to True. It should be False.
 
Joined
Jan 1, 2014
Messages
11
Motherboard
GA-Z77-UP5 TH
CPU
i7-3770K
Graphics
GTX 980 Ti
just installed the Yosemite security update after i got it working (DUMB)and tried problem 5 but still not working... I see beta drivers for the el capitan in the thread earlier... Any for Yosemite? I have the 980Ti if that makes a difference.

OS X Version 10.10.5 (14F1912)

If theres just no driver out yet any way to know if it will be coming soon?
 
Joined
May 24, 2016
Messages
4
Motherboard
Gigabyte GA-Z170X-UD5 TH
CPU
Core i7-6700K
Graphics
Gigabyte GTX 980 Ti
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
0MB VRAM means you have Inject Nvidia set to True. It should be False.

…and now everything looks perfect.
Thank you very much!
:thumbup:
 

slim.jim

Moderator
Joined
Dec 17, 2014
Messages
4,258
Motherboard
MSI Z97 Gaming 9 AC
CPU
i7-4790K
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
Classic Mac
  1. PowerBook
Mobile Phone
  1. iOS
just installed the Yosemite security update after i got it working (DUMB)and tried problem 5 but still not working... I see beta drivers for the el capitan in the thread earlier... Any for Yosemite? I have the 980Ti if that makes a difference.

OS X Version 10.10.5 (14F1912)

If theres just no driver out yet any way to know if it will be coming soon?

Full list of Yosemite drivers, including beta drivers can be found here - http://www.insanelymac.com/forum/topic/301416-nvidia-web-driver-updates-for-yosemite/
 
Joined
Jan 1, 2014
Messages
11
Motherboard
GA-Z77-UP5 TH
CPU
i7-3770K
Graphics
GTX 980 Ti

slim.jim

Moderator
Joined
Dec 17, 2014
Messages
4,258
Motherboard
MSI Z97 Gaming 9 AC
CPU
i7-4790K
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
Classic Mac
  1. PowerBook
Mobile Phone
  1. iOS
My OS build isn't listed there as i do not believe Nvidia has made it yet.



What ended up working was editing the NVDAstartup.kext

<key>NVDARequiredOS</key>
<string>14F1909</string>

Change to

<key>NVDARequiredOS</key>
<string>14F1912</string>

And then just repaired disk permissions in disk utility.

I know your OS build isn't listed there but you can always install the beta drivers because they do not check the full build number. They only check the first three characters of the build number, in this case "14F", therefore it works for ALL versions of 10.10.5.

This is the beta driver you want: Nvidia Web Driver - 346.02.03b01
 
Top