Contribute
Register

[Solved] XPS 13 9360 Hackintosh Not Showing Correct Model

Joined
Dec 31, 2013
Messages
3
Motherboard
Dell XPS 13 9360-Clover
CPU
i5-7200U
Graphics
HD 620, 1920x1080
Mobile Phone
  1. iOS
Hi all, I recently converted my late 2016 Dell XPS 13 Core i5 Kaby Lake laptop to a Hackintosh on Sierra 10.12.6 using RehabMan's guide with Clover. I then used the Clover Configurator tool to select the SMBIOS for a MacBook14,1 (Mid 2017 MacBook Pro w/o TouchBar and i5). I have not connected my machine to the internet since I am waiting on the correct WiFi card to come in.

However, viewing the model in About This Mac only shows "MacBook" and does not show the full model info containing "MacBook Pro (Retina, 13-inch, Late 2016)". Problem shown in AboutThisMac.png

Subsequently, the System Report dialog box shows an incomplete model identifier as "MacBookPro1" and not "MacBookPro14,1". It also shows my machine as a MacBook Air and not a Pro. Problem shown in SystemReport.png

How can I address this issue? I have attached screenshots with relevant info highlighted and files as per guide.
 

Attachments

  • AboutThisMac.png
    AboutThisMac.png
    3.6 MB · Views: 384
  • SystemReport.png
    SystemReport.png
    3.2 MB · Views: 358
  • EFI.zip
    2.2 MB · Views: 88
  • Jalen’s MacBook Air.ioreg.zip
    565.9 KB · Views: 29
  • outputerminal.rtf.zip
    2 KB · Views: 34
  • outputterminal2.rtf.zip
    1.1 KB · Views: 32
  • RehabMan.zip
    55 KB · Views: 42
Last edited:

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,161
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Hi all, I recently converted my late 2016 Dell XPS 13 Core i5 Kaby Lake laptop to a Hackintosh on Sierra 10.12.6 using RehabMan's guide with Clover. I then used the Clover Configurator tool to select the SMBIOS for a MacBook14,1 (Mid 2017 MacBook Pro w/o TouchBar and i5). I have not connected my machine to the internet since I am waiting on the correct WiFi card to come in.

However, viewing the model in About This Mac only shows "MacBook" and does not show the full model info containing "MacBook Pro (Retina, 13-inch, Late 2016)". Problem shown in AboutThisMac.png

Subsequently, the System Report dialog box shows an incomplete model identifier as "MacBookPro1" and not "MacBookPro14,1". It also shows my machine as a MacBook Air and not a Pro. Problem shown in SystemReport.png

How can I address this issue? I have attached screenshots with relevant info highlighted and files as per guide.

Dell SMBIOS truncation is common with many recent Dell laptops.

You need config.plist/KernelAndKextPatches/DellSMBIOSPatch=true
 
Joined
Dec 31, 2013
Messages
3
Motherboard
Dell XPS 13 9360-Clover
CPU
i5-7200U
Graphics
HD 620, 1920x1080
Mobile Phone
  1. iOS
Dell SMBIOS truncation is common with many recent Dell laptops.

You need config.plist/KernelAndKextPatches/DellSMBIOSPatch=true

That did the trick, thanks! For others, I changed the “MacBook Air” name by going into System Preferences > Sharing > Computer Name
 
Top