Contribute
Register

[Solved Wifi & HD 520 Graphics] MacOS Sierra booted successfully, help configuring hardware

Status
Not open for further replies.
Joined
Feb 27, 2016
Messages
141
Motherboard
Dell Inspiron 15 i5559-4682SLV Signature Edition
CPU
i5-6200U
Graphics
HD 520
Hi, Since I was trying to install OSX and didn't have the latest OSX 10.11.6 installer, I though I'd give MacOS 10.12 Sierra a try. Please find my specs in my signature.

I've successfully managed to install the OS and install clover on the drive and the computer boots up on its own now, but with FakeID 0x12345678 for the Inject Intel. But it boots without an issue.

I've been trying to get the hardware working one by one, and I'm slowly starting to get the hang of it. But there are 2 things I can't seem to make heads or tails of;
1. GPU(HD 520) : I've read a lot on this and from what I can understand I need to set the DVMT-Prealloc to a higher value. I don't have this setting in the bios, so I'm guessing I'll have to do it through a UEFI Shell. Also I read that, the same can be achieved by patching the IOkit. But I can't seem to find clear instructions on either of them to follow, can someone tell me which method I should use? My Screen is a 1080p TouchScreen.
Fixed by Adjusting the DVMT-Prealloc in Bios through UEFI Shell (All credits go to @cappicard for figuring this out)
Use the following at your own risk. I assume no responsibility. This is for information only.

I extracted the BIOS using the Universal BIOS Backup Toolkit (https://forums.lenovo.com/t5/Lenovo...niversal-BIOS-Backup-ToolKit-2-0/td-p/1205920).

https://github.com/LongSoft/UEFITool/releases. I used UEFI Tool NE. I looked for the entry that's labelled Setup (In my case, it's the GUID of 899407D7-99FE-43D8-9A21-79EC328CAC51 and toward the bottom of the tree). I expanded that. Right-clicked on PE32, and hit Extract Body. That gave me an EFI file.

I then used Universal IFR Extractor (http://donovan6000.blogspot.ca/2014/02/universal-ifr-extractor.html) to convert said EFI file into a text file.

That text file should now have the DVMT values. Just do a text search for "DVMT".

For example:
0x3849A Setting: DVMT Pre-Allocated, Variable: 0x426 {05 91 E3 06 06 07 70 27 01 00 26 04 10 10 01 FE 00}
0x384AB Option: 32M, Value: 0x1 {09 07 E4 06 30 00 01}
0x384B2 Option: 64M, Value: 0x2 {09 07 E5 06 00 00 02}
0x384B9 Option: 96M, Value: 0x3 {09 07 E6 06 00 00 03}
0x384C0 Option: 128M, Value: 0x4 {09 07 E7 06 00 00 04}

The EFI variable is 0x426, and the values are those in blue.

Then, finally you can then boot with EFI Shell (https://www.firewolf.science/wp-content/uploads/2015/04/EFI-shell.zip). Just stick it onto a FAT32 formatted USB stick. In my case, I added a Boot Option via the BIOS to boot to the included bootx64.efi file.

Upon booting to the USB stick, just type in: setup_var 0x426 0x3 (to set DVMT Preallocated to 96MB).

And voila.
Or use the MinStolenSize Patch for Sierra (Less Recommended)
https://www.tonymacx86.com/threads/readme-common-some-unsolved-problems-in-10-12-sierra.202316/
1. Put a fakeID 0x12345678 in my config.plist, enable the minstolensize patch 10.12, force AppleIntelSKLGraphicsFramebuffer.kext to load
2. Boot Sierra WITHOUT CACHES
3. After booting to Sierra rebuild cache with "sudo touch /System/Library/Extensions && sudo kextcache -u /"
4. Replace ig-platform-id 0x12345678 with normal 0x19160000
5. Boot Sierra NORMALLY
(Please note that minor graphics glitching at the top left of the screen is present. Seems to be a common Intel HD Graphics issue in Sierra 10.12)

2.WiFi(Broadcom BCM94352Z) : For this, I've been trying to use the guide here : https://github.com/RehabMan/OS-X-Fake-PCI-ID and I've successfully added FakePCIID_Broadcom_WiFi.kext to my system, but I can't seem to find the injector kext that is being talked about in the guide? I'm sure I'm missing something very obvious but I can't seem to figure it out, call me blonde. Any help?
Fixed Wifi by installing FakePCIID.kext + FakePCIID_Broadcom_WiFi.kext and adding the fcvo patch found here : https://www.tonymacx86.com/threads/readme-common-some-unsolved-problems-in-10-12-sierra.202316/ (Shoutout to @RehabMan for helping to figure this out)

Can someone please help me figure these two things out about my GPU and Wifi? I'm trying to take it one step at a time.I know Sierra is still very new and there are a lot of issues, I'm willing to work with you and be a part in resolving them. Any feedback is much appreciated. Thanks in advance. Cheers!
 
Last edited:

RehabMan

Moderator
Joined
May 3, 2012
Messages
186,691
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Hi, Since I was trying to install OSX and didn't have the latest OSX 10.11.6 installer, I though I'd give MacOS 10.12 Sierra a try. Please find my specs in my signature.

I've successfully managed to install the OS and install clover on the drive and the computer boots up on its own now, but with FakeID 0x12345678 for the Inject Intel. But it boots without an issue.

I've been trying to get the hardware working one by one, and I'm slowly starting to get the hang of it. But there are 2 things I can't seem to make heads or tails of;
1. GPU(HD 520) : I've read a lot on this and from what I can understand I need to set the DVMT-Prealloc to a higher value. I don't have this setting in the bios, so I'm guessing I'll have to do it through a UEFI Shell. Also I read that, the same can be achieved by patching the IOkit. But I can't seem to find clear instructions on either of them to follow, can someone tell me which method I should use? My Screen is a 1080p TouchScreen.

2.WiFi(Broadcom BCM94352Z) : For this, I've been trying to use the guide here : https://github.com/RehabMan/OS-X-Fake-PCI-ID and I've successfully added FakePCIID_Broadcom_WiFi.kext to my system, but I can't seem to find the injector kext that is being talked about in the guide? I'm sure I'm missing something very obvious but I can't seem to figure it out, call me blonde. Any help?

Can someone please help me figure these two things out about my GPU and Wifi? I'm trying to take it one step at a time.I know Sierra is still very new and there are a lot of issues, I'm willing to work with you and be a part in resolving them. Any feedback is much appreciated. Thanks in advance. Cheers!

Patching IOKit is a separate task than DVMT-prealloc (the pixel clock patch is needed for UHD/QHD+ screens).

FakePCIID.kext + FakePCIID_Broadcom_WiFi.kext *is* the injector. No other kexts are needed.
 
Joined
Feb 27, 2016
Messages
141
Motherboard
Dell Inspiron 15 i5559-4682SLV Signature Edition
CPU
i5-6200U
Graphics
HD 520
Patching IOKit is a separate task than DVMT-prealloc (the pixel clock patch is needed for UHD/QHD+ screens).

FakePCIID.kext + FakePCIID_Broadcom_WiFi.kext *is* the injector. No other kexts are needed.
Thanks for the reply rehabman, and you were right, the whole problem was with El Capitan was with the installer. With Sierra it booted right into the installer :D

Anyway, So I just have to set the DVMT-Prealloc to get the HD520 working on my laptop 1080p screen? What should I set it to? And Also can you provide me with a link to do it over UEFI shell, since my bios doesn't have have the setting. I tried reading up a lot on it, but I still can't find all the correct steps to carry it out. Do I use the UEFI Shell option in clover? I'm confused, please met me know. Thanks.

And ohh I understand the wifi now, I only injected FakePCIID_Broadcom_WiFi.kext earlier. I will try with both the kexts :)
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
186,691
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Anyway, So I just have to set the DVMT-Prealloc to get the HD520 working on my laptop 1080p screen? What should I set it to?

Read the FAQ. Follow the Clover guide.

And Also can you provide me with a link to do it over UEFI shell, since my bios doesn't have have the setting. I tried reading up a lot on it, but I still can't find all the correct steps to carry it out. Do I use the UEFI Shell option in clover? I'm confused, please met me know. Thanks.

The UEFI shell in Clover does not have the feature. It is a special UEFI shell that has setup_var.

And ohh I understand the wifi now, I only injected FakePCIID_Broadcom_WiFi.kext earlier. I will try with both the kexts :)

FakePCIID_Broadcom_WiFi.kext does nothing without FakePCIID.kext.
Please be sure to read the README.
 
Joined
Feb 27, 2016
Messages
141
Motherboard
Dell Inspiron 15 i5559-4682SLV Signature Edition
CPU
i5-6200U
Graphics
HD 520
Read the FAQ. Follow the Clover guide.



The UEFI shell in Clover does not have the feature. It is a special UEFI shell that has setup_var.



FakePCIID_Broadcom_WiFi.kext does nothing without FakePCIID.kext.
Please be sure to read the README.
Sorry about that, looks like I misread the guide. Anyway even after installing both kexts using kext installer I still can't seem to get Wifi to work. Am I missing anything? Is there anything that needs to be done with DSDT?

Also I thought I'll first try to resolve the other issues and then get back to the DVMT-Prealloc cause it seems very complicated.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
186,691
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Joined
Feb 27, 2016
Messages
141
Motherboard
Dell Inspiron 15 i5559-4682SLV Signature Edition
CPU
i5-6200U
Graphics
HD 520
I did now, and it works perfectly! Thanks. I will refer to the problems guide in the future. I also managed to get audio working by using VoodooHDA :D This is the furthest I've made in a hackintosh so far, much thanks to you ^^

Wondering what I should do next? Should I try to set the DVMT-Prealloc? I'm a little worried though since it's complicated, will it mess up my machine? I read about it bricking one users machine. Also what value should I set it to? 128MB?
 
Joined
Sep 17, 2013
Messages
64
Motherboard
Dell XPS 9560
CPU
i7-7700HQ
Graphics
UHD 630
I did now, and it works perfectly! Thanks. I will refer to the problems guide in the future. I also managed to get audio working by using VoodooHDA :D This is the furthest I've made in a hackintosh so far, much thanks to you ^^

Wondering what I should do next? Should I try to set the DVMT-Prealloc? I'm a little worried though since it's complicated, will it mess up my machine? I read about it bricking one users machine. Also what value should I set it to? 128MB?

Did you manage to get the webcam working?

I can't seem to get mine working.
 
Joined
Feb 27, 2016
Messages
141
Motherboard
Dell Inspiron 15 i5559-4682SLV Signature Edition
CPU
i5-6200U
Graphics
HD 520
Did you manage to get the webcam working?

I can't seem to get mine working.
I haven't tried the webcam yet, I did manage to get wifi and audio working though.

Are you using the same laptop as mine(Dell i5559) did you get the graphics(HD520) to work properly?
 
Joined
Feb 27, 2016
Messages
141
Motherboard
Dell Inspiron 15 i5559-4682SLV Signature Edition
CPU
i5-6200U
Graphics
HD 520
Read the FAQ. Follow the Clover guide.



The UEFI shell in Clover does not have the feature. It is a special UEFI shell that has setup_var.



FakePCIID_Broadcom_WiFi.kext does nothing without FakePCIID.kext.
Please be sure to read the README.
Looks like I'm stuck again! I can't set the DVMT Pre-alloc since my laptop bios doesn't have the setting, also dell packs their bios in a ".exe", from which no matter how hard I try I am unable to extract the ".rom" file, hence I'm unable to proceed with the guide in Laptop FAQ to set the pre-alloc.

What do you recommend I do now? Is there anything else I can try?

I also read that we can fix this by patching the AppleIntelBDWGraphicsFramebuffer, which I tried via clover configurator, which still didn't work. Do I need to disable minStolenSize patch for this to work?
 
Status
Not open for further replies.
Top