Contribute
Register

[Solved] USB 3.0 stopped working for me in High Sierra Upgrade

Status
Not open for further replies.
Joined
Nov 6, 2016
Messages
15
Motherboard
GA-170X-Gaming 3 Rev 1.0
CPU
Intel Core i5-6600K
Graphics
EVGA GeForce GTX 750Ti SC
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
Mobile Phone
  1. iOS
I just realized today that USB 3.0 totally stopped working for me somewhere in my series of High Sierra upgrades. I know USB 3.0 used to work when I was on Sierra.

Basically, any USB 3.0 device will not show up at all. I am attaching a screenshot of my L/E folder

View media item 189841
Any help is greatly appreciated.

Thanks
 
Joined
Nov 6, 2016
Messages
15
Motherboard
GA-170X-Gaming 3 Rev 1.0
CPU
Intel Core i5-6600K
Graphics
EVGA GeForce GTX 750Ti SC
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
Mobile Phone
  1. iOS
Remove FakePCIID_XHCIMux and FakePCIID.kext as you don't need them.

High Sierra has a new Raise Port Limit Patch for USB 3 on Skylake/100 Series builds.

Yes, this did the trick. Thank you very much! I removed both FakePCIID_XHCIMux and FakePCIID.kext and followed the instructions to "Raise Port Limit Patch for USB 3", and it works beautifully.
 
Joined
May 30, 2018
Messages
14
Motherboard
Asus UX410UA
CPU
i3-7100U
Graphics
HD 620, 1920x1080
Mobile Phone
  1. Android
Yes, this did the trick. Thank you very much! I removed both FakePCIID_XHCIMux and FakePCIID.kext and followed the instructions to "Raise Port Limit Patch for USB 3", and it works beautifully.
how can i remove those(FakePCIID_XHCIMux and FakePCIID.kext) kext file bro ?
 
Joined
Jun 28, 2018
Messages
3
Motherboard
ASUS H87-Pro
CPU
i5-4430
Graphics
RTX 1050
Classic Mac
  1. iMac
Mobile Phone
  1. Android
Thank you so much , USB 3.0 problem has solved and works well .
 
Status
Not open for further replies.
Top