Contribute
Register

[solved] Upgrade screen to FHD results to garbled screen

Status
Not open for further replies.

the-braveknight

Moderator
Joined
Nov 24, 2015
Messages
1,220
Motherboard
Lenovo Legion Y520 (Clover)
CPU
i7-7700HQ
Graphics
HD 630 (1920x1080) + Nvidia GTX 1060
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Hello. I have followed this guide >>https://www.tonymacx86.com/threads/black-screen-after-wakeup-and-strange-audio-issue.235325/page-2#post-1628292">Black screen after wakeup, and strange audio issue a little bit but some of the process is different:

1. Extract vanilla EDID (I used EDID Manager from windows, I don't know if there are any mac alternative)
2. Patch the vanilla EDID using FixEDID
-Open extracted vanilla EDID
-Select only Inject EDID Unpatched
-Checked Add/Fix Monitor Ranges
-Click Make
View attachment 303058

3. Open the file DisplayProductID-XXXX file with plist editor. The file was generated by FixEDID that was placed in Desktop with folder name DisplayVendorID-XXX

4. Take note of the 21st bit of IODisplayEDID and replace it with any of these except the previous value B5, 95, A5(these values are the ones I get when patching using iMac, MacbookAir, MacbookPro)
-- example, for me the patched vanilla is:
Code:
00FFFFFF FFFFFF00 4C834455 00000000 00190104 A5221378 0AE72599 59568E28 1E505400 00000101 01010101 01010101 01010101 0101D237 80A27038 40403020 250058C2 10000019 372580A2 70384040 30202500 58C21000 00190000 00FD0038 4C1E5311 000A2020 20202020 00000002 000C3FFF 0C3C7D1E 18327D00 0000001C

I have replaced it with 95 and as a result, no more graphics glitch on startup, also no more boot glitch effect:

Code:
00FFFFFF FFFFFF00 4C834455 00000000 00190104 95221378 0AE72599 59568E28 1E505400 00000101 01010101 01010101 01010101 0101D237 80A27038 40403020 250058C2 10000019 372580A2 70384040 30202500 58C21000 00190000 00FD0038 4C1E5311 000A2020 20202020 00000002 000C3FFF 0C3C7D1E 18327D00 0000001C

5. Put the new EDID in config.plist>Graphics>EDID>Custom, and also Inject as YES:

View attachment 303060

6. Try booting, if glitches are gone, check your bdmesg on terminal if there are any automatic patches that was done by clover on your EDID and correct your EDID. normally on my experience, the last bit was patched by clover so I updated my Injected EDID to match the clover patched EDID.

View attachment 303063

7. Video of booting with EDID patched & EDID Unpatched(i'll pm if you want):
I did the suggested steps... extracted my EDID with EDID Manager, patched it with FixEDID, and the 21st bit was already 95, but Clover isn't injecting the new EDID for some reason. It still displays the original EDID in IOReg.
 

Attachments

  • debug_13822.zip
    1.7 MB · Views: 68
Joined
Aug 1, 2015
Messages
33
Motherboard
Surface Pro 4 Intel Skylake-U Premium PCH
CPU
Intel Core i5 6300U 2.4Ghz
Graphics
Intel HD 520 2736x1824
Mobile Phone
  1. iOS
  2. Other
Last edited:
Joined
Aug 8, 2017
Messages
67
Motherboard
Dell Inspiron 5558-Clover
CPU
i5-5200U
Graphics
HD 5500, GTX 920MX, 1920x1080
Mobile Phone
  1. Android
  2. iOS
I did the suggested steps... extracted my EDID with EDID Manager, patched it with FixEDID, and the 21st bit was already 95, but Clover isn't injecting the new EDID for some reason. It still displays the original EDID in IOReg.

Your config.plist contains 95 for the 21st bit, you must try to change it to A5 or B5.
What we are trying here is to replace the original 21st bit with other apple display bit.
as for my Example, my original 21st bit was A5 so i tried to change it to 95(which fixed my issue). B5 is also working on my end too. A5(vanilla 21st bit) was the buggy bit for me
 

Attachments

  • Screen Shot 2018-01-02 at 8.33.15 PM.png
    Screen Shot 2018-01-02 at 8.33.15 PM.png
    22.9 KB · Views: 96
Last edited:
Joined
Aug 8, 2017
Messages
67
Motherboard
Dell Inspiron 5558-Clover
CPU
i5-5200U
Graphics
HD 5500, GTX 920MX, 1920x1080
Mobile Phone
  1. Android
  2. iOS
Joined
Aug 1, 2015
Messages
33
Motherboard
Surface Pro 4 Intel Skylake-U Premium PCH
CPU
Intel Core i5 6300U 2.4Ghz
Graphics
Intel HD 520 2736x1824
Mobile Phone
  1. iOS
  2. Other
I did the suggested steps... extracted my EDID with EDID Manager, patched it with FixEDID, and the 21st bit was already 95, but Clover isn't injecting the new EDID for some reason. It still displays the original EDID in IOReg.
I have tried the custom override but the effect on my hack is like there is an overlay of opaque white that really distorts my display. so I moved it to config.plist and everything went fine on my end

But this is an option too if custom EDID in config.plist is not working:)

Yes! Glad to hear that your problem is solved!
 

the-braveknight

Moderator
Joined
Nov 24, 2015
Messages
1,220
Motherboard
Lenovo Legion Y520 (Clover)
CPU
i7-7700HQ
Graphics
HD 630 (1920x1080) + Nvidia GTX 1060
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
I have tried the custom override but the effect on my hack is like there is an overlay of opaque white that really distorts my display. so I moved it to config.plist and everything went fine on my end

But this is an option too if custom EDID in config.plist is not working:)
What fork of Clover are you using?

I tried both RehabMan’s fork and the original one without success. I’ll try changing the EDID from data type to string type and see if it works.

EDIT: It’s working now. config.plist/Graphics/Inject/Intel was set to false... I’ll try with those values and see what happens.
 
Last edited:
Joined
Aug 8, 2017
Messages
67
Motherboard
Dell Inspiron 5558-Clover
CPU
i5-5200U
Graphics
HD 5500, GTX 920MX, 1920x1080
Mobile Phone
  1. Android
  2. iOS
What fork of Clover are you using?

I tried both RehabMan’s fork and the original one without success. I’ll try changing the EDID from data type to string type and see if it works.

EDIT: It’s working now. config.plist/Graphics/Inject/Intel was set to false... I’ll try with those values and see what happens.

I am using RehabMan's fork of clover. Can you confirm that EDID injection fixed your issue too? :)
 

the-braveknight

Moderator
Joined
Nov 24, 2015
Messages
1,220
Motherboard
Lenovo Legion Y520 (Clover)
CPU
i7-7700HQ
Graphics
HD 630 (1920x1080) + Nvidia GTX 1060
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
I am using RehabMan's fork of clover. Can you confirm that EDID injection fixed your issue too? :)
I can confirm it had no effect for me. I still get a garbled screen at boot without the kext patch in place. I also still get permenant garbled horizontal lines when booting without CSM, although they disappear if I sleep/wake the laptop.
 
Joined
Aug 8, 2017
Messages
67
Motherboard
Dell Inspiron 5558-Clover
CPU
i5-5200U
Graphics
HD 5500, GTX 920MX, 1920x1080
Mobile Phone
  1. Android
  2. iOS
I can confirm it had no effect for me. I still get a garbled screen at boot without the kext patch in place. I also still get permenant garbled horizontal lines when booting without CSM, although they disappear if I sleep/wake the laptop.

Hmm same issue as mine, garbled screen on login and only disappears on sleep/wake. Have you tried A5 and B5? And does it reflect on your ioreg? You can try also override method suggested by shdkpr2008
 

the-braveknight

Moderator
Joined
Nov 24, 2015
Messages
1,220
Motherboard
Lenovo Legion Y520 (Clover)
CPU
i7-7700HQ
Graphics
HD 630 (1920x1080) + Nvidia GTX 1060
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Hmm same issue as mine, garbled screen on login and only disappears on sleep/wake. Have you tried A5 and B5? And does it reflect on your ioreg? You can try also override method suggested by shdkpr2008
Are you sure you're not using the kext patch for eliminating the glitch?
Also keep in mind that if you're using IntelGraphicsFixup.kext, it will apply that patch.
 
Status
Not open for further replies.
Top