Contribute
Register

[Solved] Updated Sierra to High Sierra lost ALC892 Sound

Status
Not open for further replies.
Joined
Apr 4, 2011
Messages
35
Motherboard
GA-Z77N-WIFI
CPU
I7
Graphics
Built-In
I just updated a fully working Sierra to High Sierra and everything appears to be working except sound. I tried to reinstall the ALC892 drivers with Multibeast 9.2.1 and Multibeast quits with a segment fault. Also, I noticed that the Multibeast drive install selection dropdown is empty. By the way my SSD was converted to APFS by the install.
 

aol

Joined
Apr 14, 2011
Messages
503
Motherboard
GA-Z370-HD3P
CPU
i7-8700K
Graphics
RX570
Mac
  1. MacBook Pro
  2. Mac Pro
Mobile Phone
  1. iOS
I don't think MultiBeast has been updated for High Sierra yet.

I don't know if @toleda's ALC patches support ALC892, but that'd be one place to check.
 
Joined
May 5, 2014
Messages
65
Motherboard
Dell VOSTRO 3478
CPU
I5-8250u
Graphics
HD 620, Radeon HD 520
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS

`

Joined
Sep 18, 2017
Messages
113
Motherboard
H170N-wifi
CPU
I3-7100
Graphics
HD630
Mobile Phone
  1. iOS
me also.

select internal speaker no sound. lineout has sound but wrong speaker. only rear speaker, not front speaker as I want.

before beta version, it worked well.

tried both applealc and cloveralc

I'm using Realtek 1150
 
Joined
Apr 4, 2011
Messages
35
Motherboard
GA-Z77N-WIFI
CPU
I7
Graphics
Built-In
Joined
May 28, 2014
Messages
3
Motherboard
Gigabyte GA-Z87-HD3
CPU
i7-4770K
Graphics
RX 580
Mac
  1. MacBook
  2. MacBook Air
  3. MacBook Pro
  4. Mac mini
Mobile Phone
  1. iOS
Joined
Aug 30, 2013
Messages
1
Motherboard
motherboard OR system make & model # > See Rules!
CPU
i7 > need model # > See Rules!
Graphics
HD 5000
Mac
  1. MacBook Air
Joined
Oct 4, 2014
Messages
29
Motherboard
Asus P9X79
CPU
Intel Core i7 4930K
Graphics
geforce 770 gtx Gigabyte
Mac
Classic Mac
Mobile Phone
Status
Not open for further replies.
Top