Contribute
Register

[Solved] Update GPU Bios GTX 1050

Joined
Mar 20, 2018
Messages
16
Motherboard
Gigabyte Z170MX-G 5
CPU
i7-6700k
Graphics
Geforce GTX1050 LP
Mac
MacBook Pro
Mobile Phone
Android
Hello everybody, just finishing my first hackintosh.
Managed to have everything working except for graphics (They are at a 99% with Nvidia Web Drivers 25.106 and installed with B. Dobell's awesome script).
  • Already tried some of the whitelisted driver versions, but results are the same.
  • Clover seems to be set up alright (Attached file). (If not, I will feel really stupid by this point haha)
  • CPU's video card is turned off from bios, and is not displayed in my graphic device list (attached).
  • ROM on my GPU seems to be the latest available for flashing through NVFLASH method in DOS.
Everything works great, except when I start pushing my card to more demanding tasks (Running Parallels, Photoshop with heavy files, and so on). All of a sudden, I will get black glitches(kinda turned off monitor), they last a second or two, then the screen comes back. Issues started when I begun using my ultrawide monitor (3440x1440), I'm connected through DVI.

I read in this thread this is a possible solution for my problem, thing is I can't seem to run the exe since I don't have a windows drive on my computer.

Any other approach to fix this?

Thanks in advance!
 

Attachments

Joined
Mar 20, 2018
Messages
16
Motherboard
Gigabyte Z170MX-G 5
CPU
i7-6700k
Graphics
Geforce GTX1050 LP
Mac
MacBook Pro
Mobile Phone
Android
Solved!
BTW there is no way that I'm aware to update the GPU BIOS while on Mac. I took a simple approach, created a bootable USB Windows Drive with WINTOUSB, booted this drive, installed drivers for my card and installed the update.

My issues seem to be GONE!

It seems if you are running a Low Profile 1050 card, 2 or 4 GB, you are most likely to run a smooth build with the Beta BIOS.
This is supported by my case and by this one.
 
Top