[SOLVED] UniBeast 7.1.1 fails to create bootable USB (logs included)

Discussion in 'UniBeast Archived Threads' started by sweeznit, Apr 4, 2017.

  1. sweeznit

    sweeznit

    Joined:
    Jun 9, 2012
    Messages:
    14
    Mobo:
    Mac Pro Hackintosh
    CPU:
    i5-3570K
    Graphics:
    Intel HD Graphics 4000 512 MB
    Mac:
    MacBook, MacBook Pro, Mac Pro
    Mobile Phone:
    iOS
    Apr 4, 2017 at 10:16 AM #1
    sweeznit

    sweeznit

    Joined:
    Jun 9, 2012
    Messages:
    14
    Mobo:
    Mac Pro Hackintosh
    CPU:
    i5-3570K
    Graphics:
    Intel HD Graphics 4000 512 MB
    Mac:
    MacBook, MacBook Pro, Mac Pro
    Mobile Phone:
    iOS
    Update: Solved - [link]

    Creating a bootable USB fails to complete and the progress bar hangs in the UI.

    I'm using a partitioned volume of the recommended max 32GB from a 1TB WD My Passport hard drive. I've also tried on an HP 8GB USB drive.

    I'm working from a MacBook Pro (Retina, 15-inch, Mid 2014) running macOS Sierra 10.12.4.

    Options that were selected:
    • The partitioned volume (Mini [32GB])
    • Sierra (downloaded from the App Store [10.12.4] as of April 3, 2017)
    • UEFI Boot Mode
    Below is a log from UniBeast.log:
    Code (Text):

    04/04/17 04:47:29 - Starting UniBeast 7.1.1-20170401
    04/04/17 04:47:41 - Mounting Volumes...
    04/04/17 04:47:42 - Copying Files...

    04/04/17 04:51:42 - Detaching Volumes...

    04/04/17 04:51:54 - Installing Bootloader...

    04/04/17 04:51:57 - installer: Package name is Clover v2.4k r4045 EFI bootloader
    installer: Installing at base path /Volumes/Mini
    installer: The install failed (The Installer encountered an error that caused the installation to fail. Contact the software manufacturer for assistance.)
    err
    04/04/17 04:51:57 - installer --- installer: Package name is Clover v2.4k r4045 EFI bootloader
    installer: Installing at base path /Volumes/Mini
    installer: The install failed (The Installer encountered an error that caused the installation to fail. Contact the software manufacturer for assistance.)
    err --- Couldn't install Bootloader
     
    Below is a portion of the log from install.log:
    I could not find "Install: "UniBeast Mac App Store"" or Displaying 'Install Failed' UI. However, I found where it started to error.
    Code (Text):

    Apr  4 04:51:56 sweeznit installd[442]: ./preinstall: /tmp/PKInstallSandbox.FhL58Y/Scripts/org.clover.uefi.only.hq9wV3/preinstall: line 16: cd: /Volumes/Mini/EFIROOTDIR: No such file or directory

    Apr  4 04:51:56 sweeznit installd[442]: PackageKit: Executing script "./preinstall" in /private/tmp/PKInstallSandbox.FhL58Y/Scripts/org.clover.target.esp.72VDax

    Apr  4 04:51:56 sweeznit installd[442]: ./preinstall: preinstall: Path to installer....... /private/var/folders/dg/4djfdg4x629cmp8smtxf7j2c0000gn/T/AppTranslocation/E0FB1719-A8B0-461B-A2D1-B6BA3C7056CE/d/UniBeast.app/Contents/Resources/Clover_v2.4k_r4045-UEFI-UB.pkg

    Apr  4 04:51:56 sweeznit installd[442]: ./preinstall: preinstall: Path to destination..... /Volumes/Mini

    Apr  4 04:51:56 sweeznit installd[442]: ./preinstall: preinstall: Path to dest volume..... /Volumes/Mini

    Apr  4 04:51:56 sweeznit installd[442]: ./preinstall: preinstall: Root of system folder... /

    Apr  4 04:51:56 sweeznit installd[442]: ./preinstall: /tmp/PKInstallSandbox.FhL58Y/Scripts/org.clover.target.esp.72VDax/preinstall: line 16: cd: /Volumes/Mini/EFIROOTDIR: No such file or directory

    Apr  4 04:51:56 sweeznit installd[442]: PackageKit: Executing script "./preinstall" in /private/tmp/PKInstallSandbox.FhL58Y/Scripts/org.clover.efifolder.rn4T9q

    Apr  4 04:51:56 sweeznit installd[442]: ./preinstall: ===============================================

    Apr  4 04:51:56 sweeznit installd[442]: ./preinstall: EFIFolder Pre-Install Script

    Apr  4 04:51:56 sweeznit installd[442]: ./preinstall: ===============================================

    Apr  4 04:51:56 sweeznit installd[442]: ./preinstall: preinstall: Path to installer....... /private/var/folders/dg/4djfdg4x629cmp8smtxf7j2c0000gn/T/AppTranslocation/E0FB1719-A8B0-461B-A2D1-B6BA3C7056CE/d/UniBeast.app/Contents/Resources/Clover_v2.4k_r4045-UEFI-UB.pkg

    Apr  4 04:51:56 sweeznit installd[442]: ./preinstall: preinstall: Path to destination..... /Volumes/Mini/EFIROOTDIR

    Apr  4 04:51:56 sweeznit installd[442]: ./preinstall: preinstall: Path to dest volume..... /Volumes/Mini

    Apr  4 04:51:56 sweeznit installd[442]: ./preinstall: preinstall: Root of system folder... /

    Apr  4 04:51:57 sweeznit installd[442]: PackageKit: releasing backupd

    Apr  4 04:51:57 sweeznit installd[442]: PackageKit: allow user idle system sleep

    Apr  4 04:51:57 sweeznit installd[442]: PackageKit: Install Failed: Error Domain=PKInstallErrorDomain Code=112 "An error occurred while running scripts from the package “Clover_v2.4k_r4045-UEFI-UB.pkg”." UserInfo={NSFilePath=./preinstall, NSURL=file://localhost/private/var/folders/dg/4djfdg4x629cmp8smtxf7j2c0000gn/T/AppTranslocation/E0FB1719-A8B0-461B-A2D1-B6BA3C7056CE/d/UniBeast.app/Contents/Resources/Clover_v2.4k_r4045-UEFI-UB.pkg#EFIFolder.pkg, PKInstallPackageIdentifier=org.clover.efifolder, NSLocalizedDescription=An error occurred while running scripts from the package “Clover_v2.4k_r4045-UEFI-UB.pkg”.} {

        NSFilePath = "./preinstall";

        NSLocalizedDescription = "An error occurred while running scripts from the package \U201cClover_v2.4k_r4045-UEFI-UB.pkg\U201d.";

        NSURL = "file://localhost/private/var/folders/dg/4djfdg4x629cmp8smtxf7j2c0000gn/T/AppTranslocation/E0FB1719-A8B0-461B-A2D1-B6BA3C7056CE/d/UniBeast.app/Contents/Resources/Clover_v2.4k_r4045-UEFI-UB.pkg#EFIFolder.pkg";

        PKInstallPackageIdentifier = "org.clover.efifolder";

    }

    Apr  4 04:51:57 sweeznit installd[442]: PackageKit: Running idle tasks

    Apr  4 04:51:57 sweeznit installd[442]: PackageKit: Removing client PKInstallDaemonClient pid=1686, uid=0 (/usr/sbin/installer)

    Apr  4 04:51:57 sweeznit installer[1686]: install:didFailWithError:Error Domain=PKInstallErrorDomain Code=112 "An error occurred while running scripts from the package “Clover_v2.4k_r4045-UEFI-UB.pkg”." UserInfo={NSFilePath=./preinstall, NSURL=file://localhost/private/var/folders/dg/4djfdg4x629cmp8smtxf7j2c0000gn/T/AppTranslocation/E0FB1719-A8B0-461B-A2D1-B6BA3C7056CE/d/UniBeast.app/Contents/Resources/Clover_v2.4k_r4045-UEFI-UB.pkg#EFIFolder.pkg, PKInstallPackageIdentifier=org.clover.efifolder, NSLocalizedDescription=An error occurred while running scripts from the package “Clover_v2.4k_r4045-UEFI-UB.pkg”.}

    Apr  4 04:51:57 sweeznit installer[1686]: Install failed: The Installer encountered an error that caused the installation to fail. Contact the software manufacturer for assistance.

    Apr  4 04:51:57 sweeznit installd[442]: PackageKit: Done with sandbox removals
     
    Any insight would be greatly appreciated. Hopefully this helps improve UniBeast.
     

    Attached Files:

    • Screen Shot 2017-04-04 at 3.14.12 AM.png  (96.3 KB, 103 views)
    Last edited: Apr 4, 2017
  2. sweeznit

    sweeznit

    Joined:
    Jun 9, 2012
    Messages:
    14
    Mobo:
    Mac Pro Hackintosh
    CPU:
    i5-3570K
    Graphics:
    Intel HD Graphics 4000 512 MB
    Mac:
    MacBook, MacBook Pro, Mac Pro
    Mobile Phone:
    iOS
    Apr 4, 2017 at 11:02 AM #2
    sweeznit

    sweeznit

    Joined:
    Jun 9, 2012
    Messages:
    14
    Mobo:
    Mac Pro Hackintosh
    CPU:
    i5-3570K
    Graphics:
    Intel HD Graphics 4000 512 MB
    Mac:
    MacBook, MacBook Pro, Mac Pro
    Mobile Phone:
    iOS
    Update: I noticed the `No such file or directory` error in my install.log so I ended up doing a First Aid on my portable USB hard drive. It turned out to be corrupted so I booted my MacBook in recovery mode (cmd + r + restart) and erased the drive there with Disk Utility. I then booted back into macOS and partitioned a 16GB volume naming it USB. Running through UniBeast one more time showed a successful install.
     
    uejalib37 likes this.

    Attached Files:

    • Screen Shot 2017-04-04 at 5.52.42 AM.png  (90.7 KB, 98 views)

Share This Page