Contribute
Register

[solved] UHD 630 either not booting or no acceleration on Dell XPS 15 9570 4K

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,285
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
I took a look in IDA and it seems to be crashing at this line:
View attachment 354752

View attachment 354753

Division by zero...? What's "[IGFB][ERROR ] fActiveNumberOfLanes = %d, linkSymbolClock = %llu.. One of them is 0 for FB%x - will lead to DivideByZero panic. PixelClock = %llu!!!!!\n"...? v11 is the register r13, so it appears to definitely be division by 0.

Display is eDP or LVDS? Don't really know enough about IGPU hardware programming to decypher.
 
Joined
Feb 19, 2018
Messages
66
Motherboard
Dell XPS 15 9570 (Clover UEFI)
CPU
i7-8750H/CM246
Graphics
UHD 630/1050Ti, 3840x2160
Mobile Phone
  1. Android
Display is eDP or LVDS?
Ah, looks like it's eDP. I read about needing to patch it to that. Is that correct..?

Edit: I poked around and attached my config.plist; it crashes with the same exact KP as before, at the same exact line. The panic references "divide error=0", so I'm 100% sure it's that line.

Edit 2: I can connect through VNC after enabling it, and there's QE/CI/acceleration of some sort (Launchpad doesn't lag). But... there are only 2 display options: 1280x1024 and 1024x768, AND it's not outputting to my internal display. This is with the 32MB framebuffer patch, which is probably why...
Perhaps the kext is expecting 128MB DVMT-prealloc instead of 64MB because of the 4K display?

upload_2018-10-2_19-14-20.png
 

Attachments

  • config.plist
    13.3 KB · Views: 115
Last edited:

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,285
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Ah, looks like it's eDP. I read about needing to patch it to that. Is that correct..?

Edit: I poked around and attached my config.plist; it crashes with the same exact KP as before, at the same exact line. The panic references "divide error=0", so I'm 100% sure it's that line.

Edit 2: I can connect through VNC after enabling it, and there's QE/CI/acceleration of some sort (Launchpad doesn't lag). But... there are only 2 display options: 1280x1024 and 1024x768, AND it's not outputting to my internal display. This is with the 32MB framebuffer patch, which is probably why...
Perhaps the kext is expecting 128MB DVMT-prealloc instead of 64MB because of the 4K display?

View attachment 354805

Attach full problem reporting files as per FAQ.
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
 
Joined
Feb 19, 2018
Messages
66
Motherboard
Dell XPS 15 9570 (Clover UEFI)
CPU
i7-8750H/CM246
Graphics
UHD 630/1050Ti, 3840x2160
Mobile Phone
  1. Android
For whatever reason, I could only upload the debug zip file in parts because the site was complaining about a large filesize......??

debug_8723.z01.zip => debug_8723.z01
debug_8723.z02.zip => debug_8723.z02

I noticed suddenly a weird line going across the output. I can actually see some video output (part of the folder icon) but it actually doesn't update. Just a small detail I guess.
 

Attachments

  • debug_8723.zip
    1.2 MB · Views: 41
  • debug_8723.z01.zip
    2 MB · Views: 37
  • debug_8723.z02.zip
    2 MB · Views: 33
  • photo_2018-10-03_19-47-26.jpg
    photo_2018-10-03_19-47-26.jpg
    224.3 KB · Views: 35

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,285
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
For whatever reason, I could only upload the debug zip file in parts because the site was complaining about a large filesize......??

debug_8723.z01.zip => debug_8723.z01
debug_8723.z02.zip => debug_8723.z02

I noticed suddenly a weird line going across the output. I can actually see some video output (part of the folder icon) but it actually doesn't update. Just a small detail I guess.

Looks like only debug_8723.zip is a valid ZIP file.
 
Joined
Feb 19, 2018
Messages
66
Motherboard
Dell XPS 15 9570 (Clover UEFI)
CPU
i7-8750H/CM246
Graphics
UHD 630/1050Ti, 3840x2160
Mobile Phone
  1. Android
Looks like only debug_8723.zip is a valid ZIP file.
It's in parts - I'm not sure if the built in macOS decompresser can handle that. Is there any way to actually upload it in one piece? I can't seem to.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,285
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
It's in parts - I'm not sure if the built in macOS decompresser can handle that. Is there any way to actually upload it in one piece? I can't seem to.

There was a site software update today... not sure if it causing problems or not.
If so, upload to dropbox.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,285
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Top