Contribute
Register

[solved] UHD 630 either not booting or no acceleration on Dell XPS 15 9570 4K

Joined
Feb 19, 2018
Messages
66
Motherboard
Dell XPS 15 9570 (Clover UEFI)
CPU
i7-8750H/CM246
Graphics
UHD 630/1050Ti, 3840x2160
Mobile Phone
Android
Have any of you guys been able to figure out the delayed/max brightness issue?
 
Joined
Jul 19, 2015
Messages
49
Motherboard
Dell XPS 15 9570 (Clover UEFI)
CPU
i7-8750H/CM246
Graphics
UHD 630/1050Ti Max-Q, 3840x2160
Mobile Phone
iOS
Have any of you guys been able to figure out the delayed/max brightness issue?
That’s not an issue that’s limited to the 9570 and from what I’ve read, people are working on that.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,123
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Joined
Feb 19, 2018
Messages
66
Motherboard
Dell XPS 15 9570 (Clover UEFI)
CPU
i7-8750H/CM246
Graphics
UHD 630/1050Ti, 3840x2160
Mobile Phone
Android
You mean this issue?
Ah, it is! Thanks.

@sparc1234 I saw your post, I use an OEM DW1560. It works great on macOS with the various patch kexts. It breaks after sleeping on Windows 10 1809 (I have to disconnect and reconnect to the network manually) but otherwise relatively well. I'm unable to confirm if the same behaviour exists on macOS as I don't have sleep working just yet. I'll post a list of my kexts later which should include those kexts.
To mods: sorry, can't PM him because we don't have 75 posts yet :(
 
Last edited:
Joined
Oct 6, 2018
Messages
11
Ah, it is! Thanks.

@sparc1234 I saw your post, I use an OEM DW1560. It works great on macOS with the various patch kexts. It breaks after sleeping on Windows 10 1809 (I have to disconnect and reconnect to the network manually) but otherwise relatively well. I'm unable to confirm if the same behaviour exists on macOS as I don't have sleep working just yet. I'll post a list of my kexts later which should include those kexts.
To mods: sorry, can't PM him because we don't have 75 posts yet :(
would you like to upload it on github?
 
Joined
Feb 19, 2018
Messages
66
Motherboard
Dell XPS 15 9570 (Clover UEFI)
CPU
i7-8750H/CM246
Graphics
UHD 630/1050Ti, 3840x2160
Mobile Phone
Android
would you like to upload it on github?
I have neither the time nor patience to maintain a support repository :(
Plus, I don't even have a fully working system right now.

But.. in my Clover kext directory, I have:
AppleALC.kext BT4LEContiunityFixup.kext
BrcmFirmwareData.kext BrcmNonPatchRAM2.kext
FakePCIID.kext Lilu.kext
FakePCIID_Broadcom_WiFi.kext USBInjectAll.kext
FakeSMC.kext

In /L/E:
ACPIBatteryManager.kext CoreDisplayFixup.kext
Lilu.kext AppleALC.kext
AppleBacklightInjector.kext VoodooPS2Controller.kext
 
Joined
Jul 19, 2015
Messages
49
Motherboard
Dell XPS 15 9570 (Clover UEFI)
CPU
i7-8750H/CM246
Graphics
UHD 630/1050Ti Max-Q, 3840x2160
Mobile Phone
iOS
I have neither the time nor patience to maintain a support repository :(
Plus, I don't even have a fully working system right now.

But.. in my Clover kext directory, I have:
AppleALC.kext BT4LEContiunityFixup.kext
BrcmFirmwareData.kext BrcmNonPatchRAM2.kext
FakePCIID.kext Lilu.kext
FakePCIID_Broadcom_WiFi.kext USBInjectAll.kext
FakeSMC.kext

In /L/E:
ACPIBatteryManager.kext CoreDisplayFixup.kext
Lilu.kext AppleALC.kext
AppleBacklightInjector.kext VoodooPS2Controller.kext
That’s quite a few kext’s that could be in the Clover other folder instead. As ReHabMan suggested it might be a good idea to replace CoreDisplayFixup with whatevergreen. Especially since it will also include the framebuffer patch soon. It avoids having to update too many kext’s before updating MacOS in the future and potentially ending up with a non bootable system.

As for the repository request, I agree it doesn’t make sense at this stage. A complete guide makes more sense when all things are (nearly) completely functional.
 
Last edited:
Joined
Feb 19, 2018
Messages
66
Motherboard
Dell XPS 15 9570 (Clover UEFI)
CPU
i7-8750H/CM246
Graphics
UHD 630/1050Ti, 3840x2160
Mobile Phone
Android
That’s quite a few kext’s that could be in the Clover other folder instead.
I know :)
That's what I meant about "I have neither the time nor patience". I'm too lazy to potentially break something and then fix it.
Maybe soon.
 
Joined
Jul 13, 2013
Messages
40
Motherboard
Dell XPS 15 9570 4K
CPU
i7-8750H
Graphics
UHD 630 + GTX 1050 Ti
I know :)
That's what I meant about "I have neither the time nor patience". I'm too lazy to potentially break something and then fix it.
Maybe soon.
Hey Raymonf, could you upload your CLOVER folder? I'd really appreciate it - I have the exact same spec XPS 15 9570 as you and whenever I try and get gpu acceleration to work under Mojave my screen just goes black and reboots. It works fine however with disabled graphics acceleration by a fake ig-platform-id
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,123
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Hey Raymonf, could you upload your CLOVER folder? I'd really appreciate it - I have the exact same spec XPS 15 9570 as you and whenever I try and get gpu acceleration to work under Mojave my screen just goes black and reboots. It works fine however with disabled graphics acceleration by a fake ig-platform-id
No "Problem Reporting" files attached.
Read FAQ, "Problem Reporting" again. Carefully. Attach all requested files/output.
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
Use the gen_debug.sh tool mentioned in the FAQ, that way it is less likely you'll omit something.
 
Top