Contribute
Register

[Solved] UEFI clover boot option gone after BIOS update

Joined
Nov 8, 2018
Messages
6
Motherboard
Gigabyte Z370M D3H
CPU
i5-8400
Graphics
UHD 630
Mobile Phone
Android
Tracked down a solution that didn't require new apps - and this worked for me.

Pre - get your system booted up off the USB and mount the system EFI drive (not the USB EFI drive) - check your directories and copy down the path to the \CLOVER\CLOVERX64.EFI file (I noticed this differs some amongst varying install procedures on the net). Also, doesn't hurt to open Terminal and run "disk util" - note the /dev/disk# location of the drive that has the EFI installed in it. Now, restart and proceed.
  • Boot into clover off of the USB
  • Start up the Clover EFI shell
  • Pull the USB (saves confusion in the next step)
  • Type "map" (no quotes)
  • Look at the drives and apply some thinking about which one is the drive where your Clover EFI drive is - the drive# from disk util will help if you have several drives/partitions showing up. Once you've got it, note the drive - e.g. mine was "FS2"
  • Type "bcfg boot dump" (no quotes)
  • You'll see each boot entry proceeded with a number. For the love of Pete, don't use any of those - determine the next number up. My highest was 03, so I used 04 in the next step.
  • Type the following to create the boot entry:
    bcfg boot add 04 FS2:\EFI\CLOVER\CLOVERX64.EFI CloverUEFI
  • In the above step, the path is helped out by having checked my mounted EFI drive on my system. The last part, "CloverUEFI" above is how the boot entry will appear in BIOS - name this as you will.
  • Type "bcfg boot dump" again to be sure your new entry made it.
  • Exit, shut down, pull the USB if you didn't already.
  • Hold down DEL to open BIOS settings - and in my case - CloverUEFI was in the Boot options. I set it as primary, and everything was back to normal with no more need to use the USB.
I tried this method so many times with so many Clover Bootloader versions. But each time I failed for not working shift key of my keyboard. The issue is running for a long time. Don't know why they aren't fixing this.

Finally, I made it with the Windows EasyUEFI tool. Thanks anyway.
 
Joined
Jun 17, 2015
Messages
18
Motherboard
Mainboards Gigabyte GA B75M - D3V REV 2.0
CPU
Intel® Pentium® Processor G2030 (3M Cache, 3.00 GHz)
Graphics
GV-N6400C-2GI Geforce GT 640
Classic Mac
iMac
Mobile Phone
Android
My Mainboard Asrock H81Pro BTC REV2.00 too.I finding solution for boot without usb Clover.
Thanks for everyone for Sharing.

My Specification

intel I5 4590 3.30 Ghz
Ram apacer DDR3 1600 8 Gb.
Vga on Board
SSD 128 gb Galax Gamer
 
Top