Contribute
Register

[SOLVED] Troubleshooting GTX 1070 Web Drivers on Sierra 10.12.4 with GA-Z170N

Joined
Mar 14, 2016
Messages
9
Motherboard
GA-Z170N-Gaming 5
CPU
Intel Core i7-6700K
Graphics
Asus GTX 1070 Turbo
[Solved] EDIT: Although other threads said not to use them, Boot > Arguments > nvda_drv=1 and Graphics > Inject > Nvidia > true were both required clover config.plist settings to get my system working. Your mileage may vary. Below info is now incorrect. System working flawlessly as iMac17,1 so far. Cinebench score 117 fps.

System Info:
- Motherboard: Gigabyte GA-Z170N-Gaming 5
- UEFI BIOS: Version F5 (4/25/2016)
- GFX: Asus GeForce GTX 1070 Turbo
- macOS: Sierra 10.12.4
- NVIDIA Web Driver 378.05.05.05f01
- Clover: 2.4-4049
- EFI/CLOVER/drivers64UEFI: FSInject-64.efi, OsxAptioFix2Drv-64.efi, OsxFatBinaryDrv-64.efi, VBoxHfs-64.efi, EmuVariableUefi-64
- EFI/CLOVER/kexts/Other: AppleALC.kext, AtherosE2200Ethernet.kext, FakeSMC.kext

This is where I’m starting from after installing the downloaded package for NVIDIA Web Drivers on my fully functioning system. All kexts & driver are latest version as of this week. Everything still works outputting via my motherboard’s IGFX DVI perfectly fine starting from this point:

Motherboard Settings:
- Peripherals > Initial Display Output > PCIe Slot

Clover Config.plist:
- SMBIOS > BoardVersion > iMac17,1
- Boot > Arguments > nvda_drv=1
- Graphics > Inject > Intel > true
- Graphics > Inject > Nvidia > false

After researching these forums at length, I’m also able to get the following to output via my GTX 1070 DVI with significant problems (as in, it is not actually usable, but I guess technically it works). From the above, I have to change:

Motherboard Settings:
- Peripherals > Initial Display Output > PCIe Slot 1

Clover Config.plist:
- Boot > Arguments > nv_disable [REMOVED]
- Graphics > Inject > Intel > false
- SystemParameters > NvidiaWeb > true
- KernelAndKextPatches > KextsToPatch > Applied

This results in a couple things:

1) It successfully outputs over the GTX1070 DVI port, but there is screen tearing, completely unusable input lag, and general graphical nonsense that is presumably all fixed by the released NVIDIA driver, except that…

2) The NVIDIA Driver Preferences always reverts to the OS X Default Graphics Driver instead of the Nvidia Driver no matter what I select before restarting, except that…

3) I CAN use Boot > Arguments > nvda_drv=1 to get the NVIDIA driver despite having a Clover newer than r3751 (this forum says to remove this setting, but its the only way for me to get the NVIDIA driver). However, with this settings I never even have my monitor recognize a signal from the computer port (as in, it is the black screen I had fixed with the AppleGraphicsDevicePolicy.kext patch mentioned above). I only know it selects the driver because it will boot to my perfectly working system and output over my IGFX DVI, but with the NVIDIA Web Driver selected in the Preferences Pane.

4) It only works this way if I use the GTX 1070 as my initial display output from the motherboard settings. It will not switch over if I boot into the IGFX and then use EFI settings to switch. This is how I previously handled dual-booting on my functioning system (monitor DVI plugged into IGFX is used to boot to EFI and continue to macOS, or if I select to boot to Windows, I change the monitor's input source to the DisplayPort plugged into the GTX 1070).

5) It will only output to the GTX 1070 DVI, but doesn't seem to work if I try it with the GTX 1070 DisplayPort.

6) Weirdest of all, the above only works when I use Clover’s verbose mode. Yep. With verbose ON, I boot in about 10 seconds. With verbose OFF, I hang permanently at the apple logo over a black background. This last point makes no sense at all, so I figured I’d report it.

Any ideas?
 
Last edited:
Top