[SOLVED] The Dreaded Asus Z10PE-D8 WS

Not open for further replies.
hi TpwUK
could you please summarize here what needs to be done to run sierra/high sierra on Z10Pe d8Ws
I have Geforce 1080 ti as video card
your help is appreciated
thank you
iMac 14,2 works here - Greetings from the Z10PE-D8 WS running macOS Sierra 10.12
Thanks for the tip P1LGRIM :)

Hey there, could you post your Clover config files? Trying to figure out UEFI / non-UEFI + Clover on a Z10PE-D8 WS with 2x E5 2699v4s and a 1080ti... what a pain lol.
you can get the Z10 to run Snow Leopard in legacy mode, but there are so many things that don't work in SL
like what exactly? i read the whole thread and except for not having the right graphics card your only other problem i spotted was the i210. the latter should be sorted with AppleIGB which is even available for 10.5.

i plan on using 10.6.8 with a Z10PA-U8. if anyone is interested i can report back on how that worked out.
Last edited:
quick feedback here, things are running fine. i'm writing this with an E5-2690 v4 and 10.6.8 and i had no issues at all. in fact 10.6.8 was the easiest and 10.12.6 the hardest because the latter requires a pci patch. otherwise you're stuck in a reboot loop.
10.8.5 turned out to be a bit of a diva as well but needs almost no kexts and has no showstoppers like the 10.12 pci issue.

bottom line is if you wanna max out 10.6.8, broadwell is your best bet because it's the last with usb 2.0. use a supported graphics card, throw in voodootsc and appleigb and if you don't wanna mod the kernel yourself use the one from iboot.
Hi everyone,

I just got a use z10-P8 WS and equipped it with 2 XEON e5-2690 v3 CPUS and 128 GB Memory.

Windows works fine (UEFI Install) but as soon as I try to use a device with Clover witihinthe EFI Partition the boot process failes with following error message: "roping tail with size: 2893847328"

I diabled virtualisation, enables CSM with Leagacy and UEFI and all Storage Controllers are configured as ACPI.

The USB stick and SSD where OSX is installed are working fine with my Asrock x99 and i7 6900K.

Any ideas what could be the reason?
Not open for further replies.