Contribute
Register

[Solved] Stuck with log showing AppleNVMe: Assert failed

Joined
Apr 10, 2017
Messages
23
Motherboard
GA-Z270X Gaming 7
CPU
i7-7700K
Graphics
GTX 1080 + Radeon WX PRO 7100
Mac
  1. MacBook
Mobile Phone
  1. iOS
Problem: First boot on a new hackintosh - attempting to install Sierra. Boot stalls after AppleNVMe Assert Failed line.

System is in my profile - note that I have not yet installed the GPU - I'm using onboard graphics for now to get the install done. I'm wanting to do the install on the SATA SSD, NOT the M.2 NVMe SSD (which I'm intending to use for Windows boot only).

Is there something I'm missing to turn off NVMe stuff in clover? Attached screen shots of boot screen and zipped clover sans themes. Appreciate any tips while I stumble along!

Thanks
Ed
 

Attachments

  • CLOVER.zip
    1.5 MB · Views: 422
  • IMG_7115.JPG
    IMG_7115.JPG
    4 MB · Views: 5,007
  • IMG_7116.JPG
    IMG_7116.JPG
    2.2 MB · Views: 4,372

BreBo

Moderator
Joined
Oct 17, 2011
Messages
9,449
Motherboard
Gigabyte GA-Z87X-OC
CPU
i7-4770K
Graphics
HD 4600 / RX 580
Attached screen shots of boot screen
For the freeze on the line with AppleUSBLegacyRoot:
At Clover Boot Screen select Options > PCI devices > USB Ownership and USB Injection

For permanent solution check Inject USB + FixOwnership in Clovers config.plist
Code:
  <key>USB</key>
        <dict>
            <key>FixOwnership</key>
            <true/>
            <key>Inject</key>
            <true/>
        </dict>
 
Joined
Apr 10, 2017
Messages
23
Motherboard
GA-Z270X Gaming 7
CPU
i7-7700K
Graphics
GTX 1080 + Radeon WX PRO 7100
Mac
  1. MacBook
Mobile Phone
  1. iOS
For the freeze on the line with AppleUSBLegacyRoot:
At Clover Boot Screen select Options > PCI devices > USB Ownership and USB Injection

For permanent solution check Inject USB + FixOwnership in Clovers config.plist
Code:
  <key>USB</key>
        <dict>
            <key>FixOwnership</key>
            <true/>
            <key>Inject</key>
            <true/>
        </dict>

Boom - that was fast - and effective. Thank you very much for your assistance sir. Problem solved and successfully made it to language selection.
 
Joined
Jun 26, 2013
Messages
1
Motherboard
OS X 10.9
CPU
i7
Graphics
HD 4000
Mac
Classic Mac
Mobile Phone
You are the man !
Work with Asus Prime H270-Pro !
Thanks !
 
Joined
Nov 24, 2018
Messages
17
Motherboard
GigaByte Z390 AORUS PRO
CPU
Intel Core i9-9900k
Graphics
Radeon Nitro+ Rx 580 8GB
Mac
  1. iMac
thank you so much for the quick fix, works on gigabyte z370n wifi as well!
 
Joined
Jun 16, 2012
Messages
33
Motherboard
Asus Maximus VI Hero Z390
CPU
i7-9700K
Graphics
Vega 64
I am having the same issue. Ive done the above suggested steps.
 
Joined
Mar 9, 2017
Messages
19
Motherboard
MSI Z390 CARBON AC
CPU
i9-9900K
Graphics
GTX 1080
For the freeze on the line with AppleUSBLegacyRoot:
At Clover Boot Screen select Options > PCI devices > USB Ownership and USB Injection

For permanent solution check Inject USB + FixOwnership in Clovers config.plist
Code:
  <key>USB</key>
        <dict>
            <key>FixOwnership</key>
            <true/>
            <key>Inject</key>
            <true/>
        </dict>

I tried both adding to config.plist and in the clover settings, but I'm still getting hung up around the "AppleNVMe Assert failed" :( (Trying to install Mojave)

<-- My specs are on my profile
 

Attachments

  • IMG_4190.JPG
    IMG_4190.JPG
    3.8 MB · Views: 633
Top