Contribute
Register

[Solved] Stuck at IOConsoleUsers: gIOScreenLockState 3

Joined
Sep 18, 2017
Messages
113
Motherboard
H170N-wifi
CPU
I3-7100
Graphics
HD630
Mobile Phone
iOS
Hi
I've updated to beta 2 and then login for first time successfully.



2nd power on my PC, it is stuck at IOConsoleUsers: gIOScreenLockState 3



anyone know how to fix. I'm using hd630 with whatevergreen kext (+lilu kext with latest versions) and ran well with beta 1.



Thank you.
 
Joined
Oct 1, 2018
Messages
15
Motherboard
MSI H270 Gaming M3
CPU
i5-7500
Graphics
HD 630
Mac
iMac, MacBook Air
Mobile Phone
Android, iOS
Stuck at IOConsoleUsers: gIOScreenLockState 3. I'm using hd630 with whatevergreen kext (+lilu kext with latest versions) and ran well with beta 1.
Post your EFI folder, I'll try to take a look at it. Did you enable -disablegfxfirmware?
 
Joined
Jun 4, 2019
Messages
3
Motherboard
MSI
CPU
Q9300
Graphics
Intel
Hi there, same problem here.
I couldn’t be able to boot after updating mac mojave to 10.14.5!!!
Please help me I added boot-arg “-disablegfxfirmware” but still same problem stuck and IOConsoleUsers: gIOScreenLockState 3.

I just update to mac mojave to 10.14.5 and then I restarted, Installed xcode used it built my app to my phone. Then I shutdown. After that Now when I’m turning it back on, it’s not booting up. :(
Please help to fix it!!!!

Thanks.
 

trs96

Moderator
Joined
Jul 31, 2012
Messages
16,325
Motherboard
GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
HD4600 / RX 570
Mac
iMac, Mac mini
Mobile Phone
Android
Joined
Sep 5, 2019
Messages
18
Motherboard
Gigabyte Z390 UD
CPU
i3-9100
Graphics
HD 630
Mac
MacBook Pro, Mac mini
Mobile Phone
iOS
Not sure if I am supposed to add to this thread, as the description is the same it COULD make sense, but then again maybe it should be a separate post. In the latter case, dear moderators, feel free to move it wherever you like (you would anyway, I am sure :)).

Here's the situation:
- fresh build
- fresh Mojave install
- solved various issues along the way up to and including step 4 & 5 of the guide with help from the useful information on these forums. You all rock!
- Ran into this problem late last night. Tried the -disablegfxfirmware solution, but that didn't work for me
- I understood it is most likely a graphics related issue and made the (in retrospect) mistake of messing around with the Fake_ID in the plist (found some information that indicated a certain value in the intel gfx box). This try DID make the boot from Mojave process continue past this error for a second, but then blacked out the screen. More or less confirming that it's a graphics (setting) related issue :).
- I have corrected my changes and tried again, to be met with the same stuc-point
- Looking for any help in getting me past this point

Screenshot from stuck-point and zipped EFI folder from my USB Installer included.
 

Attachments

pastrychef

Moderator
Joined
May 29, 2013
Messages
13,958
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Radeon VII
Mac
MacBook, Mac Pro
Classic Mac
iBook, Power Mac, PowerBook
Mobile Phone
iOS
Not sure if I am supposed to add to this thread, as the description is the same it COULD make sense, but then again maybe it should be a separate post. In the latter case, dear moderators, feel free to move it wherever you like (you would anyway, I am sure :)).

Here's the situation:
- fresh build
- fresh Mojave install
- solved various issues along the way up to and including step 4 & 5 of the guide with help from the useful information on these forums. You all rock!
- Ran into this problem late last night. Tried the -disablegfxfirmware solution, but that didn't work for me
- I understood it is most likely a graphics related issue and made the (in retrospect) mistake of messing around with the Fake_ID in the plist (found some information that indicated a certain value in the intel gfx box). This try DID make the boot from Mojave process continue past this error for a second, but then blacked out the screen. More or less confirming that it's a graphics (setting) related issue :).
- I have corrected my changes and tried again, to be met with the same stuc-point
- Looking for any help in getting me past this point

Screenshot from stuck-point and zipped EFI folder from my USB Installer included.
Try this EFI.

Injecting bogus device-id for IGPU causes more problems than it helps.
 

Attachments

Joined
Sep 5, 2019
Messages
18
Motherboard
Gigabyte Z390 UD
CPU
i3-9100
Graphics
HD 630
Mac
MacBook Pro, Mac mini
Mobile Phone
iOS
Try this EFI.

Injecting bogus device-id for IGPU causes more problems than it helps.
Thanks. Will give it a try. And yes, I understand about the id injection now (thought it came from a reliable source, goes to show you what I know). It's a journey, Hackintoshing. I AM having fun with it though.
 
Joined
Sep 5, 2019
Messages
18
Motherboard
Gigabyte Z390 UD
CPU
i3-9100
Graphics
HD 630
Mac
MacBook Pro, Mac mini
Mobile Phone
iOS
Tried the new EFI. During boot from Mojave it ran past the previous stuck-point. At some point it just rebooted. Tried twice and also tried to boot again from the Installer, same result, rebooted when expected to go into install screen.
 
Top