Contribute
Register

[Solved] Stuck at black screen after apple logo

Joined
Jun 15, 2017
Messages
4
Motherboard
Gigabit z170x gaming m5
CPU
I7 6700K skylake
Graphics
EVGA Nvidia 970 ACX
Hello everyone ! My Sierra hackintosh went into a boot loop after some modifications* My build was working fine and then I decided to follow a tutorial - for high sierra :( - to make my hackintosh faster for FCPX. This done when i restart my system i have a black screen after the clover menu ! Then the screen disconnect et it restart again and again.


- Undo the Bios change didn't help.
- Tried to restart using different option like nv_disable=1, didn't help neither
- The verbose show only ++++++++++ right from the start and then i’m stuck on the boot loop
- I did compress archive with my former config.plist before i made any change but i don’t know how to access it since i can’t launch OSX...
- Tried to boot from USB which appears on the clover menu : same black screen. If i unplug my SSD and boot with only the USB key, the usb key works
- pressing F12 to directly boot from the USB doesn't show any USB storage
- Tried to boot from a previous carbon copy storage : didn't work... If i unplug my SSD the carbon copy storage works
- I still can boot to windows 7 from the clover boot screen
- In windows i browse to /Volumes/EFI but there's no file ?!


Can somebody help me? Maybe my mistake was to follow a tutorial for high sierra when i'm using sierra ?

Is there a way to access my desktop and restore my previous config.plist ?

My Hackintosh : Sierra, i7 6700k, GIGABIT Z170X gaming M5, EGVA Geforce 970 ACX

thanks

*the modification

Following a tutorial i did this :

Download the latest RELEASE.zip of Shiki.kext
Copy & Paste Shiki.kext into EFI/CLOVER/kexts/Other
Download the latest RELEASE.zip of Lilu.kext
Copy & Paste Lilu.kext into EFI/CLOVER/kexts/Other
Download the most recent version of IntelGraphicsFixup.kext
Paste IntelGraphicsFixup.kext into EFI/CLOVER/kexts/Other
Download the most recent version of NvidiaGraphicsFixup.kext
Paste NvidiaGraphicsFixup.kext into EFI/CLOVER/kexts/Other
Download the most recent version of FAKEPCIID
Unzip RehabMan-FakePCIID folder
Copy FakePCIID.kext and FakePCIID_Intel_HD_Graphics.kext from the Release folder of Rehabman-FAKEPCIID
Paste FakePCIID.kext and FakePCIID_Intel_HD_Graphics.kext to EFI/CLOVER/kexts/Other

config.plist changes:

Navigate to Volumes/EFI/EFI/CLOVER/
Open config.plist with Clover Configurator
Select System Parameters on left-side column
Verify Inject Kexts is set to Yes
Select Boot on left-side column
Under Custom flags add:
Nvidia users:
shikigva=12

DSDT Patching

In config.plist Select Acpi on left-side column of Clover Configurator
Verify you have the following under DSDT -> Patches. It’s important that GFX0 -> iGPU is before PEGP -> GFX0
HECI -> IMEI Patch
Comment: change HECI to IMEI
Find* [Hex]: 48454349
Replace [Hex]: 494d4549
GFX0 -> IGPU Patch
Comment: change GFX0 to IGPU
Find* [Hex]: 47465830
Replace* [Hex] : 49475055
PEGP -> GFX0 Patch
Comment: change PEGP to GFX0
Find* [Hex]: 50454750
Replace [Hex]: 47465830
Save config.plist
Restart Hackintosh & Enter BIOS

Bios Change
Chipset → Integrated Graphics : Enabled
Chipset → DVMT Pre-Allocated :128M
Nvidia or AMD
Peripherals → Initial Display Output : PCIe 1 Slot​
 
Last edited:
Joined
Jun 15, 2017
Messages
4
Motherboard
Gigabit z170x gaming m5
CPU
I7 6700K skylake
Graphics
EVGA Nvidia 970 ACX
I manage to restore my hackintosh.
1 - plug a unibeast USB KEY
2 - plug a carbon copy
3 - plug my system SSD through a USB dock
4 - use Clover configurator to mount the EFI et restore back all the EFI partition content

After few tests, look like the problem is the last NvidiaGraphicsFixup.kext 1.2.6 doesn't work along with sierra or it demands some tweak to work well.
i'll try to put back the modified config.plist
 
Joined
Jun 15, 2017
Messages
4
Motherboard
Gigabit z170x gaming m5
CPU
I7 6700K skylake
Graphics
EVGA Nvidia 970 ACX
does anyone has a faster way to restore the efi?
 
Top