Contribute
Register

[SOLVED] Strange PowerNap/SMBIOS(Board-ID)/Airport behavior

Status
Not open for further replies.

RehabMan

Moderator
Joined
May 2, 2012
Messages
183,805
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Okay so after what seems like the 100th restart, the sound now works. I didn't do anything special, first boot without caches, ran "sudo touch /System/Library/Extensions && sudo kextcache -u /" (just like everytime else), rebooted, no sound, reboot again, no sound. But this particular time it complied. No idea; making time machine backup now :cool:
Thanks for all the help @RehabMan :thumbup:

for future:
- boot without caches *must* be done via Clover option (accessed via space bar)
- rebuild cache *must* be done very soon after booting
 
Joined
Jul 19, 2016
Messages
22
Motherboard
Elitebook 8470p
CPU
i5-3320M
Graphics
HD 4000
That's weird, the only way I know of to reliably boot without caches is pressing SPACE in clover (don't trust -f or UseKernelCache flags); I'm just glad the sound issue worked out... however it's murphy's law at work... I'm being punished for fixing a working system :lol:

The bluetooth appears to be malfunctioning after sleep :<
Pressing the hardware button a few times results in bluetooth working, but then WiFi becomes disabled :\
 
Last edited:
Joined
Jul 19, 2016
Messages
22
Motherboard
Elitebook 8470p
CPU
i5-3320M
Graphics
HD 4000
Here's the support zip I was going to upload yesterday. I added an IOREG dump of before and after sleeping. If there's anything else I can add to help let me know.
I had trouble with Bluetooth with PBI also, to get around the issue I remember experimenting with kexts I used in Yosemite, none of the kext backups I've kept are working, and I'm now just working with regular El Capitan versions. Just doesn't work after a 5minute sleep.
Most obvious thing somethings wrong:
Code:
[[0x4000]  OpCode 0x0C03 (Reset) from: kernel_task (0)  Synchronous  status: 0x00 (kIOReturnSuccess) state: 2 (BUSY) timeout: 10000] Bluetooth warning: An HCI Req timeout occurred.

**** [BroadcomBluetoothHostController][SetupController] -- disableHIDEmulation() failed -- result = 0x0010 (kBluetoothHCIErrorHostTimeout) -- retry 3 time(s) -- 0x5f00 ****

REQUIRE_NO_ERR failure: 0x10 - file: /BuildRoot/Library/Caches/com.apple.xbs/Sources/IOBluetoothFamily_kexts/IOBluetoothFamily-4406.4.1/Core/Family/HCI/HostControllers/IOBluetoothHostController.cpp:4173


**** [IOBluetoothFamily][ProcessBluetoothTransportShowsUpActionWL] -- Error!! -- Something went wrong in the setup process. Could not communicate with Bluetooth Transport successfully -- 0xe400 -- 0xe800 ****

Bluetooth - [0a5c:21e1]: USB [F4B7E2DC37E5 v274] "BCM20702A0" by "Broadcom Corp"
Wifi - (HP brand) Broadcom Corporation BCM43224 802.11a/b/g/n [14e4:4353] (rev 01)
 
Last edited:

RehabMan

Moderator
Joined
May 2, 2012
Messages
183,805
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Here's the support zip I was going to upload yesterday. I added an IOREG dump of before and after sleeping. If there's anything else I can add to help let me know.
I had trouble with Bluetooth with PBI also, to get around the issue I remember experimenting with kexts I used in Yosemite, none of the kext backups I've kept are working, and I'm now just working with regular El Capitan versions. Just doesn't work after a 5minute sleep.
Most obvious thing somethings wrong:
Code:
[[0x4000]  OpCode 0x0C03 (Reset) from: kernel_task (0)  Synchronous  status: 0x00 (kIOReturnSuccess) state: 2 (BUSY) timeout: 10000] Bluetooth warning: An HCI Req timeout occurred.

**** [BroadcomBluetoothHostController][SetupController] -- disableHIDEmulation() failed -- result = 0x0010 (kBluetoothHCIErrorHostTimeout) -- retry 3 time(s) -- 0x5f00 ****

REQUIRE_NO_ERR failure: 0x10 - file: /BuildRoot/Library/Caches/com.apple.xbs/Sources/IOBluetoothFamily_kexts/IOBluetoothFamily-4406.4.1/Core/Family/HCI/HostControllers/IOBluetoothHostController.cpp:4173


**** [IOBluetoothFamily][ProcessBluetoothTransportShowsUpActionWL] -- Error!! -- Something went wrong in the setup process. Could not communicate with Bluetooth Transport successfully -- 0xe400 -- 0xe800 ****

Bluetooth - [0a5c:21e1]: USB [F4B7E2DC37E5 v274] "BCM20702A0" by "Broadcom Corp"
Wifi - (HP brand) Broadcom Corporation BCM43224 802.11a/b/g/n [14e4:4353] (rev 01)

Your problem is caused by Android File Transfer.

Read the FAQ: http://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
 
Joined
Jul 19, 2016
Messages
22
Motherboard
Elitebook 8470p
CPU
i5-3320M
Graphics
HD 4000
That's so weird, I've always used Android File Transfer, as long as it's been out. I use OSX everyday.
I will try without it, never would have seen the link between the two, thanks for suggestion
 

RehabMan

Moderator
Joined
May 2, 2012
Messages
183,805
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
That's so weird, I've always used Android File Transfer, as long as it's been out. I use OSX everyday.
I will try without it, never would have seen the link between the two, thanks for suggestion

It is a well known incompatibility between BrcmPatchRAM and AFT. It comes up quite often. People should read the FAQ...
 
Joined
Jul 19, 2016
Messages
22
Motherboard
Elitebook 8470p
CPU
i5-3320M
Graphics
HD 4000
Thanks a lot, seems to be working fine after wake up now (4 wakes in so far, all good); now to figure out the default/best value for darkwake, starting with 11 (seems to be default) and going from there.

Glad I took the plunge(usually never touch working systems), a little bit readier to upgrade now when Sierra rolls around, support much appreciated:thumbup:
 

RehabMan

Moderator
Joined
May 2, 2012
Messages
183,805
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Thanks a lot, seems to be working fine after wake up now (4 wakes in so far, all good); now to figure out the default/best value for darkwake, starting with 11 (seems to be default) and going from there.

I never use the darkwake flag.
 
Joined
Jul 19, 2016
Messages
22
Motherboard
Elitebook 8470p
CPU
i5-3320M
Graphics
HD 4000
I never use the darkwake flag.

Thanks again for the input! I had noticed earlier that by feeding it the darkwake=11 flag, I wasn't seeing anything at all in the system log/dmesg/ about wakeups. Time machine was also not completing.
Removed the flag and restarted, hopefully no extra configuration necessary
 
Joined
Jul 19, 2016
Messages
22
Motherboard
Elitebook 8470p
CPU
i5-3320M
Graphics
HD 4000
Seems like bluetooth is still dying upon wake, even without AFT
Man, Yosemite really was a better operating system in every way I can think of... el cap has been nothing but troublesome and sacrifices :\

Code:
BrcmPatchRAM2: [0a5c:21e1]: device request failed ("0xe0005000 (UNDEFINED)" 0xe0005000).
BrcmPatchRAM2: [0a5c:21e1]: readCompletion - Return aborted (0xe00002eb)
BrcmPatchRAM2: [0a5c:21e1]: Firmware upgrade failed.
BrcmPatchRAM2: [0a5c:21e1]: Found existing IOKit personality "com.apple.iokit.BroadcomBluetoothHostControllerUSBTransport".
BrcmPatchRAM2: Processing time 64.65 seconds.
BrcmPatchRAM2: Version 2.2.7 starting on OS X Darwin 15.6.
BrcmPatchRAM2: [0a5c:21e1]: USB [F4B7E2DC37E5 v274] "BCM20702A0" by "Broadcom Corp"
BrcmPatchRAM2: [0a5c:21e1]: Firmware upgrade completed successfully.
BrcmPatchRAM2: [0a5c:21e1]: Found existing IOKit personality "com.apple.iokit.BroadcomBluetoothHostControllerUSBTransport".
BrcmPatchRAM2: Processing time 240.27 seconds.
Couldn't alloc class "BroadcomBluetoothHostControllerUSBTransport"
 
Last edited:
Status
Not open for further replies.
Top