Contribute
Register

[solved] Sleep issues

Status
Not open for further replies.
Joined
Apr 30, 2017
Messages
17
Motherboard
Toshiba Satellite S55-C5360
CPU
i7-6500U
Graphics
HD520 1366x768/NVIDIA GeForce 930M
Mac
  1. iMac
  2. MacBook Air
Mobile Phone
  1. iOS
I posted previously under the SSDT-UAIC thread for USBInjectAll as I thought that was my issue. RehabMan was kind enough to point out that my installation was a mess (it was a wreck) so I started from scratch and followed every guide I could find for everything I was trying to accomplish. So far, everything is working except sleep. I have googled the issue for several hours and have yet to find a solution. Going from the apple menu to sleep will put the laptop to sleep after about 120 seconds. Wake with the power button only to a black screen with pointer that I can move for about 2 or 3 minutes and then reboot automatically with a sleep/wake error. I have tried all different dark wake options some will bring back the desktop but nothing works except the pointer moves but I can't click anything and then automatic reboot every time. Please help (and if you notice anything else I have wrong please point it out). Thanks!
 

Attachments

  • debug_4778.zip
    2.4 MB · Views: 86
  • sleep:wake report.zip
    9.8 KB · Views: 60
Joined
Apr 30, 2017
Messages
17
Motherboard
Toshiba Satellite S55-C5360
CPU
i7-6500U
Graphics
HD520 1366x768/NVIDIA GeForce 930M
Mac
  1. iMac
  2. MacBook Air
Mobile Phone
  1. iOS
Ah yes. I did start to attempt this and I located the SSDT which contained both _OFF and _INI however what I was finding was not matching the guide and I couldn’t figure out exactly what I needed to do to accomplish the patch. I am by no means skilled in programming and I admit if there isn’t a patch in the repo, then I haven’t made any changes manually to the DSDT or SSDTs (aside from SSDT-UIAC as that was one rather obvious for what I needed to resolve). I’m at work for the day otherwise I would take a stab at it right now again. Will look at it again tonight if I get a chance and report back. Thanks.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
186,728
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
I posted previously under the SSDT-UAIC thread for USBInjectAll as I thought that was my issue. RehabMan was kind enough to point out that my installation was a mess (it was a wreck) so I started from scratch and followed every guide I could find for everything I was trying to accomplish. So far, everything is working except sleep. I have googled the issue for several hours and have yet to find a solution. Going from the apple menu to sleep will put the laptop to sleep after about 120 seconds. Wake with the power button only to a black screen with pointer that I can move for about 2 or 3 minutes and then reboot automatically with a sleep/wake error. I have tried all different dark wake options some will bring back the desktop but nothing works except the pointer moves but I can't click anything and then automatic reboot every time. Please help (and if you notice anything else I have wrong please point it out). Thanks!

Read here:
https://www.tonymacx86.com/threads/readme-common-problems-in-10-13-high-sierra.233582/
 
Joined
Apr 30, 2017
Messages
17
Motherboard
Toshiba Satellite S55-C5360
CPU
i7-6500U
Graphics
HD520 1366x768/NVIDIA GeForce 930M
Mac
  1. iMac
  2. MacBook Air
Mobile Phone
  1. iOS
So I have done this:
https://www.tonymacx86.com/threads/...-only-ran-for-0-seconds-with-dual-gpu.233092/
And this:
https://www.tonymacx86.com/threads/solved-black-screen-after-upgrade-to-high-sierra.237050/page-5

Black screen after sleep is resolved. I can now see the desktop. However, I am still having the long delay before sleep and while I can see the desktop after sleep, I still cannot interact with it. System is frozen and eventually reboots. Most recent problem reporting files attached.
 

Attachments

  • debug_30064.zip
    2.2 MB · Views: 84

RehabMan

Moderator
Joined
May 3, 2012
Messages
186,728
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
So I have done this:
https://www.tonymacx86.com/threads/...-only-ran-for-0-seconds-with-dual-gpu.233092/
And this:
https://www.tonymacx86.com/threads/solved-black-screen-after-upgrade-to-high-sierra.237050/page-5

Black screen after sleep is resolved. I can now see the desktop. However, I am still having the long delay before sleep and while I can see the desktop after sleep, I still cannot interact with it. System is frozen and eventually reboots. Most recent problem reporting files attached.

What do you mean by "long delay before sleep"?

And what do you mean by "System is frozen and eventually reboots"? Seems to conflict with "Black screen after sleep is resolved".
 
Joined
Apr 30, 2017
Messages
17
Motherboard
Toshiba Satellite S55-C5360
CPU
i7-6500U
Graphics
HD520 1366x768/NVIDIA GeForce 930M
Mac
  1. iMac
  2. MacBook Air
Mobile Phone
  1. iOS
What do you mean by "long delay before sleep"?

And what do you mean by "System is frozen and eventually reboots"? Seems to conflict with "Black screen after sleep is resolved".
Long delay before sleep: I go to Apple menu>sleep. Screen immediately goes dark but laptop is still on for about 2 minutes then it sleeps and will stay asleep. I press power to turn the system back on and after a few seconds the desktop appears and I can move the mouse pointer but I cannot click on anything. Nothing responds. No finder windows. No dock icons. Cannot “right click” for any menus. Nothing. It sits that way for around 4 or 5 minutes and then restarts itself. After reboot the system is back to normal. Prior to the EDID guide posted above, the desktop would not appear. Just a black screen with cursor. Same 4-5 minutes before it would reboot. So the only thing that has been fixed is now instead of the screen being black, I can now see the desktop but all other behavior is the same.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
186,728
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Long delay before sleep: I go to Apple menu>sleep. Screen immediately goes dark but laptop is still on for about 2 minutes then it sleeps and will stay asleep.

Not unusual.
15-20 second delay is normal, longer if assertions need to clear.

I press power to turn the system back on and after a few seconds the desktop appears and I can move the mouse pointer but I cannot click on anything. Nothing responds. No finder windows. No dock icons. Cannot “right click” for any menus. Nothing. It sits that way for around 4 or 5 minutes and then restarts itself. After reboot the system is back to normal.

May be related to PS2 kexts you're using. Try without them and use USB keyboard/mouse instead (as a test).

Also, you have some unnecessary patches applied to DSDT. Apply only those that are required.

And SSDT-DiscreteSpoof.aml is short term. At post install, you should properly disable the secondary GPU device instead of spoofing. Note that you profile indicates you have no secondary GPU, so I have no idea why you have SSDT-DiscreteSpoof.aml in the first place (either your profile is wrong, or you don't need it... up to you to decide which and fix).

Your profile is also lacking screen resolution. Please fix.

You also forgot to disable hibernation. Read here:
https://www.tonymacx86.com/threads/guide-native-power-management-for-laptops.175801/
 
Joined
Apr 30, 2017
Messages
17
Motherboard
Toshiba Satellite S55-C5360
CPU
i7-6500U
Graphics
HD520 1366x768/NVIDIA GeForce 930M
Mac
  1. iMac
  2. MacBook Air
Mobile Phone
  1. iOS
May be related to PS2 kexts you're using. Try without them and use USB keyboard/mouse instead (as a test).
Tested. Not related.
Also, you have some unnecessary patches applied to DSDT. Apply only those that are required.
Done. Applied only battery patch, osfix, IRQfix, AudioLayout3
And SSDT-DiscreteSpoof.aml is short term. At post install, you should properly disable the secondary GPU device instead of spoofing. Note that you profile indicates you have no secondary GPU, so I have no idea why you have SSDT-DiscreteSpoof.aml in the first place (either your profile is wrong, or you don't need it... up to you to decide which and fix).
Removed SSDT-DiscreteSpoof.aml. I do have secondary GPU. Signature/profile updated.
Your profile is also lacking screen resolution. Please fix.
Done.
Also done.

Issue is resolved. I removed the SSDT-DiscreteSpoof.aml. I followed the guide to correctly patch SSDT to disable NVIDIA GPU as well as disable hibernation properly (I remember doing this but it may have been before I started over fresh). Thanks for your help.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
186,728
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Issue is resolved. I removed the SSDT-DiscreteSpoof.aml. I followed the guide to correctly patch SSDT to disable NVIDIA GPU as well as disable hibernation properly (I remember doing this but it may have been before I started over fresh). Thanks for your help.

Marked solved.
 
Status
Not open for further replies.
Top