Contribute
Register

[SOLVED] Sierra 750 TI Black Screen After Logo (DVI/VGA/HDMI)

Joined
Aug 14, 2016
Messages
7
Motherboard
MSi H81Mm-P33
CPU
Intel Core i7 3.6 Ghz
Graphics
ASUS NVIDIA GTX750 TI OC
Mac
iMac
Mobile Phone
iOS
Hi all. I once had Sierra working fine only on HDMI, DVI never worked but i only need one monitor so that's fine. Since I've switched my hard drive and tried to install again, I can't go through the apple logo.. it gives me a black screen. Tried every solution even AGP Fix. I have Inject Nvida False and I am using the correct WebDrivers.

My board is MSI H81M-P33.
Graphics: ASUS Nvidia GTX 750 TI OC
HyperX 16GB RAM 1600 Mhz
Intel Core I7-4790 3.6 GHZ.
 

slim.jim

Moderator
Joined
Dec 17, 2014
Messages
4,112
Motherboard
MSI Z97 Gaming 9 AC
CPU
i7-4790K
Graphics
RX 5700 XT
Mac
MacBook Pro
Classic Mac
PowerBook
Mobile Phone
iOS
What SMBIOS are you using? Have you read any of the troubleshooting sticky threads? If you are using HDMI you will need to flash your card with the VBIOS from another manufacturer because of an issue specific to ASUS cards.
 
Joined
Aug 14, 2016
Messages
7
Motherboard
MSi H81Mm-P33
CPU
Intel Core i7 3.6 Ghz
Graphics
ASUS NVIDIA GTX750 TI OC
Mac
iMac
Mobile Phone
iOS
What SMBIOS are you using? Have you read any of the troubleshooting sticky threads? If you are using HDMI you will need to flash your card with the VBIOS from another manufacturer because of an issue specific to ASUS cards.
I am using iMac 14,2. I am right now using DVI, but I get stuck on apple logo
 

jyc

Joined
Dec 8, 2012
Messages
13
Motherboard
Sandy Bridge
CPU
2600k
Graphics
HD3000
Mac
Classic Mac
Mobile Phone
that card doesn't work, period.

Some had success flashing other card's BIOS, but I've tried a lot of the BIOS floating around and never got it to work. Use integrated until you get a card~
 
Joined
Aug 14, 2016
Messages
7
Motherboard
MSi H81Mm-P33
CPU
Intel Core i7 3.6 Ghz
Graphics
ASUS NVIDIA GTX750 TI OC
Mac
iMac
Mobile Phone
iOS
that card doesn't work, period.

Some had success flashing other card's BIOS, but I've tried a lot of the BIOS floating around and never got it to work. Use integrated until you get a card~
I got it working by flashing my card BIOS with GM107 rom. Did it yesterday and after Sierra installation all ports (DVI/HDMI/VGA) are working just fine.
 

jyc

Joined
Dec 8, 2012
Messages
13
Motherboard
Sandy Bridge
CPU
2600k
Graphics
HD3000
Mac
Classic Mac
Mobile Phone
Congrats! I had no luck with various BIOS. I have since sold the card anyway, oh well.
 
Top