Contribute
Register

[Solved] Serial Number - Unavailable

Joined
Feb 8, 2010
Messages
164
Motherboard
Gigabyte GA-Z87X-UD4H
CPU
i5-4670K
Graphics
RX 580
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Hi my serial number is showing as unavailable and the Mac model is missing.

aboutmac.png

I have used this serial number for years without issue. My iMessage is currently working fine. Primarily I am concerned about the Mac model not showing and would like to get this fixed.

Attached is my EFI. Yes it is very minimal.

Things that have changed:
- Installed a new RX 580 graphics card
- I am pretty sure the SN showed after the GPU install. The issue seems to have occurred since I was trying to get the framebuffer to be correct in Sierra. Ended up just using Lilu+WEG with the default frame buffer.

Things I have tried:
1. Searching tonymacx86 and google. All I could find is this issue occurring for regular Macs.
2. Updating Clover
3. Resetting NVRAM - boot into single user mode and run: sudo nvram -c
4. Making sure my config.plist is formatted correctly using an online XML validation checker
6. Ran iMessageDebug and again after reboot and all the values stay the same.
6. Booted into a High Sierra install and the same issue. I prefer to say on Sierra for now (so I don't have to set back up my environment)
7. I removed the "External icons patch" to see if I still needed it and my icons were still showing as internal. This was around the time that the issue occurred. I added it back to config and issue still remains.
 

Attachments

  • EFI.zip
    2.1 MB · Views: 188
Top