Contribute
Register

[SOLVED] Sata drives not loading, AppleTyMCEDriver, AppleIntelCPUPowerManagement problems

Status
Not open for further replies.
Joined
Aug 29, 2015
Messages
64
Motherboard
EVGA-SR2 Classified
CPU
XEON E5645 2.4GHz
Graphics
AMD RX580 8GB
Mac
  1. iMac
  2. Mac Pro
Mobile Phone
  1. Android
Hi, this is my first post, so forgive me if I do not respect some code of conduct, but I wanted to share this after 2 weeks of trying to solve the problems many of us have:
- SATA drives are not mounted during boot, or, even more frustrating, sometimes yes, sometimes no
- AppleTyMCEDriver.kext blocking during the first install
- AppleIntelCPUPowerManagement.kext waiting for you, once you've painstakingly managed to patch your config.plist and get through the AppleTyMCEDriver.kext

I have tried so many patches, manually with plist editor, or with clover, and then I understood that AppleTyMCEDriver is for ECC rams only, so it's just a model problem in SIMBIOS, so you just need to use any iMac or Macpro3,1 , and this also cleared, for me at least, the AICPM problem, which also depends on the model.

For Sierra and High Sierra, MacPro3,1 won't work, so I used iMac13,1 and it works like a charm for all 3 systems. Just remove the AppleTyMCEDriver once you're logged in, it's useless if you don't have ECC RAMs.

But the SATA problem drove me mad, I couldn't find anything to make it work, even with all those SATA kexts out there such as SuperVIAATA, AppleNForceATA etc... when you look in 'System Information', at least in my case, some are not even loaded. And why do some drives load sometimes, which drove me nuts because then I had to question the cables, the drives themselves, in which position the SATA cable is plugged etc ...

And then I remembered I had an old Yosemite partition as a safety, I hadn't used it for a year, but I remembered that it did load the disks. I tried it and it worked beautifully. I added the SIP bypass for Sierra without any other changes.

In the end, this little config.plist, very simple, that I attach here works, on 10.10, 10.12, 10.13 without any DSDT at all.
So, if you're stuck with these problems, just give it a shot. I have skipped El Capitan, but it would probably work as well. I just tried it with 10.13.2 and a AMD Rx Vega card, no problem. And my mobo is 6 years old now, I was expecting problems one day, but not so far.

I have compared this config.list to the ones that didn't work, the 'sophisticated ones', and I couldn't pinpoint one thing in particular, I am not an expert by far but maybe it's just the sophisticated ones that have too much stuff in them. I am so glad I have this config. It may not work on your setup, but then I'd say it's a good starting point. Otherwise, you may get sucked into fiddling with so many parameters, fixes and doing hundred reboots, for days, inflating your config file more and more.

In the end, OSX is supposed to run on a limited number of hardware configurations... feeding it with unexpected, complex combinations of fixes and tweaks, and manually changed keys could simply confuse it, but that's just a hunch.

Hope this helps.
 

Attachments

  • config without serial numbers.plist
    4 KB · Views: 301
Last edited:
Status
Not open for further replies.
Top