Contribute
Register

(Solved) Realtek Killer E3000 Ethernet Not Working - use LucyRTL8125Ethernet.kext for Realtek RTL8125

Status
Not open for further replies.

Feartech

Moderator
Joined
Aug 3, 2013
Messages
24,904
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
i was going off of the driver information from the dell Alienware m15r2 website
your preboot.log as no mention of Atheros........
 
Joined
Oct 24, 2018
Messages
96
Motherboard
Dell Alienware m15 r2 - 1.3.9 - Open Core
CPU
i9-9880HK/HM370
Graphics
UHD 630, 1920x1080
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
nope, that didn't work either. hmmm I can't get any ethernet kexts to load, Will they only start if the recognise supported hardware? I would think they would be able to run
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
24,904
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
nope, that didn't work either. hmmm I can't get any ethernet kexts to load, Will they only start if the recognise supported hardware? I would think they would be able to run
what makes you think using an ethernet kext would work if you do not have the hardware? why are you trying to make something work that won't work because you do not have the hardware?
 

P1LGRIM

Moderator
Joined
Mar 2, 2012
Messages
25,500
Motherboard
Lenovo ThinkStation p700
CPU
2x E5-2620 V3
Graphics
RX 560
Mac
  1. MacBook Pro
  2. Mac mini
Classic Mac
  1. Power Mac
Mobile Phone
  1. iOS
0:105 0:000 === [ GetDevices ] ==============================
0:105 0:000 GOP found at: PciRoot(0x0)/Pci(0x2,0x0)/AcpiAdr(0x80011400)
0:105 0:000 PCI (00|00:00.00) : 8086 3E20 class=060000
0:105 0:000 PCI (00|00:01.00) : 8086 1901 class=060400
0:105 0:000 PCI (00|01:00.00) : 10DE 1E90 class=030000
0:105 0:000 - GFX: Model=Unknown family 1FF (NVidia unknown)
0:105 0:000 PCI (00|01:00.01) : 10DE 10F8 class=040300
0:105 0:000 - HDMI Audio:
0:105 0:000 PCI (00|01:00.02) : 10DE 1AD8 class=0C0330
0:105 0:000 PCI (00|01:00.03) : 10DE 1AD9 class=0C8000
0:105 0:000 PCI (00|00:01.01) : 8086 1905 class=060400
0:105 0:000 PCI (00|00:02.00) : 8086 3E9B class=030000
0:105 0:000 - GOP: Provided by device
0:105 0:000 - GFX: Model=Intel UHD Graphics 630 (Intel)
0:105 0:000 PCI (00|00:04.00) : 8086 1903 class=118000
0:105 0:000 PCI (00|00:12.00) : 8086 A379 class=118000
0:105 0:000 PCI (00|00:13.00) : 8086 A37C class=070000
0:105 0:000 PCI (00|00:14.00) : 8086 A36D class=0C0330
0:105 0:000 PCI (00|00:14.02) : 8086 A36F class=050000
0:105 0:000 PCI (00|00:15.00) : 8086 A368 class=0C8000
0:105 0:000 PCI (00|00:16.00) : 8086 A360 class=078000
0:105 0:000 PCI (00|00:1B.00) : 8086 A340 class=060400
0:105 0:000 PCI (00|03:00.00) : 8086 15DA class=060400
0:105 0:000 PCI (00|04:00.00) : 8086 15DA class=060400
0:105 0:000 PCI (00|05:00.00) : 8086 15D9 class=088000
0:105 0:000 PCI (00|04:01.00) : 8086 15DA class=060400
0:105 0:000 PCI (00|04:02.00) : 8086 15DA class=060400
0:105 0:000 PCI (00|3B:00.00) : 8086 15DB class=0C0330
0:105 0:000 PCI (00|00:1B.04) : 8086 A32C class=060400
0:106 0:000 PCI (00|3C:00.00) : 1C5C 1627 class=010802
0:106 0:000 PCI (00|00:1D.00) : 8086 A330 class=060400
0:106 0:000 PCI (00|3D:00.00) : 10EC 5762 class=010802
0:106 0:000 PCI (00|00:1D.06) : 8086 A336 class=060400
0:106 0:000 PCI (00|3E:00.00) : 10EC 3000 class=020000
0:106 0:000 - LAN: 0 Vendor=Realtek
0:106 0:000 PCI (00|00:1D.07) : 8086 A337 class=060400
0:106 0:000 PCI (00|3F:00.00) : 8086 2723 class=028000
0:106 0:000 - WIFI: Vendor=32902 = Intel
0:106 0:000 PCI (00|00:1F.00) : 8086 A30D class=060100
0:106 0:000 PCI (00|00:1F.03) : 8086 A348 class=040300
0:106 0:000 PCI (00|00:1F.04) : 8086 A323 class=0C0500
0:106 0:000 PCI (00|00:1F.05) : 8086 A324 class=0C8000

0:106 0:000 PCI (00|3E:00.00) : 10EC 3000 class=020000
0:106 0:000 - LAN: 0 Vendor=Realtek
 
Joined
Oct 24, 2018
Messages
96
Motherboard
Dell Alienware m15 r2 - 1.3.9 - Open Core
CPU
i9-9880HK/HM370
Graphics
UHD 630, 1920x1080
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
what makes you think using an ethernet kext would work if you do not have the hardware? why are you trying to make something work that won't work because you do not have the hardware?
I am just trying to make my ethernet to work. I was going off of the dell website and it said I had killer ethernet. I thought that killer ethernet required AtherosE2200Ethernet.kext

I now see that this is not the case and that I need a Realtek one. I am new at this and was going off of reference clover folders from others who have made EFI folders for similar machines.

Sorry for the confusion, regardless the RealtekRTL8111 kext is not working either. I will change the name in the post to avoid confusion

Thanks for trying to help me through this
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
24,904
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
I am just trying to make my ethernet to work. I was going off of the dell website and it said I had killer ethernet. I thought that killer ethernet required AtherosE2200Ethernet.kext

I now see that this is not the case and that I need a Realtek one. I am new at this and was going off of reference clover folders from others who have made EFI folders for similar machines.

Sorry for the confusion, regardless the RealtekRTL8111 kext is not working either. I will change the name in the post to avoid confusion

Thanks for trying to help me through this
no worries, just delete your other ethernet kexts and try the realtek on it's own
 

P1LGRIM

Moderator
Joined
Mar 2, 2012
Messages
25,500
Motherboard
Lenovo ThinkStation p700
CPU
2x E5-2620 V3
Graphics
RX 560
Mac
  1. MacBook Pro
  2. Mac mini
Classic Mac
  1. Power Mac
Mobile Phone
  1. iOS
regardless the RealtekRTL8111 kext is not working either.



Also check that your Ethernet controller is enabled in the BIOS settings.
It is not unknown for disabled devices to show up in lists.
 
Joined
Oct 24, 2018
Messages
96
Motherboard
Dell Alienware m15 r2 - 1.3.9 - Open Core
CPU
i9-9880HK/HM370
Graphics
UHD 630, 1920x1080
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
I have a usb wireless dongle that looks like it is using Realtek drivers ? it also thinks its a wired connection
could that be interfering ?

Also I will try the Realtek drivers again and let you know
 
Joined
Oct 24, 2018
Messages
96
Motherboard
Dell Alienware m15 r2 - 1.3.9 - Open Core
CPU
i9-9880HK/HM370
Graphics
UHD 630, 1920x1080
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Also check that your Ethernet controller is enabled in the BIOS settings.
It is not unknown for disabled devices to show up in lists.
I don't have a bios option to disable it, and it works in both manjaro and windows
 

P1LGRIM

Moderator
Joined
Mar 2, 2012
Messages
25,500
Motherboard
Lenovo ThinkStation p700
CPU
2x E5-2620 V3
Graphics
RX 560
Mac
  1. MacBook Pro
  2. Mac mini
Classic Mac
  1. Power Mac
Mobile Phone
  1. iOS
I have a usb wireless dongle that looks like it is using Realtek drivers ?

0:106 0:000 PCI (00|3F:00.00) : 8086 2723 class=028000
0:106 0:000 - WIFI: Vendor=32902 = Intel
 
Status
Not open for further replies.
Top