Contribute
Register

[solved] Problems patching DSDT and AppleHDA

Status
Not open for further replies.
Joined
Jan 9, 2016
Messages
219
Motherboard
Cube mix plus
CPU
M3-7y30
Graphics
HD 615, 1920 × 1080
Hi,
I'm trying to patch DSDT for battery stats, enabling brightness and applehda...
For AppleHDA I'm successfully enabled headphones (I can use external microphone and speaker) but osx can't detect my internal speaker/microphone... I used cloveralc(ALC283)

For DSDT patch I pressed F4 and dumped ACPI then I fixed the errors and followed the guide for enabling the battery stats... At the reboot I have no indicator... I think I followed the guide good, but it is clear that I'm doing wrong something...

For brightness I followed the guide, placed the SSDT patch on clover and then installed the kext, but in monitor I can't see the brightness setting...

I'm also finding a way to fix the graphics glitch, but I don't understand how to fix it...

Thanks for your help, these are the required files for support.
 

Attachments

  • debug_30631.zip
    1.8 MB · Views: 36

RehabMan

Moderator
Joined
May 3, 2012
Messages
186,727
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Hi,
I'm trying to patch DSDT for battery stats, enabling brightness and applehda...
For AppleHDA I'm successfully enabled headphones (I can use external microphone and speaker) but osx can't detect my internal speaker/microphone... I used cloveralc(ALC283)

ALC283 needs CodecCommander.kext.
Your kextcache indicates it is not installed.

For DSDT patch I pressed F4 and dumped ACPI then I fixed the errors and followed the guide for enabling the battery stats... At the reboot I have no indicator... I think I followed the guide good, but it is clear that I'm doing wrong something...

Your kextcache indicates ACPIBatteryManager.kext is not installed.
Read the guide carefully:
https://www.tonymacx86.com/threads/guide-how-to-patch-dsdt-for-working-battery-status.116102/

For brightness I followed the guide, placed the SSDT patch on clover and then installed the kext, but in monitor I can't see the brightness setting...

Your config.plist is missing the patch for AppleBacklight.
Read the guide carefully:
https://www.tonymacx86.com/threads/...rol-using-applebacklightinjector-kext.218222/

I'm also finding a way to fix the graphics glitch, but I don't understand how to fix it...

Read here:
https://www.tonymacx86.com/threads/readme-common-problems-in-10-13-high-sierra.233582/

--

Also...
Your kextcache output proves kexts are not installed correctly.
All kexts you need must be installed to the system volume.
Read post #2 of the Clover guide for details:
https://www.tonymacx86.com/threads/guide-booting-the-os-x-installer-on-laptops-with-clover.148093/
 
Joined
Jan 9, 2016
Messages
219
Motherboard
Cube mix plus
CPU
M3-7y30
Graphics
HD 615, 1920 × 1080
ALC283 needs CodecCommander.kext.
Your kextcache indicates it is not installed.

I installed it but the audio is still not detected
I'd like to add also that the guide I used not mention codeccommander.kext(cloveralc)

Your kextcache indicates ACPIBatteryManager.kext is not installed.
Read the guide carefully:
https://www.tonymacx86.com/threads/guide-how-to-patch-dsdt-for-working-battery-status.116102/

Installed it, I can see now the battery indicator but it is stuck at 0%... Power AC is correctly detected but it don't change from 0%..

Your config.plist is missing the patch for AppleBacklight.
Read the guide carefully:
https://www.tonymacx86.com/threads/...rol-using-applebacklightinjector-kext.218222/

Added but no brightness indication in Monitor.

Also...
Your kextcache output proves kexts are not installed correctly.
All kexts you need must be installed to the system volume.
Read post #2 of the Clover guide for details:

Installed
 

Attachments

  • debug_10471.zip
    1.8 MB · Views: 35
Last edited:

RehabMan

Moderator
Joined
May 3, 2012
Messages
186,727
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
I installed it but the audio is still not detected
I'd like to add also that the guide I used not mention codeccommander.kext(cloveralc)

ALC283 is the same as my Lenovo u430. You can use AppleHDA_ALC283.kext in my u430 repo...

https://github.com/RehabMan/Lenovo-U430-Touch-DSDT-Patch

Requirements:
- Clover bootloader
- config.plist must have the four AppleHDA patches from my config.plist in the repo (but not the zml.zlib patch)
- AppleHDA.kext must be vanilla
- CodecCommander.kext installed to /S/L/E: https://github.com/RehabMan/EAPD-Codec-Commander
- AppleHDA_ALC283.kext installed to /S/L/E
- rebuild cache following the procedure detailed in the u430 guide: http://www.tonymacx86.com/yosemite-...ideapad-u330-u430-u530-using-clover-uefi.html
- DSDT patches "IRQ Fix" and "Audio Layout 3".

Installed it, I can see now the battery indicator but it is stuck at 0%... Power AC is correctly detected but it don't change from 0%..

Your ACPI is not patched correctly (looks like _BIF and _BST are failing).
See guide:
https://www.tonymacx86.com/threads/guide-how-to-patch-dsdt-for-working-battery-status.116102/


Added but no brightness indication in Monitor.

Brightness requires properly working graphics. You're using an invalid ig-platform-id (0x12345678) which disables the graphics drivers.

Installed

config.plist/SystemParameters/InjectKexts=Yes is wrong. Must be set "Detect".
 
Joined
Jan 9, 2016
Messages
219
Motherboard
Cube mix plus
CPU
M3-7y30
Graphics
HD 615, 1920 × 1080
ALC283 is the same as my Lenovo u430. You can use AppleHDA_ALC283.kext in my u430 repo...

https://github.com/RehabMan/Lenovo-U430-Touch-DSDT-Patch

Requirements:
- Clover bootloader
- config.plist must have the four AppleHDA patches from my config.plist in the repo (but not the zml.zlib patch)
- AppleHDA.kext must be vanilla
- CodecCommander.kext installed to /S/L/E: https://github.com/RehabMan/EAPD-Codec-Commander
- AppleHDA_ALC283.kext installed to /S/L/E
- rebuild cache following the procedure detailed in the u430 guide: http://www.tonymacx86.com/yosemite-...ideapad-u330-u430-u530-using-clover-uefi.html
- DSDT patches "IRQ Fix" and "Audio Layout 3".
OK, I'll try it. Thanks.

Your ACPI is not patched correctly (looks like _BIF and _BST are failing).
See guide:
https://www.tonymacx86.com/threads/guide-how-to-patch-dsdt-for-working-battery-status.116102/

I tried to patch BST (as written in the guide) but when I copy the patch it doesn't recognize it and I cannot apply it...

Brightness requires properly working graphics. You're using an invalid ig-platform-id (0x12345678) which disables the graphics drivers.

How to find a good ig-platform-id? I tried to use a ig-platform-id from another "mix plus" tablet(same model) but osx doesn't boot...

config.plist/SystemParameters/InjectKexts=Yes is wrong. Must be set "Detect".

OK thanks, I'll fix it.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
186,727
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
I tried to patch BST (as written in the guide) but when I copy the patch it doesn't recognize it and I cannot apply it...

ACPI is not even patched correctly at all...
For example, no accommodation for _OSI("Darwin") (eg. no "OS Check Fix").
See guide:
https://www.tonymacx86.com/threads/guide-patching-laptop-dsdt-ssdts.152573/

How to find a good ig-platform-id? I tried to use a ig-platform-id from another "mix plus" tablet(same model) but osx doesn't boot...

Systematically try all valid ig-platform-id values.

Install Hex Fiend.
In Terminal:
Code:
open -a "Hex Fiend" /System/Library/Extensions/AppleIntelSKLGraphicsFramebuffer.kext/Contents/MacOS/AppleIntelSKLGraphicsFramebuffer
In Hex Fiend, search for a known ig-platform-id, for example, 0x19120000 is hex search for '00 00 12 19'
Each ig-platform-id is 184 bytes (in this kext and KBL).
It helps to expand the Hex Fiend window to 23 columns (need a big screen, 184/4/2=23), because then you can see each ig-platform-id lined up vertically (every other row).
You will find the table starts with 0x191e0000 and the last is 0x19260007. The 0xFFFFFFFF signifies the end of table.
 
Joined
Jan 9, 2016
Messages
219
Motherboard
Cube mix plus
CPU
M3-7y30
Graphics
HD 615, 1920 × 1080
Sistematically try all valid ig-platform-id values.

Install Hex Fiend.
In Terminal:
Code:
open -a "Hex Fiend" /System/Library/Extensions/AppleIntelSKLGraphicsFramebuffer.kext/Contents/MacOS/AppleIntelSKLGraphicsFramebuffer
In Hex Fiend, search for a known ig-platform-id, for example, 0x19120000 is hex search for '00 00 12 19'
Each ig-platform-id is 184 bytes (in this kext and KBL).
It helps to expand the Hex Fiend window to 23 columns (need a big screen, 184/4/2=23), because then you can see each ig-platform-id lined up vertically (every other row).
You will find the table starts with 0x191e0000 and the last is 0x19260007. The 0xFFFFFFFF signifies the end of table.

These are all the ig-platform-id? I tried to find 0x59230000 as 00 00 23 59 but there isn't... It should be a valid ig-platform-id because @zhangguancai use it...
Should my ig-platform-id be like 0x59xxxxxx (as I saw every kabylake ig-platform-id are similar) or it can be different like 0x19xxxxxx?
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
186,727
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
These are all the ig-platform-id? I tried to find 0x59230000 as 00 00 23 59 but there isn't... It should be a valid ig-platform-id because @zhangguancai use it...
Should my ig-platform-id be like 0x59xxxxxx (as I saw every kabylake ig-platform-id are similar) or it can be different like 0x19xxxxxx?

0x59230000 is not a valid ig-platform-id.
 
Joined
Jan 9, 2016
Messages
219
Motherboard
Cube mix plus
CPU
M3-7y30
Graphics
HD 615, 1920 × 1080
0x59230000 is not a valid ig-platform-id.

I forgot to enable set dvmt to 64m on bios, so it was not working... For the ig-platform-id 0x59230000 I'm using it right now and it seems to work good, so I think that is valid...
For the thread I set it as solved because @zhangguangcai sent me a clover folder with hotpatch and it works very good...
I had only two last questions:
-as Intel Bluetooth is native on osx I can use it without kext but I can't disable the Bluetooth, is there a way to enable the switch? (I googled it but no response to this question because I all the threads speak about Broadcom Bluetooth and not Intel one...
-I tried to open iTunes and set my account but it says I need to wait 90 days to download/stream my music because my computer has had another account on it (it is a random serial number so I don't think I got an used serial number), is there a fix for that?
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
23,688
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
I forgot to enable set dvmt to 64m on bios, so it was not working... For the ig-platform-id 0x59230000 I'm using it right now and it seems to work good, so I think that is valid...
For the thread I set it as solved because @zhangguangcai sent me a clover folder with hotpatch and it works very good...
I had only two last questions:
-as Intel Bluetooth is native on osx I can use it without kext but I can't disable the Bluetooth, is there a way to enable the switch? (I googled it but no response to this question because I all the threads speak about Broadcom Bluetooth and not Intel one...
-I tried to open iTunes and set my account but it says I need to wait 90 days to download/stream my music because my computer has had another account on it (it is a random serial number so I don't think I got an used serial number), is there a fix for that?
you won't be able to turn off intel bluetooth
 
Status
Not open for further replies.
Top