Contribute
Register

[SOLVED]Patched AppleHDA for 10.8.3?

Joined
Nov 24, 2012
Messages
13
Motherboard
Gigabyte GA-H61N-USB3
CPU
Intel Core i3
Graphics
Intel HD3000
Mac
Classic Mac
Mobile Phone
iOS
Hi guys,

I'm again having trouble to enable my HDMI audio. In 10.8.2 I got it with the AppleHDA from here
http://tonymacx86.blogspot.de/2011/09/hdmi-audio-solutions-intel-hd-3000.html

But now I just can enable the ALC889 with Multibeast. But I need HDMI. In DPCI Manager two audio devices are shown. ALC889 and HD3000 HDMI. So how can I enable the HD 3000 audio? I'm using GA-H61N-USB 3 and Intel Core i3. Of course I use the DSDT from the Database.

vicquick
 

beelzebozo

Super Moderator
Joined
Mar 31, 2010
Messages
3,820
Motherboard
Main Build: ASUS z170-Deluxe
CPU
i7 - 6700K
Graphics
AMD Radeon RX 5700 XT
Mac
iMac
Classic Mac
Power Mac
Mobile Phone
iOS
Patched AppleHDA for 10.8.3?

Hi guys,

I'm again having trouble to enable my HDMI audio. In 10.8.2 I got it with the AppleHDA from here
http://tonymacx86.blogspot.de/2011/09/hdmi-audio-solutions-intel-hd-3000.html

But now I just can enable the ALC889 with Multibeast. But I need HDMI. In DPCI Manager two audio devices are shown. ALC889 and HD3000 HDMI. So how can I enable the HD 3000 audio? I'm using GA-H61N-USB 3 and Intel Core i3. Of course I use the DSDT from the Database.

vicquick
You'll need to run the latest MultiBeast for OS X Mountain Lion again and choose the same audio kext.
 

toleda

Moderator
Joined
May 20, 2010
Messages
24,260
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
iMac, MacBook Pro, Mac mini
Classic Mac
512K, LC, Power Mac
Mobile Phone
iOS
Joined
Nov 24, 2012
Messages
13
Motherboard
Gigabyte GA-H61N-USB3
CPU
Intel Core i3
Graphics
Intel HD3000
Mac
Classic Mac
Mobile Phone
iOS
Patched AppleHDA for 10.8.3?

Mountain Lion Audio IDs changed from Lion. See 2b. Mountain Lion AppleHDA.kext, Post #2, Official CustoMac Mini 2011 Guide and Notes (in progress). DSDT/HDEF/layout-id edit required.
What exactly do I have to do? Should I download the attached DSDT (F8) in the Link and install UserDSDT and ALC889 in Multibeast again?

thanks
vicquick

EDIT: I got it!!! Everything works fine! Thank you very much toleda!
 
Joined
Nov 18, 2011
Messages
50
Motherboard
Gigabyte Z490M Gaming X / GA-H67N-USB3-B3
CPU
intel i7-10700 / intel i3-2105
Graphics
built in
Yes, how did you get this working? I had it working up through 10.8.2. I have the other motherboard (H67) but I downloaded the dsdt with hdmi audio for my motherboard, renamed dsdt.aml as before, ran multibeast as userdsdt, and installed realtek889. Everything works as usual but I have lost hdmi audio. Everything is the same as before, so something changed in the update. Is there something else we can do to fix this issue? Thanks.


What exactly do I have to do? Should I download the attached DSDT (F8) in the Link and install UserDSDT and ALC889 in Multibeast again?

thanks
vicquick

EDIT: I got it!!! Everything works fine! Thank you very much toleda!
 
Joined
Nov 18, 2011
Messages
50
Motherboard
Gigabyte Z490M Gaming X / GA-H67N-USB3-B3
CPU
intel i7-10700 / intel i3-2105
Graphics
built in
There was no need to update the dsdt. Read Post #3 in this thread. Edit dsdt/HDEF/layout-id as documented.
Thank you for the reply. I tried with HDEF layout 1, then I read that I should use layout 3, so I did so. I verified the edits were 0x03, 0x00, 0x00, 0x00 in the DSDT with HDMI F9 file you attached to this thread, which is the build I have. http://www.tonymacx86.com/lion-desk...-customac-mini-2011-guide-notes-progress.html.

Everything still works perfectly except for HDMI audio, which was working in 10.8.2. I really didn't need to update, so if these don't work I will simply backup and reinstall to 10.8.2. I've never had any issue with HDMI audio before, even in 10.8.2. (ps- obviously using HDMI port under USB ports)

I've attached my DSDT and a copy of the IOReg backup. Any help would be appreciated.
 

Attachments

toleda

Moderator
Joined
May 20, 2010
Messages
24,260
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
iMac, MacBook Pro, Mac mini
Classic Mac
512K, LC, Power Mac
Mobile Phone
iOS
Everything still works perfectly except for HDMI audio, which was working in 10.8.2.
The dsdt/HDEF edit is not correct. Download the HDMI F9 dsdt again. Edit one line:
From
0x85, 0x01, 0x00, 0x00
To
0x03, 0x00, 0x00, 0x00
Compile and install.

Delete S/L/E/HDAEnabler1.kext, fix permissions and cache. Restart. Reply with a copy of IOReg.
 
Joined
Nov 18, 2011
Messages
50
Motherboard
Gigabyte Z490M Gaming X / GA-H67N-USB3-B3
CPU
intel i7-10700 / intel i3-2105
Graphics
built in
Awesome! This worked perfectly. Thank you so much for taking the time to help. I learned a lot and now I understand how these changes affect the system. Hopefully I'll be able to help some others also...thanks again!

The dsdt/HDEF edit is not correct. Download the HDMI F9 dsdt again. Edit one line:
From
0x85, 0x01, 0x00, 0x00
To
0x03, 0x00, 0x00, 0x00
Compile and install.

Delete S/L/E/HDAEnabler1.kext, fix permissions and cache. Restart. Reply with a copy of IOReg.
 
Top