Contribute
Register

[Solved] Only getting 256mb of VRAM from my GTX1080 on 10.12.6

Status
Not open for further replies.
Joined
Nov 14, 2016
Messages
4
Motherboard
MSI Z77A-G41
CPU
i5-3570k
Graphics
GTX1080
So I recently converted my main build to a hackintosh, however, I cannot get my system to read all 8gb of my GTX1080. It only sees 256mb. I have tried installing the web drivers manually, changing my system definition (currently using iMac late 2012). I have tried adding Lilu and NvidiaGraphicsFixu kexts into my Clover install and my Emuvariableuefi-64 driver has been added as well. I have also made sure that nv_disable isn't set and that WebDriver is set to true in my .plist file. However, I still can only see 256mb of VRAM. I have a thread on ****** (I will link at the bottom for a working history), however, they told me my best bet might be to start a thread here. If anyone has any ideas it would be greatly appreciated.

CPU - i5-3570k
MoBo - MSI Z77A-G41
Ram - 16gb
GPU - GTX1080
OS - Currently on Sierra (10.12.6)

****** thread - https://www.******.com/r/hackintosh/comments/76qhrl/osx_only_sees_gtx1080_as_256mb/

Again, I am out of ideas and really want to figure out how to get this working. If anyone has any ideas I am all ears.
 

P1LGRIM

Moderator
Joined
Mar 2, 2012
Messages
26,074
Motherboard
Lenovo ThinkStation p700
CPU
2x E5-2620 V3
Graphics
RX 560
Mac
  1. MacBook Pro
  2. Mac mini
Classic Mac
  1. Power Mac
Mobile Phone
  1. iOS
The Rules said:
Profiles need to contain at least your primary system to assist others with helping you
Ensure that your integrated graphics are disabled in your BIOS settings and that you are not injecting Intel graphics in your config.plist.
 
Joined
Nov 14, 2016
Messages
4
Motherboard
MSI Z77A-G41
CPU
i5-3570k
Graphics
GTX1080
Ensure that your integrated graphics are disabled in your BIOS settings and that you are not injecting Intel graphics in your config.plist.
My apologies. I though that meant my Mobo/CPU and stuff in my post. I have updated my profile.

Also, I will be sure to check my BIOS when I get home.

Thanks!

edit- I can't read sometimes
 
Last edited:
Joined
Sep 25, 2012
Messages
1,321
Motherboard
Asus Z270 Maximus IX HERO
CPU
i7-7700K
Graphics
GTX 1080 Ti
Mac
  1. Mac Pro
Mobile Phone
  1. iOS
Ensure that your integrated graphics are disabled in your BIOS settings and that you are not injecting Intel graphics in your config.plist.

I have these both ON in order to fix the iBooks clear window issue, even though I've got no monitor plugged in the IGP connector.
 
Joined
Nov 14, 2016
Messages
4
Motherboard
MSI Z77A-G41
CPU
i5-3570k
Graphics
GTX1080
Ok, everyone here gets permission to slap me if ever they meet me. Apparently, I checked the "inject Nvidia" box while making my unibeast installer (totally forgot that I did this). Disabling that with CC fixed the issue and all 8gb are now showing up in "About this Mac". Thank you all for you help.
 
Joined
Sep 25, 2012
Messages
1,321
Motherboard
Asus Z270 Maximus IX HERO
CPU
i7-7700K
Graphics
GTX 1080 Ti
Mac
  1. Mac Pro
Mobile Phone
  1. iOS
Joined
Apr 4, 2017
Messages
1,131
Motherboard
ASUS Z270 ROG MAXIMUS IX HERO
CPU
i7-7700K
Graphics
Vega 64
Mac
  1. iMac
Mobile Phone
  1. iOS
NOTE: The latest Lilu + NVidiaGraphicsFixup.kext implements NVidiaWebDriverLibVal.kext, rendering the latter obsolete.
 
Joined
Sep 25, 2012
Messages
1,321
Motherboard
Asus Z270 Maximus IX HERO
CPU
i7-7700K
Graphics
GTX 1080 Ti
Mac
  1. Mac Pro
Mobile Phone
  1. iOS
NOTE: The latest Lilu + NVidiaGraphicsFixup.kext implements NVidiaWebDriverLibVal.kext, rendering the latter obsolete.
Will this also install a ceiling fan??? :mrgreen:
 
Status
Not open for further replies.
Top