Contribute
Register

(solved) NVME on 10.12.1 (Samsung 951)

Status
Not open for further replies.
Joined
Jun 21, 2010
Messages
269
Motherboard
Gigabyte Z490 Aorus Elite AC-F22 OC 0.8.2
CPU
i7-11700K
Graphics
RX 580
Mac
  1. MacBook Air
Classic Mac
  1. iMac
Mobile Phone
  1. Android
  2. iOS
Using HackrNVMeFamily.kext via the patch from RehabMan https://github.com/RehabMan/patch-nvme
works very well with 10.12.0 but not on the .1 update.
Tried in in different ways but no chance but crashes (I know that the chance was low).
Strange: The original IONVMeFamily.kext from 10.12.0 and 10.12.1 have the same version number 2.1.0 but differ in size and built date.
I know that I have to wait until RehabMan finds a way to patch IONVMeFamily.kext in 10.12.1 too.
But maybe somebody knows a side way so I can update to 10.12.1 before that happens.
The Samsung SSD (MZVPV256HDGL) is the system disk.
 
Last edited:

RehabMan

Moderator
Joined
May 2, 2012
Messages
183,827
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Using HackrNVMeFamily.kext via the patch from RehabMan https://github.com/RehabMan/patch-nvme
works very well with 10.12.0 but not on the .1 update.
Tried in in different ways but no chance but crahes (I know that the chance was low).
Strange: The original IONVMeFamily.kext from 10.12.0 and 10.12.1 have the same version number 2.1.0 but differ in size and built date.
I know that I have to wait until RehabMan finds a way to patch IONVMeFamily.kext in 10.12.1 too.
But maybe somebody knows a side way so I can update to 10.12.1 before that happens.
The Samsung SSD (MZVPV256HDGL) is the system disk.

Use an older version of HackrNMVeFamily (eg. for 10.12.0).
 
Joined
Jun 21, 2010
Messages
269
Motherboard
Gigabyte Z490 Aorus Elite AC-F22 OC 0.8.2
CPU
i7-11700K
Graphics
RX 580
Mac
  1. MacBook Air
Classic Mac
  1. iMac
Mobile Phone
  1. Android
  2. iOS
Use an older version of HackrNMVeFamily (eg. for 10.12.0).
I tried it with the one built from 10.12.0 (wich works perfectly under 10.12.0) but it crahes under 10.12.1 and the system is rebooting. No matter if I delete IONvmefamily.kext or not from /L/E.
It even cahes if I boot from an external SSD with installed 10.12.1 if HackrNMVeFamily.kext is installed in EFI/Clover/kexts/other.
 

Stork

Admin
Staff member
Joined
Sep 21, 2010
Messages
13,208
Motherboard
Gigabyte Z690 Aero G
CPU
i5-12600K
Graphics
RX 6800 XT
Mac
  1. MacBook Pro
  2. Mac mini
  3. Mac Pro
Classic Mac
  1. Power Mac
  2. PowerBook
Mobile Phone
  1. iOS
My 10.12.0 HackrNVMeFamily.kext is working with 10.12.1. I just removed the updated 10.12.1 IONVMeFamily.kext after the update and rebooted w/o caches.
 
Joined
Jun 21, 2010
Messages
269
Motherboard
Gigabyte Z490 Aorus Elite AC-F22 OC 0.8.2
CPU
i7-11700K
Graphics
RX 580
Mac
  1. MacBook Air
Classic Mac
  1. iMac
Mobile Phone
  1. Android
  2. iOS
okay, thank you, I'll give it a try w/o caches.
 

RehabMan

Moderator
Joined
May 2, 2012
Messages
183,827
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
I tried it with the one built from 10.12.0 (wich works perfectly under 10.12.0) but it crahes under 10.12.1 and the system is rebooting. No matter if I delete IONvmefamily.kext or not from /L/E.
It even cahes if I boot from an external SSD with installed 10.12.1 if HackrNMVeFamily.kext is installed in EFI/Clover/kexts/other.

IONVMeFamily.kext is in /S/L/E, not /L/E.
 
Joined
Jun 21, 2010
Messages
269
Motherboard
Gigabyte Z490 Aorus Elite AC-F22 OC 0.8.2
CPU
i7-11700K
Graphics
RX 580
Mac
  1. MacBook Air
Classic Mac
  1. iMac
Mobile Phone
  1. Android
  2. iOS
IONVMeFamily.kext is in /S/L/E, not /L/E.
Yes, you are right.
And it was my fault: When I deleted IONVMeFamily.kext from S/L/E I accidentially only moved it to the desktop - not realizing that this was just a copy because of a system folder. After deleting it now de facto it work instantly after a reboot.
Then I was able to update my NVMe SSD to 10.12.1, deleting IONVMeFamily.kext (this time actually), restart and install ob nVidia webdriver all is working as it should - even sound is still working...
Thank you RehabMan and Stork!
 
Joined
Jul 25, 2013
Messages
2
Mac
Classic Mac
Mobile Phone
May i ask what is S/L/E. i got to installer and 950 Pro not show up. Try to follow all step but alway a step away to get it. Been working around with it almost a week.
 
Joined
Jun 21, 2010
Messages
269
Motherboard
Gigabyte Z490 Aorus Elite AC-F22 OC 0.8.2
CPU
i7-11700K
Graphics
RX 580
Mac
  1. MacBook Air
Classic Mac
  1. iMac
Mobile Phone
  1. Android
  2. iOS
system/library/extension
 
Status
Not open for further replies.
Top